summaryrefslogtreecommitdiff
path: root/games-misc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
commit71deace00d1a2b091313fe137ab7092418c6f87c (patch)
tree9f1f0dee23e13658e52f49437befe78427148c51 /games-misc
parent29aabba0ea759c6a2864ff5631735b67ee38e5e0 (diff)
gentoo resync : 10.02.2020
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/Manifest.gzbin12151 -> 12153 bytes
-rw-r--r--games-misc/openmsx/Manifest2
-rw-r--r--games-misc/openmsx/files/openmsx-0.3.1-python3.patch306
-rw-r--r--games-misc/openmsx/openmsx-0.3.1-r3.ebuild37
4 files changed, 345 insertions, 0 deletions
diff --git a/games-misc/Manifest.gz b/games-misc/Manifest.gz
index 5ff4532dcc04..9cb3400f5ef7 100644
--- a/games-misc/Manifest.gz
+++ b/games-misc/Manifest.gz
Binary files differ
diff --git a/games-misc/openmsx/Manifest b/games-misc/openmsx/Manifest
index 274e584c6ce3..fac3e02934f9 100644
--- a/games-misc/openmsx/Manifest
+++ b/games-misc/openmsx/Manifest
@@ -1,3 +1,5 @@
+AUX openmsx-0.3.1-python3.patch 8650 BLAKE2B 8a26d10fcac16895ad0db10c242aee0be00dbfd3071d909af7f0bdeb1a9ff289bbd51f4861d5cb171128bb857e5ee4d62b0994724dfa1aa228c5c444522ef477 SHA512 d454d982df8f6b6e07f588c6a8b4a3e8e7053f9a8ad6906a83d25f163caf744225e56754d3871b76efd7d2e432c01badd1e3371758dcd7bf4f8ff88b61d8c0a7
DIST openmsx-0.3.1-source.tar.gz 152798 BLAKE2B 8c6d757b708bf5af9312318d13bf99b7326ed3cf82d158c4e639e04eab5c722d76976820a6a8913cef93246225578fcbd598afde11f09cdadc47d626d977d947 SHA512 e455f99f32d1daa77157def4f109dd1456169ae2b527290035b6a52f591c13fb7464fd221e00eb46bf03f51e8d0101de08a9e47cebe2430ad05a840ab235973e
EBUILD openmsx-0.3.1-r2.ebuild 702 BLAKE2B 464524bf487c6a872ed156d2275088160279c7ec874b2a968c240485ac67270f454d983e652d43aafd942cfde1be67e93090fbe33d72221230dcb2dd4e901c0f SHA512 86565b559cb611d4b6d1fa235e3f7d5fb6327d242a8de44cda7b3d4f1246e2393d4c7026a49831fb9266ba09c4d7f1bdbf72215b8c7d7cdaacf971b7c346774e
+EBUILD openmsx-0.3.1-r3.ebuild 756 BLAKE2B 7e9aa4fd5390dc133a79af2d87e9965cd42b9567f5cba1cfb1860365ae6ed55fd65e274c4a9ddef2a31b6426af9069e76f7324c99dc4c70c91dbfb874e31bd29 SHA512 a564c7c35e634210f21a4b5f85ba89f607077ecfac065e3b1beb8d3cf721aaf0d87c6f13e41c0b470e1b4dccef59da8d7202304c32b759dfc35e64363397a5c0
MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-misc/openmsx/files/openmsx-0.3.1-python3.patch b/games-misc/openmsx/files/openmsx-0.3.1-python3.patch
new file mode 100644
index 000000000000..0e8a44a5ec3d
--- /dev/null
+++ b/games-misc/openmsx/files/openmsx-0.3.1-python3.patch
@@ -0,0 +1,306 @@
+From 7b298b1bacc56392b9a19ba6b95d368309832ad7 Mon Sep 17 00:00:00 2001
+From: Stefan Strogin <steils@gentoo.org>
+Date: Fri, 7 Feb 2020 13:15:16 +0200
+Subject: [PATCH] Fix: support Python 3
+
+Correct tabs and spaces in scripts to make them consistent.
+Don't call deprecated methods.
+
+Upstream-Status: Submitted [https://github.com/OpenTTD/OpenMSX/pull/2]
+Signed-off-by: Stefan Strogin <steils@gentoo.org>
+---
+ scripts/authorlist.py | 20 ++++++++---------
+ scripts/md5list.py | 48 ++++++++++++++++++++--------------------
+ scripts/midifiles.py | 30 ++++++++++++-------------
+ scripts/namelist.py | 34 ++++++++++++++--------------
+ scripts/playlist.py | 42 +++++++++++++++++------------------
+ scripts/sanitize_list.py | 48 ++++++++++++++++++++--------------------
+ 6 files changed, 111 insertions(+), 111 deletions(-)
+
+diff --git a/scripts/authorlist.py b/scripts/authorlist.py
+index 689ddb9..e041d64 100755
+--- a/scripts/authorlist.py
++++ b/scripts/authorlist.py
+@@ -14,14 +14,14 @@ import string
+ import sys
+
+ while 1:
+- data = sys.stdin.readline()
+- if data != '':
+- # do some processing of the contents of
+- # the data variable
+- separate = string.split(data,";")
+- print '%-30s %s' % (separate[1]+":", separate[2])
+- # end of data processing command group
++ data = sys.stdin.readline()
++ if data != '':
++ # do some processing of the contents of
++ # the data variable
++ separate = data.split(';')
++ print('%-30s %s' % (separate[1]+":", separate[2]))
++ # end of data processing command group
+ # sys.stdout.write(res)
+- else:
+- sys.stdout.flush()
+- break
++ else:
++ sys.stdout.flush()
++ break
+diff --git a/scripts/md5list.py b/scripts/md5list.py
+index cf611fc..a60f977 100755
+--- a/scripts/md5list.py
++++ b/scripts/md5list.py
+@@ -16,28 +16,28 @@ import subprocess
+ import os
+
+ while 1:
+- data = sys.stdin.readline()
+- if data != '':
+- # leave out all comment lines (lines starting with '#')
+- comment_pos = string.find(data,'#')
+- if comment_pos == 0:
+- continue
+- # separate the single entries by ';'
+- separate = string.split(data,";")
+- if len(separate) != 4:
+- continue
+- systemtype = (os.uname())[0]
+- if systemtype == 'Linux':
+- md5call = ["md5sum"]
+- elif systemtype == 'Darwin':
+- md5call = ["md5", "-r"]
++ data = sys.stdin.readline()
++ if data != '':
++ # leave out all comment lines (lines starting with '#')
++ comment_pos = data.find('#')
++ if comment_pos == 0:
++ continue
++ # separate the single entries by ';'
++ separate = data.split(';')
++ if len(separate) != 4:
++ continue
++ systemtype = (os.uname())[0]
++ if systemtype == 'Linux':
++ md5call = ["md5sum"]
++ elif systemtype == 'Darwin':
++ md5call = ["md5", "-r"]
++ else:
++ md5call = ["md5sum"]
++ md5call = md5call + ["src/"+separate[1].strip()]
++ md5sum = subprocess.Popen(md5call, stdout=subprocess.PIPE).communicate()[0]
++ md5sum = md5sum.split()
++ res = "%-32s = %s\n" % (separate[1], md5sum[0])
++ sys.stdout.write(res)
+ else:
+- md5call = ["md5sum"]
+- md5call = md5call + ["src/"+string.strip(separate[1])]
+- md5sum = subprocess.Popen(md5call, stdout=subprocess.PIPE).communicate()[0]
+- md5sum = string.split(md5sum)
+- res = "%-32s = %s\n" % (separate[1], md5sum[0])
+- sys.stdout.write(res)
+- else:
+- sys.stdout.flush()
+- break
++ sys.stdout.flush()
++ break
+diff --git a/scripts/midifiles.py b/scripts/midifiles.py
+index 3b5ec57..a89e4f2 100755
+--- a/scripts/midifiles.py
++++ b/scripts/midifiles.py
+@@ -15,18 +15,18 @@ import sys
+
+ res = ""
+ while 1:
+- data = sys.stdin.readline()
+- if data != '':
+- # leave out all comment lines (lines starting with '#')
+- comment_pos = string.find(data,'#')
+- if comment_pos == 0:
+- continue
+- # separate the single entries by ';'
+- separate = string.split(data,";")
+- if len(separate) != 4:
+- continue
+- res = res + " src/" + string.strip(separate[1])
+- else:
+- sys.stdout.write(res)
+- sys.stdout.flush()
+- break
++ data = sys.stdin.readline()
++ if data != '':
++ # leave out all comment lines (lines starting with '#')
++ comment_pos = data.find('#')
++ if comment_pos == 0:
++ continue
++ # separate the single entries by ';'
++ separate = data.split(';')
++ if len(separate) != 4:
++ continue
++ res = res + " src/" + separate[1].strip()
++ else:
++ sys.stdout.write(res)
++ sys.stdout.flush()
++ break
+diff --git a/scripts/namelist.py b/scripts/namelist.py
+index cdac127..107ad00 100755
+--- a/scripts/namelist.py
++++ b/scripts/namelist.py
+@@ -14,23 +14,23 @@ import string
+ import sys
+
+ while 1:
+- data = sys.stdin.readline()
+- if data != '':
+- # leave out all comment lines (lines starting with '#')
+- comment_pos = string.find(data,'#')
+- if comment_pos == 0:
+- continue
+- # separate the single entries by ';'
+- separate = string.split(data,";")
+- if len(separate) != 4:
+- continue
+- res = "%-32s = %s\n" % (separate[1], string.strip(separate[3]))
+- sys.stdout.write(res)
+- else:
+- sys.stdout.flush()
+- break
++ data = sys.stdin.readline()
++ if data != '':
++ # leave out all comment lines (lines starting with '#')
++ comment_pos = data.find('#')
++ if comment_pos == 0:
++ continue
++ # separate the single entries by ';'
++ separate = data.split(';')
++ if len(separate) != 4:
++ continue
++ res = "%-32s = %s\n" % (separate[1], separate[3].strip())
++ sys.stdout.write(res)
++ else:
++ sys.stdout.flush()
++ break
+
+ def authorlist(mystr):
+- separate = string.split()
++ separate = separate.split()
+ for str in separate:
+- print string.strip(str)
+\ No newline at end of file
++ print(str.strip())
+diff --git a/scripts/playlist.py b/scripts/playlist.py
+index 939d03d..e77b02a 100755
+--- a/scripts/playlist.py
++++ b/scripts/playlist.py
+@@ -14,27 +14,27 @@ import string
+ import sys
+
+ while 1:
+- data = sys.stdin.readline()
+- if data != '':
+- # leave out all comment lines (lines starting with '#')
+- comment_pos = string.find(data,'#')
+- if comment_pos == 0:
+- continue
+- # separate the single entries by ';'
+- separate = string.split(data,";")
+- res = ""
+- # leave out all lines which don't have the proper number of elements
+- if len(separate) >= 1:
+- res = string.strip(separate[0]) + " = "
+- if len(separate) == 4:
+- res = res + separate[1]
+- res = res + "\n"
+- sys.stdout.write(res)
+- else:
+- sys.stdout.flush()
+- break
++ data = sys.stdin.readline()
++ if data != '':
++ # leave out all comment lines (lines starting with '#')
++ comment_pos = data.find('#')
++ if comment_pos == 0:
++ continue
++ # separate the single entries by ';'
++ separate = data.split(';')
++ res = ""
++ # leave out all lines which don't have the proper number of elements
++ if len(separate) >= 1:
++ res = separate[0].strip() + " = "
++ if len(separate) == 4:
++ res = res + separate[1]
++ res = res + "\n"
++ sys.stdout.write(res)
++ else:
++ sys.stdout.flush()
++ break
+
+ def authorlist(mystr):
+- separate = string.split()
++ separate = separate.split()
+ for str in separate:
+- print string.strip(str)
+\ No newline at end of file
++ print(str.strip())
+diff --git a/scripts/sanitize_list.py b/scripts/sanitize_list.py
+index f97709a..5368831 100755
+--- a/scripts/sanitize_list.py
++++ b/scripts/sanitize_list.py
+@@ -14,30 +14,30 @@ import string
+ import sys
+
+ while 1:
+- data = sys.stdin.readline()
+- if data != '':
+- # leave out all comment lines (lines starting with '#')
+- comment_pos = string.find(data,'#')
+- if comment_pos == 0:
+- continue
+- # separate the single entries by ';'
+- separate = string.split(data,";")
+- if len(separate) != 4:
+- continue
+- res = ""
+- for str in separate:
+- if res != '':
+- res = res + ";" + string.strip(str)
+- else:
+- res = string.strip(str)
+- # end of data processing command group
+- res = res + "\n"
+- sys.stdout.write(res)
+- else:
+- sys.stdout.flush()
+- break
++ data = sys.stdin.readline()
++ if data != '':
++ # leave out all comment lines (lines starting with '#')
++ comment_pos = data.find('#')
++ if comment_pos == 0:
++ continue
++ # separate the single entries by ';'
++ separate = data.split(';')
++ if len(separate) != 4:
++ continue
++ res = ""
++ for str in separate:
++ if res != '':
++ res = res + ";" + str.strip()
++ else:
++ res = str.strip()
++ # end of data processing command group
++ res = res + "\n"
++ sys.stdout.write(res)
++ else:
++ sys.stdout.flush()
++ break
+
+ def authorlist(mystr):
+- separate = string.split()
++ separate = separate.split()
+ for str in separate:
+- print string.strip(str)
+\ No newline at end of file
++ print(str.strip())
+--
+2.25.0
+
diff --git a/games-misc/openmsx/openmsx-0.3.1-r3.ebuild b/games-misc/openmsx/openmsx-0.3.1-r3.ebuild
new file mode 100644
index 000000000000..256776545d93
--- /dev/null
+++ b/games-misc/openmsx/openmsx-0.3.1-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit python-any-r1
+
+DESCRIPTION="Open source music base set for OpenTTD"
+HOMEPAGE="https://wiki.openttd.org/OpenMSX https://github.com/OpenTTD/OpenMSX"
+SRC_URI="https://cdn.openttd.org/openmsx-releases/${PV}/${P}-source.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+
+S=${WORKDIR}/${P}-source
+
+PATCHES=( "${FILESDIR}"/${P}-python3.patch )
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_compile() {
+ emake _V= bundle
+}
+
+src_install() {
+ insinto "/usr/share/games/openttd/gm/${P}"
+ doins ${P}/{*.mid,openmsx.obm}
+ dodoc ${P}/{changelog.txt,readme.txt}
+}