summaryrefslogtreecommitdiff
path: root/games-misc/sdljoytest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-misc/sdljoytest
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-misc/sdljoytest')
-rw-r--r--games-misc/sdljoytest/Manifest3
-rw-r--r--games-misc/sdljoytest/metadata.xml11
-rw-r--r--games-misc/sdljoytest/sdljoytest-11102003.ebuild41
3 files changed, 55 insertions, 0 deletions
diff --git a/games-misc/sdljoytest/Manifest b/games-misc/sdljoytest/Manifest
new file mode 100644
index 000000000000..5a65deded699
--- /dev/null
+++ b/games-misc/sdljoytest/Manifest
@@ -0,0 +1,3 @@
+DIST SDLJoytest-GL-11102003.tar.bz2 85997 BLAKE2B 23ae410c462d9501306d6e225d2523ef940dd3f3e6ab7c898313a25253f86c42d3c0c7d64385a0c6de06331ca68ddc49296cea572f0a1f42161a912e8ff3274d SHA512 4994e878eaacacb156d4d9988d1e7864ed4e5e3d4db6bc0be8a883d7edde87d56698eb22de5d39e2110be7f960e5bf080283a7563bb2bc3f17c390181e097c6a
+EBUILD sdljoytest-11102003.ebuild 872 BLAKE2B cc1368cb30bfc1f7c938a4df493d5819dace93a031cb5db50762cfac49f0d540d5e1059fd37af3da0331a4a7ea406a8e02cff458ab16bd8b8e7ddb5941347744 SHA512 4b16ec9ed12bc139dd4876459528fe8cb1c27c299315297c720015c008d9d3bcf68428b2acbb3856d13abfabb236b776247952266df682c231666274cd8322b9
+MISC metadata.xml 333 BLAKE2B 5eadf19507a2a63c03c3457ae2efec7cbc5a2b6abc8d323c7f38510f639b795e56d1e83e7ead78c1d3930317e712d6536cdc5453c84bc66573ea7c5963f63f58 SHA512 f3c36c935fc927fa6ccf4402f67ec8d213fd94c2bf5855b4f1e6852c3c2c32fa051998cda971050c7f2f3257dc4102369c0af8d5d386ecb2a1e4d2ab177217d9
diff --git a/games-misc/sdljoytest/metadata.xml b/games-misc/sdljoytest/metadata.xml
new file mode 100644
index 000000000000..9a85b3b89d73
--- /dev/null
+++ b/games-misc/sdljoytest/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">sdljoytest</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-misc/sdljoytest/sdljoytest-11102003.ebuild b/games-misc/sdljoytest/sdljoytest-11102003.ebuild
new file mode 100644
index 000000000000..905eb1487338
--- /dev/null
+++ b/games-misc/sdljoytest/sdljoytest-11102003.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="SDL app to test joysticks and game controllers"
+HOMEPAGE="http://sdljoytest.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sdljoytest/SDLJoytest-GL-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[joystick,opengl,video]
+ virtual/opengl
+ media-libs/sdl-image"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/SDLJoytest-GL
+
+src_prepare() {
+ emake clean
+ sed -i -e 's:/usr/local:/usr:' joytest.h || die
+ sed -i -e 's:SDL/::' *.c || die
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ CFLAGS="$(sdl-config --cflags) ${CFLAGS}" \
+ LDFLAGS="$(sdl-config --libs) -lGL ${LDFLAGS}"
+}
+
+src_install() {
+ dobin SDLJoytest-GL
+ insinto /usr/share/SDLJoytest-GL
+ doins *.bmp
+ doman SDLJoytest.1
+}