summaryrefslogtreecommitdiff
path: root/games-misc/opengfx/opengfx-0.5.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /games-misc/opengfx/opengfx-0.5.5.ebuild
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'games-misc/opengfx/opengfx-0.5.5.ebuild')
-rw-r--r--games-misc/opengfx/opengfx-0.5.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/games-misc/opengfx/opengfx-0.5.5.ebuild b/games-misc/opengfx/opengfx-0.5.5.ebuild
new file mode 100644
index 000000000000..dc39acc0d275
--- /dev/null
+++ b/games-misc/opengfx/opengfx-0.5.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="OpenGFX data files for OpenTTD"
+HOMEPAGE="http://bundles.openttdcoop.org/opengfx/"
+SRC_URI="http://bundles.openttdcoop.org/opengfx/releases/${PV}/${P}-source.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+RESTRICT="test" # nml version affects the checksums that the test uses (bug #451444)
+
+DEPEND=">=games-util/nml-0.4.0
+ games-util/grfcodec"
+RDEPEND=""
+
+S="${WORKDIR}/${P}-source"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.5.5-Makefile.patch"
+)
+
+src_compile() {
+ emake GIMP="" help # print out the env to make bug reports better
+ emake GIMP="" _V="" bundle_tar
+}
+
+src_install() {
+ insinto "/usr/share/games/openttd/data/"
+ doins *.grf opengfx.obg
+ dodoc docs/{changelog.txt,readme.txt}
+}