summaryrefslogtreecommitdiff
path: root/games-misc/opengfx/opengfx-0.5.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-misc/opengfx/opengfx-0.5.4-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-misc/opengfx/opengfx-0.5.4-r1.ebuild')
-rw-r--r--games-misc/opengfx/opengfx-0.5.4-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-misc/opengfx/opengfx-0.5.4-r1.ebuild b/games-misc/opengfx/opengfx-0.5.4-r1.ebuild
new file mode 100644
index 000000000000..72fd656ad797
--- /dev/null
+++ b/games-misc/opengfx/opengfx-0.5.4-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="OpenGFX data files for OpenTTD"
+HOMEPAGE="http://bundles.openttdcoop.org/opengfx/"
+SRC_URI="http://bundles.openttdcoop.org/opengfx/releases/${PV}/${P}-source.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+RESTRICT="test" # nml version affects the checksums that the test uses (bug #451444)
+
+DEPEND=">=games-util/nml-0.4.0
+ games-util/grfcodec"
+RDEPEND=""
+
+S=${WORKDIR}/${P}-source
+
+PATCHES=(
+ "${FILESDIR}/${P}-Makefile.patch"
+)
+
+src_compile() {
+ emake GIMP="" help # print out the env to make bug reports better
+ emake GIMP="" _V="" bundle_tar
+}
+
+src_install() {
+ insinto "/usr/share/games/openttd/data/"
+ doins *.grf opengfx.obg
+ dodoc docs/{changelog.txt,readme.txt}
+}