summaryrefslogtreecommitdiff
path: root/games-misc/lucidlife/lucidlife-0.9.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-misc/lucidlife/lucidlife-0.9.2-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-misc/lucidlife/lucidlife-0.9.2-r1.ebuild')
-rw-r--r--games-misc/lucidlife/lucidlife-0.9.2-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-misc/lucidlife/lucidlife-0.9.2-r1.ebuild b/games-misc/lucidlife/lucidlife-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..33faf6200942
--- /dev/null
+++ b/games-misc/lucidlife/lucidlife-0.9.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="A Conway's Life simulator written in GTK+2 - fork from Gtklife"
+HOMEPAGE="http://gtk-apps.org/content/show.php/LucidLife?content=130867"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gnome-vfs.patch
+ "${FILESDIR}"/${P}-underlink.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+ intltoolize --force --copy --automake || die
+}
+
+src_install() {
+ emake install \
+ desktopdir=/usr/share/applications \
+ pixmapdir=/usr/share/pixmaps \
+ DESTDIR="${D}"
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}