summaryrefslogtreecommitdiff
path: root/games-misc/fortune-mod/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-misc/fortune-mod/files
reinit the tree, so we can have metadata
Diffstat (limited to 'games-misc/fortune-mod/files')
-rw-r--r--games-misc/fortune-mod/files/01_all_fortune_all-fix.patch21
-rw-r--r--games-misc/fortune-mod/files/fortune-mod-1.99.1-gentoo.patch99
2 files changed, 120 insertions, 0 deletions
diff --git a/games-misc/fortune-mod/files/01_all_fortune_all-fix.patch b/games-misc/fortune-mod/files/01_all_fortune_all-fix.patch
new file mode 100644
index 000000000000..b4175ac81bfc
--- /dev/null
+++ b/games-misc/fortune-mod/files/01_all_fortune_all-fix.patch
@@ -0,0 +1,21 @@
+--- fortune/fortune.c.old 2006-03-11 15:33:14.000000000 +0100
++++ fortune/fortune.c 2006-03-11 15:43:16.000000000 +0100
+@@ -974,7 +974,7 @@
+ if (!ret)
+ ret=add_file(percent, fullpathname, NULL, &File_list,
+ &File_tail, NULL);
+- if ( (!ret && fullpathname != locpathname) || strcmp(sp, "all") == 0 )
++ if (!ret && strncmp(fullpathname, locpathname, sizeof(fullpathname)))
+ ret=add_file(percent, locpathname, NULL, &File_list,
+ &File_tail, NULL);
+
+@@ -985,7 +985,8 @@
+ }
+ if (!ret)
+ return FALSE;
+-
++ if (strncmp(fullpathname, locpathname, sizeof(fullpathname)) && strcmp(sp, "all") == 0)
++ add_file(percent, locpathname, NULL, &File_list, &File_tail, NULL);
+ }
+ else
+ if (!add_file(percent, fullpathname, NULL, &File_list,
diff --git a/games-misc/fortune-mod/files/fortune-mod-1.99.1-gentoo.patch b/games-misc/fortune-mod/files/fortune-mod-1.99.1-gentoo.patch
new file mode 100644
index 000000000000..d9b27fb350e5
--- /dev/null
+++ b/games-misc/fortune-mod/files/fortune-mod-1.99.1-gentoo.patch
@@ -0,0 +1,99 @@
+--- fortune-mod-1.99.1/datfiles/Makefile
++++ fortune-mod-1.99.1/datfiles/Makefile
+@@ -58,7 +58,7 @@
+ if [ $(WEB) = 1 ] ; then cd html && $(MAKE) install ; fi
+ for i in $(COOKIES) ; do \
+ install -m 0644 $$i $$i.dat $(COOKIEDIR) || exit $? ; \
+- cp -d $$i.u8 $(COOKIEDIR) ; \
++ cp -P $$i.u8 $(COOKIEDIR) ; \
+ done
+
+ clean:
+--- fortune-mod-1.99.1/datfiles/off/Makefile
++++ fortune-mod-1.99.1/datfiles/off/Makefile
+@@ -38,7 +38,7 @@
+ install -m 0755 -d $(OCOOKIEDIR)
+ for i in $(OCOOKIES) ; \
+ do install -m 0644 $$i $$i.dat $(OCOOKIEDIR) || exit $$? ; \
+- cp -d $$i.u8 $(OCOOKIEDIR) ; \
++ cp -P $$i.u8 $(OCOOKIEDIR) ; \
+ done
+
+ clean:
+--- fortune-mod-1.99.1/Makefile
++++ fortune-mod-1.99.1/Makefile
+@@ -65,8 +65,7 @@
+ RECODELIBS=-lrecode
+
+ DEFINES=-DFORTDIR="\"$(COOKIEDIR)\"" -DOFFDIR="\"$(OCOOKIEDIR)\"" -DLOCFORTDIR="\"$(LOCALDIR)\"" -DLOCOFFDIR="\"$(LOCALODIR)\""
+-CFLAGS=-O2 $(DEFINES) -Wall -fomit-frame-pointer -pipe -fsigned-char
+-LDFLAGS=-s
++CFLAGS += $(DEFINES) -fsigned-char
+
+ # The above flags are used by default; the debug flags are used when make
+ # is called with a debug target, such as 'make debug'
+--- fortune-mod-1.99.1/fortune/fortune.c
++++ fortune-mod-1.99.1/fortune/fortune.c
+@@ -97,7 +97,7 @@
+ #endif /* killing warnings */
+
+ #define PROGRAM_NAME "fortune-mod"
+-#define PROGRAM_VERSION "9708"
++#define PROGRAM_VERSION "1.99.1"
+
+ #ifdef HAVE_STDBOOL_H
+ #include <stdbool.h>
+@@ -256,6 +256,7 @@
+
+ int add_dir(register FILEDESC *);
+
++const char *program_name;
+ char *program_version(void)
+ {
+ static char buf[BUFSIZ];
+@@ -1675,14 +1675,17 @@
+ char *ctype, *crequest;
+ getargs(ac, av);
+
++ program_name = (char *const) av[0];
+ outer = recode_new_outer(true);
+ request = recode_new_request (outer);
+
+ setlocale(LC_ALL,"");
+ ctype = nl_langinfo(CODESET);
+- if(strcmp(ctype,"ANSI_X3.4-1968") == 0)
+- ctype="ISO-8859-1";
+-
++ if (!ctype || !*ctype)
++ ctype="C"; /* revert to C if no valid envvars! */
++ else
++ if(strcmp(ctype,"ANSI_X3.4-1968") == 0)
++ ctype="ISO-8859-1";
+ crequest = malloc(strlen(ctype) + 7 + 1);
+ sprintf(crequest, "UTF-8..%s", ctype);
+ recode_scan_request (request, crequest);
+--- fortune-mod-1.99.1/util/rot.c
++++ fortune-mod-1.99.1/util/rot.c
+@@ -5,10 +5,11 @@
+
+ #include <stdio.h>
+ #include <ctype.h>
++#include <stdlib.h>
+
+ int main(void)
+ {
+- char a, b;
++ short int a, b;
+
+ while ((a = getchar()) != EOF)
+ {
+--- fortune-mod-1.99.1/util/unstr.c
++++ fortune-mod-1.99.1/util/unstr.c
+@@ -96,6 +96,7 @@
+ #include <string.h>
+ #include <unistd.h>
+
++#include <stdlib.h>
+ #ifndef MAXPATHLEN
+ #define MAXPATHLEN 1024
+ #endif /* MAXPATHLEN */