summaryrefslogtreecommitdiff
path: root/games-kids
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /games-kids
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'games-kids')
-rw-r--r--games-kids/Manifest.gzbin1554 -> 1554 bytes
-rw-r--r--games-kids/gcompris/Manifest4
-rw-r--r--games-kids/gcompris/gcompris-0.97.ebuild50
-rw-r--r--games-kids/gcompris/metadata.xml5
-rw-r--r--games-kids/tuxtype/Manifest7
-rw-r--r--games-kids/tuxtype/files/tuxtype-1.8.3-games-group.patch11
-rw-r--r--games-kids/tuxtype/metadata.xml3
-rw-r--r--games-kids/tuxtype/tuxtype-1.8.1-r1.ebuild43
-rw-r--r--games-kids/tuxtype/tuxtype-1.8.3-r1.ebuild63
9 files changed, 138 insertions, 48 deletions
diff --git a/games-kids/Manifest.gz b/games-kids/Manifest.gz
index b459320adebd..11edf31a7b6c 100644
--- a/games-kids/Manifest.gz
+++ b/games-kids/Manifest.gz
Binary files differ
diff --git a/games-kids/gcompris/Manifest b/games-kids/gcompris/Manifest
index e071a6474ae9..85b9e10a2693 100644
--- a/games-kids/gcompris/Manifest
+++ b/games-kids/gcompris/Manifest
@@ -1,3 +1,5 @@
DIST gcompris-qt-0.96.tar.xz 73221940 BLAKE2B e6d81d1630d962709a1ab27c8735ac42ce67182440f3e78a7d3f39b59b28617211dddf3f6d62a323ee5af7f147e2dc784ff0b305bee7b345d1e59d3ed576ef1a SHA512 980bac743d786d3b35c28cec90bd785d568177c9299f5460918124d111565609fbcd35ec76412776151f6fe12ba9ab3efc77bc5cb05895e54dc7822f9862214c
+DIST gcompris-qt-0.97.tar.xz 75362060 BLAKE2B e6bc429ba4a8a622792935c9b2e68149f5c1f4d9aae4cac84ca517ebe83e59a9b4307f6ce84b36e658256cad5c8bd37b7cbc60a058b6d65be372ad1934cf666f SHA512 23cc807238121a6ea3abb8816795b2f3b243c3be1acf782705468d92758a2032a8cb5393c3c30028877d174ff53ebc3a62f69e9045bc70a5281d1d245b6e4eba
EBUILD gcompris-0.96.ebuild 907 BLAKE2B f4b9eb381067e3c38ff9b5ae5da1973115a725f82a0a2d0b8f835cdd7a8bc1a7c14e55f46bcfc2e670968db1fa06b54882322c4549401f06d65f8233666739ba SHA512 821453c28e7e2cf8d22088d86c9b4a1f5bd8e032412ef735c0aef5bd9bd6cf6ccdbbd19de3df0f4bdeef9cf2782eb166326fdf1173c1cb4cd81b90ca5546d9cb
-MISC metadata.xml 365 BLAKE2B 4b02a383df355fff43ccbc21579c0941979e88022657f30f0bdca02dc3690e927e1d8543eef05a90c646ea0fdb2cf7aaff1ff00f530930387a474cbca8715484 SHA512 1a0a2e05ff75bd34e0f5fa69f66175548c77dcfdf260a3fba7e31d0059057ef0468cc3a0bafa775ecdf4a49dd111432fd833d27c038ea7727c73778a6c055ef4
+EBUILD gcompris-0.97.ebuild 1017 BLAKE2B 2386bae2dc68d7862a95d49ddd111804bfffa2d29bc4fb07f9ce71abe4c99c14dcde13d7b87382d7cefe10532bea9fd1627cdb34c37ece284e2b3433f8373f43 SHA512 61b9343d71ba968dac11c92f064834091cc974298aa4c4fe602b17727b6a5cbbcac48e91650667a19908d44ca44a1a014f8b0ea6429238e8ad026605a5c2b3f3
+MISC metadata.xml 497 BLAKE2B b7025c9c4c39cb4738b1fba707dd139b53acc16a2054597bddc2fe1ef7130c276c0e623f5e5b81e7942c7ebd69a6f364e16d2804368e89b527852a6f0a6ec4c5 SHA512 578a96a0961e84fbbc48aea9d0b6d1d69bec48a8be8fb97fbfa213feb31dd6424cb39c07a11c9569d10090cc9fbbc6d376d5d8db001cc3ec7ee8714c69c9471d
diff --git a/games-kids/gcompris/gcompris-0.97.ebuild b/games-kids/gcompris/gcompris-0.97.ebuild
new file mode 100644
index 000000000000..213187432c4f
--- /dev/null
+++ b/games-kids/gcompris/gcompris-0.97.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="optional"
+ECM_TEST="true"
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Full featured educational application for children from 2 to 10"
+HOMEPAGE="https://gcompris.net/"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="https://gcompris.net/download/qt/src/${PN}-qt-${PV}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-qt-${PV}"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="kiosk"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-${QTMIN}:5
+ test? (
+ dev-util/cppcheck
+ sys-devel/clang
+ )
+"
+RDEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtsensors-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+"
+DEPEND="${RDEPEND}
+ >=dev-qt/qtmultimedia-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=dev-qt/qtxmlpatterns-${QTMIN}:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DQML_BOX2D_MODULE=disabled
+ -DWITH_KIOSK_MODE=$(usex kiosk)
+ )
+ ecm_src_configure
+}
diff --git a/games-kids/gcompris/metadata.xml b/games-kids/gcompris/metadata.xml
index 713d7d0e6cc1..ab0bc780ada9 100644
--- a/games-kids/gcompris/metadata.xml
+++ b/games-kids/gcompris/metadata.xml
@@ -3,10 +3,13 @@
<pkgmetadata>
<maintainer type="project">
<email>kde@gentoo.org</email>
- <name>Gentoo Games Project</name>
+ <name>Gentoo KDE Project</name>
</maintainer>
<maintainer type="project">
<email>games@gentoo.org</email>
<name>Gentoo Games Project</name>
</maintainer>
+ <use>
+ <flag name="kiosk">Enable kiosk mode by default (for use by small children or on a self-service host machine)</flag>
+ </use>
</pkgmetadata>
diff --git a/games-kids/tuxtype/Manifest b/games-kids/tuxtype/Manifest
index c51f702f3f32..9505cfcc1252 100644
--- a/games-kids/tuxtype/Manifest
+++ b/games-kids/tuxtype/Manifest
@@ -1,3 +1,4 @@
-DIST tuxtype-1.8.1.tar.gz 11470321 BLAKE2B 13650d319e75ed9770113475841780c3413b1d9918f9641bb5b32cf67a622ab731c54149e52252f69030ab8e016b4de408a835aaed29cbf5772213b58cab3e65 SHA512 c7285ece93168260215e20cb5e4f4a46da00687c22241e70f97f735e19501ea8f1abb38e4070fac108c524e5aa3f23f680acef6ef9f5654bc2dab954bcadab01
-EBUILD tuxtype-1.8.1-r1.ebuild 1026 BLAKE2B de51914a47d05f0546210fe939cff819ba2c6bafbeaf9e997b3f66d36533a3dfd1801dbcfd114dab1375c89043a2613135b92f21059b42532c05012de060cb51 SHA512 41e898f7252a08af8f08864f766ad905106b85743f73342840832589c972e6b0829467f41d9451081d9c9c1cf6dd537b5f77ec9976654ebf1ef110b23417cf52
-MISC metadata.xml 334 BLAKE2B 6f4e62b0dbebab5c82703fda8a4aa7c796d282025d649e14416516e8ab94708342795dd9a9c70d6dd62590eda3822c51068dc4592691f8034eeaf1333451ff95 SHA512 12a1bc978d61fb759e63526aa05eea9efe60d269d0a2d52a37c4c72be7ddb0aa1e1eb0a9d76b2f0b1e91772ab50ed1a72dc9c0e486705fc51d79aed6fb786c69
+AUX tuxtype-1.8.3-games-group.patch 399 BLAKE2B cab96cc3bd314e077847a14ac8cf7925eb5a7e02092520d8bd57bf1ce0a7a38551c536105c1b42649700ed9e6ded0136715ce7f80c979a00044479e5fd75bb6c SHA512 e18350f580adc54c73852ff5a2a086680b41fa7cd3a88b4b0c1889f8fed138e573fcbb359f376d0bae9b5bf4d8a9eff0ed02325211b259ded25b75eaf226d77f
+DIST tuxtype-1.8.3.tar.gz 11805625 BLAKE2B f34b2386234001452a3aba8afda7206a6bf674e6e60d5e5a8ea889e462f6979615f46bd47d62353c75e814c785e6a2ce97728f8cef6c44e43bb799b633ca0175 SHA512 7638cf7b5cb3a02072d36b43d385e43797bb846c5a69fda532432fb80ece19c44ca7b9b54bd73d4d3b7462b18f90cadb4648ed82a1d9e4822d7f3bd2c7a89343
+EBUILD tuxtype-1.8.3-r1.ebuild 1430 BLAKE2B cee248da685292da250d1e2c2424c2cdbfa0c5299e1515559af88177a652ee21c4704997e08809787111431aa3f474352b773f6be8e9ae41b8eda057b85d83d2 SHA512 1528cdb4a4a8df6d16f095f40005937a7c25dc1f602eced964938629194d397d6eac80ca71ceb237714100e9507f0efdc9abd04a2b85cb00345d561100b0b211
+MISC metadata.xml 469 BLAKE2B a30509733c90ab2eaaf0f4f7b0393efd71daffeba9f806b9c7339f47398055805e86d17fe435bf3ca35f142fb224fd8819fcbe0f8136298559a544864d928687 SHA512 4d43ea7425bc9911f5b8b6ae46ded3fbe21fbefcea2e00a7a60274fa0b6b8fe1544ec2fcb4b533654a6abdb2fb6e4cd7c79494ba8cd02dbc2ad4d76c16ba5eda
diff --git a/games-kids/tuxtype/files/tuxtype-1.8.3-games-group.patch b/games-kids/tuxtype/files/tuxtype-1.8.3-games-group.patch
new file mode 100644
index 000000000000..444794c5f5ec
--- /dev/null
+++ b/games-kids/tuxtype/files/tuxtype-1.8.3-games-group.patch
@@ -0,0 +1,11 @@
+diff -Naur a/Makefile.am b/Makefile.am
+--- a/Makefile.am 2014-08-20 04:47:21.000000000 +0100
++++ b/Makefile.am 2019-11-26 21:12:23.430972975 +0000
+@@ -49,7 +49,6 @@
+ $(MKDIR_P) -m 2755 $(DESTDIR)$(pkglocalstatedir)
+ $(MKDIR_P) -m 2755 $(DESTDIR)$(pkglocalstatedir)/words
+ # chown root:games $(DESTDIR)$(pkglocalstatedir)
+- chown root:games $(DESTDIR)$(pkglocalstatedir)/words
+
+
+ uninstall-hook:
diff --git a/games-kids/tuxtype/metadata.xml b/games-kids/tuxtype/metadata.xml
index 52de2ed0b372..edb3136e7016 100644
--- a/games-kids/tuxtype/metadata.xml
+++ b/games-kids/tuxtype/metadata.xml
@@ -8,4 +8,7 @@
<upstream>
<remote-id type="github">tux4kids/tuxtype</remote-id>
</upstream>
+ <use>
+ <flag name="pango">Render fonts using <pkg>media-libs/sdl-pango</pkg> instead of <pkg>media-libs/sdl-ttf</pkg></flag>
+ </use>
</pkgmetadata>
diff --git a/games-kids/tuxtype/tuxtype-1.8.1-r1.ebuild b/games-kids/tuxtype/tuxtype-1.8.1-r1.ebuild
deleted file mode 100644
index 5ca2f0d987ce..000000000000
--- a/games-kids/tuxtype/tuxtype-1.8.1-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils
-
-DESCRIPTION="Typing tutorial with lots of eye-candy"
-HOMEPAGE="https://github.com/tux4kids/tuxtype"
-SRC_URI="https://github.com/tux4kids/${PN}/archive/upstream/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2 OFL-1.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="svg"
-
-DEPEND="acct-group/gamestat
- media-libs/libsdl[video]
- media-libs/sdl-image
- media-libs/sdl-mixer
- media-libs/sdl-pango
- media-libs/sdl-ttf
- svg? ( gnome-base/librsvg )"
-RDEPEND=${DEPEND}
-
-S=${WORKDIR}/${PN}-upstream-${PV}
-
-src_configure() {
- econf \
- --localedir=/usr/share/locale \
- $(use_with svg rsvg)
-}
-
-src_install() {
- default
- rm -f "${D}"/usr/share/doc/${PF}/{COPYING,INSTALL,ABOUT-NLS}*
- doicon ${PN}.ico
- make_desktop_entry ${PN} TuxTyping /usr/share/pixmaps/${PN}.ico
- keepdir /etc/${PN} /var/games/${PN}/words
-
- fowners root:gamestat /var/games/${PN} /usr/bin/${PN}
- fperms 660 /var/games/${PN}
- fperms 2755 /usr/bin/${PN}
-}
diff --git a/games-kids/tuxtype/tuxtype-1.8.3-r1.ebuild b/games-kids/tuxtype/tuxtype-1.8.3-r1.ebuild
new file mode 100644
index 000000000000..ecbbdaebb72a
--- /dev/null
+++ b/games-kids/tuxtype/tuxtype-1.8.3-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop xdg
+
+DESCRIPTION="Typing tutorial with lots of eye-candy"
+HOMEPAGE="https://github.com/tux4kids/tuxtype"
+SRC_URI="https://github.com/tux4kids/${PN}/archive/upstream/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+pango svg"
+
+DEPEND="acct-group/gamestat
+ dev-games/t4k-common
+ media-libs/libsdl[video]
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ !pango? ( media-libs/sdl-ttf )
+ pango? ( media-libs/sdl-pango )
+ svg? ( gnome-base/librsvg:2 )"
+
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}-upstream-${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.3-games-group.patch
+)
+
+src_prepare() {
+ xdg_src_prepare
+
+ # Fix broken linkage due to incorrect variable casing.
+ sed -i 's:$SDL_TTF:$SDL_ttf:g' configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --localedir="${EPREFIX}"/usr/share/locale \
+ $(use_with pango sdlpango) \
+ $(use_with svg rsvg) \
+ --without-sdlnet # Unused!
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ rm -v "${ED}"/usr/share/doc/${PF}/{ABOUT-NLS,COPYING,INSTALL} || die
+ keepdir /etc/${PN} /var/lib/${PN}/words
+
+ newicon -s 64 icon.png ${PN}.png
+ make_desktop_entry ${PN} TuxTyping
+
+ fowners root:gamestat /var/lib/${PN} /usr/bin/${PN}
+ fperms 660 /var/lib/${PN}
+ fperms 2755 /usr/bin/${PN}
+}