summaryrefslogtreecommitdiff
path: root/games-kids/tuxtype
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-kids/tuxtype
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-kids/tuxtype')
-rw-r--r--games-kids/tuxtype/Manifest3
-rw-r--r--games-kids/tuxtype/metadata.xml8
-rw-r--r--games-kids/tuxtype/tuxtype-1.8.1-r1.ebuild46
3 files changed, 57 insertions, 0 deletions
diff --git a/games-kids/tuxtype/Manifest b/games-kids/tuxtype/Manifest
new file mode 100644
index 000000000000..ef8524e2ece4
--- /dev/null
+++ b/games-kids/tuxtype/Manifest
@@ -0,0 +1,3 @@
+DIST tuxtype_w_fonts-1.8.1.tar.gz 11528002 BLAKE2B 45cf547f94665913746c6f3fbcd25554cd4adeda1b6cbcc7cbffc1afec3c161f590ad9d21fa53c8e141978916a2d943cfa626cf412f805aeaf7d327284b11615 SHA512 2c360807295f8d9f3d18f36b64c49e39fac78d81570c7a554244a01ee76627c90579e580b609ea7994378f5bbff916142e293ad94306b7b38d132fdc1c53734f
+EBUILD tuxtype-1.8.1-r1.ebuild 1059 BLAKE2B 5ae170cdbcad66fa1a2e2710555a0ab453b3de73058658700c3722041e7fc469de8498ed2bf78c9762308efca637279c626c527a0a3d07202bdd022d5b18f85c SHA512 0022ad58f51ed9eb84968c6b690c73b4cce22e61a72ef9a458fc79fe9c31474f6987af156957722d7f7fc37d9df0f277100cd4511bc91ef0278452b890a875e8
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-kids/tuxtype/metadata.xml b/games-kids/tuxtype/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-kids/tuxtype/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-kids/tuxtype/tuxtype-1.8.1-r1.ebuild b/games-kids/tuxtype/tuxtype-1.8.1-r1.ebuild
new file mode 100644
index 000000000000..ecb8f47f7717
--- /dev/null
+++ b/games-kids/tuxtype/tuxtype-1.8.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils user
+
+DESCRIPTION="Typing tutorial with lots of eye-candy"
+HOMEPAGE="https://alioth.debian.org/projects/tux4kids"
+SRC_URI="https://alioth.debian.org/frs/download.php/3270/tuxtype_w_fonts-${PV}.tar.gz"
+
+LICENSE="GPL-2 OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="svg"
+
+DEPEND="media-libs/libsdl[video]
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-pango
+ media-libs/sdl-ttf
+ svg? ( gnome-base/librsvg )"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/tuxtype_w_fonts-${PV}
+
+pkg_setup(){
+ enewgroup gamestat 36
+}
+
+src_configure() {
+ econf \
+ --localedir=/usr/share/locale \
+ $(use_with svg rsvg)
+}
+
+src_install() {
+ default
+ rm -f "${D}"/usr/share/doc/${PF}/{COPYING,INSTALL,ABOUT-NLS}*
+ doicon ${PN}.ico
+ make_desktop_entry ${PN} TuxTyping /usr/share/pixmaps/${PN}.ico
+ keepdir /etc/${PN} /var/games/${PN}/words
+
+ fowners root:gamestat /var/games/${PN} /usr/bin/${PN}
+ fperms 660 /var/games/${PN}
+ fperms 2755 /usr/bin/${PN}
+}