summaryrefslogtreecommitdiff
path: root/games-kids/tuxmath
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /games-kids/tuxmath
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'games-kids/tuxmath')
-rw-r--r--games-kids/tuxmath/Manifest4
-rw-r--r--games-kids/tuxmath/files/tuxmath-2.0.3-blits-to-tmblits.patch36
-rw-r--r--games-kids/tuxmath/files/tuxmath-2.0.3-fno-common.patch8
-rw-r--r--games-kids/tuxmath/tuxmath-2.0.3-r1.ebuild65
-rw-r--r--games-kids/tuxmath/tuxmath-2.0.3-r2.ebuild62
5 files changed, 109 insertions, 66 deletions
diff --git a/games-kids/tuxmath/Manifest b/games-kids/tuxmath/Manifest
index e97dfb6fc7bb..0042df9e1b5b 100644
--- a/games-kids/tuxmath/Manifest
+++ b/games-kids/tuxmath/Manifest
@@ -1,3 +1,5 @@
+AUX tuxmath-2.0.3-blits-to-tmblits.patch 1183 BLAKE2B fa2eeca9c40380a2efd374cbb191957cd363d15f47c688579fbaad288ece0b4100241422f4a4b979ba4025511bdbc9263180f326617c34fe57877bf2464458a7 SHA512 6b510abdb6570cbedebf54208dcc08574b37d6d2c1cb49d165e533e0a2a634c159386fb2af8d46d7d72eae26eecbb8165b6586433bdd1f8a4f1b91a33e3ca2ca
+AUX tuxmath-2.0.3-fno-common.patch 232 BLAKE2B daef36fd30ea734a3d1ae84550009926d4bbdf31f60492d38bc60db39758ca3a2fe548ca5bf17b67552fd0a63374edf132b8600fcb37cd3389fc3dc013f8c26e SHA512 6dd76127b9fc14db689904e05d479460886a85e3bdcc056ba32b5b79a865e18631621923e709434765db49c736779c0a1345c345a2ad6ffd2834042d48322fa9
DIST tuxmath_2.0.3.orig.tar.gz 10396696 BLAKE2B bd060178e1acf62a36da380b9212e72549fde8f6e680d6ca3a4bbee3a0db163ae96a2df2a26d03bad96bf9fc297a6de5c6b0135b4be98ebacc325e1aff5ffbdf SHA512 dd7af90f3b1bd637f2f1639a3877d1a9950c95e60b1a71633998e2b0a654bb8015c4bf83540a9af092fe054d468035d0de5f3ddc7d54b17c3235f794a6108fbe
-EBUILD tuxmath-2.0.3-r1.ebuild 1257 BLAKE2B 7a86a39eca2d9b280cc981db21f19c4e66a20e0c14ccb7097a2121c0553897425cdbda296c90a894f86f0408a8ec68a4ba4601c129ffafff59ff8cb70c0031c3 SHA512 659371a77325e474b14ff5cb59ac7f257b89d7d065c438efd1057699d24139ce2435b226e9021d8015767641da2901665ee4b6668f0400e34fdc0de8ec554a85
+EBUILD tuxmath-2.0.3-r2.ebuild 1365 BLAKE2B 430004d84633fd30895e8ecca8af387e862e5912df0e8644021d736f02afa5272325a12c945dcaee610be60571638372f112819ca0c93ff5177750a77f0d1a8d SHA512 56c77d496b73f9afe5b62539983c74e74c761b2b36ee96b39bf7fb6907383386dde8a91874e330acd63b5f4c723409f6079485b5a938643a14712483f463f373
MISC metadata.xml 386 BLAKE2B 7dfebc426afb7fa3073cdcb11c90ed3a2f42cb40dab13e50fa66bcb40b77beab71a2cae73cd3311ba37fa898b905674e9f868f56eb1ee9232ea4bfa5db7dcadc SHA512 7964e4fb65b8dedcbeee8612a9131775db05dd111838b1b07864adf739c228aa9f2df43a26ad6fe46c27a71ab3c2bfeb3540e9e6b7627968eae94f69d946ac76
diff --git a/games-kids/tuxmath/files/tuxmath-2.0.3-blits-to-tmblits.patch b/games-kids/tuxmath/files/tuxmath-2.0.3-blits-to-tmblits.patch
new file mode 100644
index 000000000000..ff6e875d62f0
--- /dev/null
+++ b/games-kids/tuxmath/files/tuxmath-2.0.3-blits-to-tmblits.patch
@@ -0,0 +1,36 @@
+Fixes immediate crash on titlescreen with gcc10+
+Patch from debian:
+https://bugs.debian.org/986623
+--- a/src/titlescreen.c
++++ b/src/titlescreen.c
+@@ -57,3 +57,3 @@
+ unsigned char type;
+-} blits[MAX_UPDATES];
++} tmblits[MAX_UPDATES];
+
+@@ -1021,4 +1021,4 @@
+ for (i = 0; i < MAX_UPDATES; ++i) {
+- blits[i].srcrect = &srcupdate[i];
+- blits[i].dstrect = &dstupdate[i];
++ tmblits[i].srcrect = &srcupdate[i];
++ tmblits[i].dstrect = &dstupdate[i];
+ }
+@@ -1034,4 +1034,4 @@
+ for (i = 0; i < numupdates; i++)
+- if (blits[i].type == 'E')
+- SDL_LowerBlit(blits[i].src, blits[i].srcrect, screen, blits[i].dstrect);
++ if (tmblits[i].type == 'E')
++ SDL_LowerBlit(tmblits[i].src, tmblits[i].srcrect, screen, tmblits[i].dstrect);
+ // SNOW_erase();
+@@ -1040,4 +1040,4 @@
+ for (i = 0; i < numupdates; i++)
+- if (blits[i].type == 'D')
+- SDL_BlitSurface(blits[i].src, blits[i].srcrect, screen, blits[i].dstrect);
++ if (tmblits[i].type == 'D')
++ SDL_BlitSurface(tmblits[i].src, tmblits[i].srcrect, screen, tmblits[i].dstrect);
+ // SNOW_draw();
+@@ -1069,3 +1069,3 @@
+
+- update = &blits[numupdates++];
++ update = &tmblits[numupdates++];
+
diff --git a/games-kids/tuxmath/files/tuxmath-2.0.3-fno-common.patch b/games-kids/tuxmath/files/tuxmath-2.0.3-fno-common.patch
new file mode 100644
index 000000000000..ffd711f21ce0
--- /dev/null
+++ b/games-kids/tuxmath/files/tuxmath-2.0.3-fno-common.patch
@@ -0,0 +1,8 @@
+https://bugs.gentoo.org/795069
+https://github.com/tux4kids/tuxmath/pull/15
+--- a/src/menu_lan.c
++++ b/src/menu_lan.c
+@@ -39,3 +39,2 @@
+ /* lan_player_type now defined in network.h */
+-lan_player_type lan_player_info[MAX_CLIENTS];
+
diff --git a/games-kids/tuxmath/tuxmath-2.0.3-r1.ebuild b/games-kids/tuxmath/tuxmath-2.0.3-r1.ebuild
deleted file mode 100644
index 2ef1bded85da..000000000000
--- a/games-kids/tuxmath/tuxmath-2.0.3-r1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils gnome2-utils
-
-MY_PN="${PN}_w_fonts"
-DESCRIPTION="Educational arcade game where you have to solve maths problems"
-HOMEPAGE="https://github.com/tux4kids/tuxmath"
-SRC_URI="mirror://debian/pool/main/t/${PN}/${PN}_${PV}.orig.tar.gz"
-
-LICENSE="GPL-2 OFL-1.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="nls svg"
-
-RDEPEND="dev-games/t4k-common[svg?]
- dev-libs/libxml2:2
- media-libs/libsdl:0[video]
- media-libs/sdl-image[jpeg,png]
- media-libs/sdl-mixer[mod]
- media-libs/sdl-net
- media-libs/sdl-pango
- nls? ( virtual/libintl )
- svg? (
- gnome-base/librsvg:2
- x11-libs/cairo
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/${MY_PN}-${PV}
-
-src_prepare() {
- default
-
- sed -i -e '/\bdoc\b/d' Makefile.in || die
-}
-
-src_configure() {
- econf \
- --localedir=/usr/share/locale \
- $(use_enable nls) \
- $(usex svg "" "--without-rsvg")
-}
-
-src_install() {
- default
- doicon -s scalable data/images/icons/${PN}.svg
- make_desktop_entry ${PN} "TuxMath"
- dodoc doc/{README,TODO,changelog}
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}
diff --git a/games-kids/tuxmath/tuxmath-2.0.3-r2.ebuild b/games-kids/tuxmath/tuxmath-2.0.3-r2.ebuild
new file mode 100644
index 000000000000..fb3e676b0cf5
--- /dev/null
+++ b/games-kids/tuxmath/tuxmath-2.0.3-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop optfeature
+
+DESCRIPTION="Educational arcade game where you have to solve maths problems"
+HOMEPAGE="https://www.tux4kids.com/"
+SRC_URI="mirror://debian/pool/main/t/${PN}/${PN}_${PV}.orig.tar.gz"
+S="${WORKDIR}/${PN}_w_fonts-${PV}"
+
+LICENSE="CC-BY-SA-3.0 CC-PD GPL-3+ public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls svg"
+
+RDEPEND="
+ >=dev-games/t4k-common-0.1.1-r1[svg?]
+ dev-libs/libxml2:2
+ media-libs/libsdl[video]
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-mixer
+ media-libs/sdl-net
+ nls? ( virtual/libintl )"
+DEPEND="
+ ${RDEPEND}
+ svg? (
+ gnome-base/librsvg:2
+ x11-libs/cairo
+ )"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-blits-to-tmblits.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
+
+src_configure() {
+ local econfargs=(
+ $(use_enable nls)
+ $(usex svg '' --without-rsvg)
+ )
+ econf "${econfargs[@]}"
+}
+
+src_install() {
+ default
+
+ doicon data/images/icons/${PN}.svg
+ domenu ${PN}.desktop
+
+ # bundled fonts are unused if t4k-common uses pango
+ rm -r "${ED}"/usr/share/${PN}/fonts || die
+ rm "${ED}"/usr/share/doc/${PF}/{COPYING_GPL3,GPL_VERSIONS,INSTALL,OFL,README_DATA_LICENSES} || die
+}
+
+pkg_postinst() {
+ optfeature "music support" "media-libs/sdl-mixer[mod,vorbis]"
+}