summaryrefslogtreecommitdiff
path: root/games-fps
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-20 19:08:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-20 19:08:44 +0100
commit6b89cba67f554b60d139fd07623aef5cc724ec91 (patch)
tree876c06b4840a2ed6bff1771d124049d9bfff55b1 /games-fps
parent30114ae8ef07a32fea1e44a10b61f98c84142645 (diff)
gentoo auto-resync : 20:07:2023 - 19:08:44
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/Manifest.gzbin11889 -> 11890 bytes
-rw-r--r--games-fps/xonotic/Manifest2
-rw-r--r--games-fps/xonotic/xonotic-0.8.6.ebuild107
3 files changed, 109 insertions, 0 deletions
diff --git a/games-fps/Manifest.gz b/games-fps/Manifest.gz
index e31235698ebd..25b24eb89087 100644
--- a/games-fps/Manifest.gz
+++ b/games-fps/Manifest.gz
Binary files differ
diff --git a/games-fps/xonotic/Manifest b/games-fps/xonotic/Manifest
index b0f15ceb43c2..c0dcafc42e72 100644
--- a/games-fps/xonotic/Manifest
+++ b/games-fps/xonotic/Manifest
@@ -1,3 +1,5 @@
DIST xonotic-0.8.5.zip 1228561792 BLAKE2B 3f1391ff6522c8f6b7b4f717aecd6ffe852142d70e7cffff9cb5a602a69142c59850636cc1450aade5ae39088354170b819f696427ba8829bf7c375029f2430a SHA512 4ffc4b73eeb5f580d178a98419d5b44cbff0c56e356a62baa729b5b7a6c3d43b2b425b123428c9b1bf3f4718eaf61bcf5d62914521cc061c7563a253440c807e
+DIST xonotic-0.8.6.zip 1238439495 BLAKE2B f9a9823a2ef8a1a8790c92fe898599938ff39fe9a32bb1f3595a4b451237f7fca29385feeaf8164216713a2cbe2db4d78cadeee91bb08093dae4a7ad1588e4d4 SHA512 cb39879e96f19abb2877588c2d50c5d3e64dd68153bec3dd1bebedf4d765e506afa419c28381d7005aed664cb1a042571c132b5b319e4308cab67745d996c2a6
EBUILD xonotic-0.8.5.ebuild 2377 BLAKE2B 1340f0c484f75faded196ac3d7eeec3ff0b34dab66fa01b27540b6a8308718779d0da7358118d8150a57310b96603e87df6e620ffb8f1d3c496420b79884eb42 SHA512 d30bcedb34f439d0a0d11732951758865c5747ebf1fd3186fbef03f146575141ac59b3eb4f879eb5413c723e7ceea78217d977e7aa69798ce09c40f61de93c4a
+EBUILD xonotic-0.8.6.ebuild 2444 BLAKE2B f0dc867c52d31c59dca02a8f076e4773937ca5dbfc233db42b1d2aed707cfe942d504886ad56c161231699f181a8a0dcee1f065a46b655194d52112d74cb6f64 SHA512 e339936c5f323b7ed7cb256d8b1b9da3bacfd37516b848e30c6cffbf5fd789423bf573be562c5d07a80c06caa305709514f40294b9cc75e4fe38ceccb7e950b3
MISC metadata.xml 439 BLAKE2B f60174ff89a69e81ddc9bfa36a30f846bcdd124b3793b78e1a9598dcf1ce832453ba440c2882ab3fe5212ab9e51ed6e082df222d64760a63dec68cd1e5a53ebe SHA512 5533f471c71d71bb199d1babf598b69d287e2808d44ea93661ea695dfcf9fd19a1b817843d96a220287fe43095c99a78c7437c42ed588e1e7387537d462cbeaf
diff --git a/games-fps/xonotic/xonotic-0.8.6.ebuild b/games-fps/xonotic/xonotic-0.8.6.ebuild
new file mode 100644
index 000000000000..9848e246cedb
--- /dev/null
+++ b/games-fps/xonotic/xonotic-0.8.6.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop check-reqs toolchain-funcs xdg
+
+DESCRIPTION="Fork of Nexuiz, Deathmatch FPS based on DarkPlaces, an advanced Quake 1 engine"
+HOMEPAGE="https://xonotic.org/"
+SRC_URI="https://dl.xonotic.org/${P}.zip"
+S="${WORKDIR}/${PN^}"
+
+LICENSE="GPL-3+ GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="X +alsa ode +sdl"
+
+# note: many dependencies are used through dlopen()
+COMMON_UIDEPEND="
+ media-libs/libogg
+ media-libs/libtheora
+ media-libs/libvorbis"
+RDEPEND="
+ dev-libs/d0_blind_id
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng
+ media-libs/freetype:2
+ net-misc/curl
+ sys-libs/zlib:=
+ X? (
+ ${COMMON_UIDEPEND}
+ media-libs/libglvnd[X]
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libXxf86vm
+ alsa? ( media-libs/alsa-lib )
+ )
+ ode? ( dev-games/ode:=[double-precision] )
+ sdl? (
+ ${COMMON_UIDEPEND}
+ media-libs/libsdl2[joystick,opengl,sound,video]
+ )"
+DEPEND="
+ ${RDEPEND}
+ X? ( x11-base/xorg-proto )"
+BDEPEND="app-arch/unzip"
+
+CHECKREQS_DISK_BUILD="1500M"
+CHECKREQS_DISK_USR="1200M"
+
+src_prepare() {
+ default
+
+ sed -e 's|-O3 ||' \
+ -e '/^LDFLAGS_RELEASE/s/$(OPTIM_RELEASE)/$(GENTOO_LDFLAGS)/' \
+ -i source/darkplaces/makefile.inc || die
+}
+
+src_compile() {
+ tc-export CC
+
+ # do not pass in array to keep the makefile.inc's += flags
+ local -x CPUOPTIMIZATIONS=${CFLAGS}
+
+ local emakeargs=(
+ -C source/darkplaces
+ DEFAULT_SNDAPI=$(usex alsa ALSA OSS)
+ DP_FS_BASEDIR="${EPREFIX}"/usr/share/${PN}
+ DP_LINK_ODE=$(usex ode shared no)
+ STRIP=:
+ GENTOO_LDFLAGS="${LDFLAGS}"
+ )
+
+ # split for bug 473352
+ emake "${emakeargs[@]}" sv-release
+ use X && emake "${emakeargs[@]}" cl-release
+ use sdl && emake "${emakeargs[@]}" sdl-release
+}
+
+src_install() {
+ newbin {source/darkplaces/darkplaces,${PN}}-dedicated
+
+ if use X || use sdl; then
+ if use X; then
+ newbin {source/darkplaces/darkplaces,${PN}}-glx
+ domenu misc/logos/${PN}-glx.desktop
+ fi
+ if use sdl; then
+ newbin {source/darkplaces/darkplaces,${PN}}-sdl
+ domenu misc/logos/${PN}.desktop
+ fi
+
+ local size
+ for size in 16 22 24 32 48 128 256 512; do
+ newicon -s ${size} misc/logos/icons_png/${PN}_${size}.png ${PN}.png
+ done
+ newicon -s scalable misc/logos/${PN}_icon.svg ${PN}.svg
+ fi
+
+ dodoc Docs/*.{md,txt}
+
+ insinto /usr/share/${PN}
+ doins -r key_0.d0pk server data
+
+ rm "${ED}"/usr/share/${PN}/server/.gitattributes || die
+}