summaryrefslogtreecommitdiff
path: root/games-fps/wolfgl/wolfgl-0.93-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-fps/wolfgl/wolfgl-0.93-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-fps/wolfgl/wolfgl-0.93-r2.ebuild')
-rw-r--r--games-fps/wolfgl/wolfgl-0.93-r2.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/games-fps/wolfgl/wolfgl-0.93-r2.ebuild b/games-fps/wolfgl/wolfgl-0.93-r2.ebuild
new file mode 100644
index 000000000000..2fb858261675
--- /dev/null
+++ b/games-fps/wolfgl/wolfgl-0.93-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+#ECVS_SERVER="wolfgl.cvs.sourceforge.net:/cvsroot/wolfgl"
+#ECVS_MODULE="wolfgl"
+#inherit cvs
+
+inherit eutils
+
+DESCRIPTION="Wolfenstein and Spear of Destiny port using OpenGL"
+HOMEPAGE="http://wolfgl.sourceforge.net/"
+SRC_URI="mirror://gentoo/${P}.tbz2
+ mirror://sourceforge/wolfgl/wolfdata.zip
+ mirror://sourceforge/wolfgl/sdmdata.zip"
+# mirror://sourceforge/wolfgl/wolfglx-wl6-${PV}.zip
+# mirror://sourceforge/wolfgl/wolfglx-sod-${PV}.zip
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="virtual/opengl"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ x11-proto/xproto"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-gcc.patch
+ "${FILESDIR}"/${PV}-sample-rate.patch
+ "${FILESDIR}"/${PV}-sprite.patch
+ "${FILESDIR}"/${P}-as-needed.patch
+ "${FILESDIR}"/${PV}-gcc4.patch
+)
+
+src_compile() {
+ emake -j1 CFLAGS="${CFLAGS}" DATADIR="/usr/share/${PN}" || die "emake failed"
+}
+
+src_install() {
+ newbin linux/SDM/wolfgl wolfgl-sdm
+ newbin linux/SOD/wolfgl wolfgl-sod
+ newbin linux/WL1/wolfgl wolfgl-wl1
+ newbin linux/WL6/wolfgl wolfgl-wl6
+
+ insinto /usr/share/${PN}
+ doins "${WORKDIR}"/*.{sdm,wl1}
+}
+
+pkg_postinst() {
+ elog "This installed the shareware data files for"
+ elog "Wolfenstein 3D and Spear Of Destiny."
+ elog "If you wish to play the full versions just"
+ elog "copy the data files to /usr/share/${PN}/"
+}