summaryrefslogtreecommitdiff
path: root/games-fps/ut2004-demo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-fps/ut2004-demo
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-fps/ut2004-demo')
-rw-r--r--games-fps/ut2004-demo/Manifest3
-rw-r--r--games-fps/ut2004-demo/metadata.xml8
-rw-r--r--games-fps/ut2004-demo/ut2004-demo-3334.ebuild84
3 files changed, 95 insertions, 0 deletions
diff --git a/games-fps/ut2004-demo/Manifest b/games-fps/ut2004-demo/Manifest
new file mode 100644
index 000000000000..08be85fa9a4f
--- /dev/null
+++ b/games-fps/ut2004-demo/Manifest
@@ -0,0 +1,3 @@
+DIST ut2004-lnx-demo3334.run 288950743 BLAKE2B 82a45af7de4735cbcb1b8b4b5303d28d96e3e4888e12b60b920db096ed07b4c5d902eda258276c95865316206ddfd5828174397a8e921118e33f63be01e71861 SHA512 4cdd61901f4c082d1e02caf301a24f1e18e89f4efc9fbce0e4496178916b6c14245131b62f27deb17f1763cd4b8bf68ee60cc7af5ece5fa2b39d1bf349361da0
+EBUILD ut2004-demo-3334.ebuild 1865 BLAKE2B 2654f4494e232e40d44622e1cd997f327b4c152a67ddb17ce54efd3f7be5de290eb6ebf63c79dae7b817d3ed19075c4384079559590ad64607f763f42d232988 SHA512 859a82c7cb969396640f35824cd0fe3a7ad6c0a172e1ce68a60230e57599b174838c773a71f756374ffdf551617945999744f7e4f4ec7bb06ea5529b492dfded
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-fps/ut2004-demo/metadata.xml b/games-fps/ut2004-demo/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-fps/ut2004-demo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-fps/ut2004-demo/ut2004-demo-3334.ebuild b/games-fps/ut2004-demo/ut2004-demo-3334.ebuild
new file mode 100644
index 000000000000..53cca08e3d83
--- /dev/null
+++ b/games-fps/ut2004-demo/ut2004-demo-3334.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils unpacker games
+
+MY_P="ut2004-lnx-demo${PV}.run"
+DESCRIPTION="Demo for the critically-acclaimed first-person shooter"
+HOMEPAGE="http://www.unrealtournament.com/"
+SRC_URI="mirror://gentoo/${MY_P}"
+
+LICENSE="ut2003-demo"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="strip"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ virtual/libstdc++:3.3
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+QA_PREBUILT="${dir:1}/System/*"
+
+src_unpack() {
+ unpack_makeself
+ unpack ./setupstuff.tar.gz
+}
+
+src_install() {
+ dodir "${dir}"
+
+ tar xjf ut2004demo.tar.bz2 -C "${Ddir}" || die
+
+ if use x86
+ then
+ tar xjf linux-x86.tar.bz2 || die
+ fi
+ if use amd64
+ then
+ tar xjf linux-amd64.tar.bz2 || die
+ fi
+
+ insinto "${dir}"
+ doins README.linux ut2004.xpm
+ newicon ut2004.xpm ut2004-demo.xpm
+
+ exeinto "${dir}"
+ doexe bin/ut2004-demo
+
+ exeinto "${dir}"/System
+ doexe System/{libSDL-1.2.so.0,openal.so,ucc-bin,ut2004-bin}
+
+ games_make_wrapper ut2004-demo ./ut2004-demo "${dir}" "${dir}"
+ make_desktop_entry ut2004-demo "Unreal Tournament 2004 (Demo)" ut2004-demo
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "For Text To Speech:"
+ elog " 1) emerge festival speechd"
+ elog " 2) Edit your ~/.ut2004demo/System/UT2004.ini file."
+ elog " In the [SDLDrv.SDLClient] section, add:"
+ elog " TextToSpeechFile=/dev/speech"
+ elog " 3) Start speechd."
+ elog " 4) Start the game. Be sure to go into the Audio"
+ elog " options and enable Text To Speech."
+ echo
+ elog "To test, pull down the console (~) and type:"
+ elog " TTS this is a test."
+ echo
+ elog "You should hear something that sounds like 'This is a test.'"
+ echo
+}