summaryrefslogtreecommitdiff
path: root/games-fps/ut2004-demo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-fps/ut2004-demo
reinit the tree, so we can have metadata
Diffstat (limited to 'games-fps/ut2004-demo')
-rw-r--r--games-fps/ut2004-demo/Manifest5
-rw-r--r--games-fps/ut2004-demo/metadata.xml8
-rw-r--r--games-fps/ut2004-demo/ut2004-demo-3334.ebuild84
3 files changed, 97 insertions, 0 deletions
diff --git a/games-fps/ut2004-demo/Manifest b/games-fps/ut2004-demo/Manifest
new file mode 100644
index 000000000000..3502632504e2
--- /dev/null
+++ b/games-fps/ut2004-demo/Manifest
@@ -0,0 +1,5 @@
+DIST ut2004-lnx-demo3334.run 288950743 SHA256 c7065a758e91fdf5cf79cb8f9646e4360928ba9de4460ab7011c08e22a240cf3 SHA512 4cdd61901f4c082d1e02caf301a24f1e18e89f4efc9fbce0e4496178916b6c14245131b62f27deb17f1763cd4b8bf68ee60cc7af5ece5fa2b39d1bf349361da0 WHIRLPOOL 07749d100e601967ed581725290f67479252a4a5393b43d44037513776306432d20e1ed7cc05fa747be90cd04065eb3ba6484095d630c9ceea599d8f83b429a9
+EBUILD ut2004-demo-3334.ebuild 1863 SHA256 9d21c4c91b2837f47eda03295c564c80e7d19c9e12ae734597a1749faf69e3a5 SHA512 433b9091774ebf0f7d3b14c33baede935cbd184fc846d9e23267335c2723ea5728e51dfe0703b9ed448e5155fc6618c7933927a4a212abc441f05a7b7ccbff82 WHIRLPOOL 37b2172ea231d28da1cc3f650596ec3ecfd8f89684597bc29c734be0100cc5cda2e19ca81f3fc799854f4cde400df5b41d847f21268cf32279fc2198eb4498b3
+MISC ChangeLog 2438 SHA256 f6727e8ed846787f249e8e35fa863b8939d11e39bb595bcead197d4d2a27653d SHA512 15dc07e0d973a022e225b7218bdbe077df7cf922a8b670cf876011989955e87e10d8d6e1e0886f6ee8d16e209e8853db2a30444ec1ebc11b0a890a87306eabd0 WHIRLPOOL aab30fc790a33b57207c4c4346798a019175dbec7382082b1a34c91fad14a856c7d735a5237a93f425bc29cce3c0a9c6f9dca74cfcfc968ae86e7c69e613e354
+MISC ChangeLog-2015 5831 SHA256 b31af3f9c125e940f4523b6b5e7fa06b2c1db5d378e61be3f3b46cdc233cc02e SHA512 6a48bb73e0f58b8cbcb63dd121d66ee786576d06cb4704a29ad2c045c41e1f59d2c5003045cf43c8ce946249b04a043229d4bf7cea45a188a9768627648e8910 WHIRLPOOL 8d49f123795a84021c9b4f49a0076551562e838c8bd9b09a04f2d00920295a3428ac0f651a08119148b78307522e862bdfcf30f5021fbc8e2739f35329b4af2e
+MISC metadata.xml 249 SHA256 943b9ce0cd072229b43569ab668dd7ec741d9dfefd942c8921dabd4490b27b0c SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118 WHIRLPOOL b10e21575c78e201a652c8582cd16e3f7c86b13dd20a30f4cea44066fb139440b3c186147dbaae83478f11a20b6f457a99c8b29ee1239a4caaa21eee01250088
diff --git a/games-fps/ut2004-demo/metadata.xml b/games-fps/ut2004-demo/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-fps/ut2004-demo/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-fps/ut2004-demo/ut2004-demo-3334.ebuild b/games-fps/ut2004-demo/ut2004-demo-3334.ebuild
new file mode 100644
index 000000000000..c9f009b33945
--- /dev/null
+++ b/games-fps/ut2004-demo/ut2004-demo-3334.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils unpacker games
+
+MY_P="ut2004-lnx-demo${PV}.run"
+DESCRIPTION="Demo for the critically-acclaimed first-person shooter"
+HOMEPAGE="http://www.unrealtournament.com/"
+SRC_URI="mirror://gentoo/${MY_P}"
+
+LICENSE="ut2003-demo"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+RESTRICT="strip"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ virtual/libstdc++:3.3
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+QA_PREBUILT="${dir:1}/System/*"
+
+src_unpack() {
+ unpack_makeself
+ unpack ./setupstuff.tar.gz
+}
+
+src_install() {
+ dodir "${dir}"
+
+ tar xjf ut2004demo.tar.bz2 -C "${Ddir}" || die
+
+ if use x86
+ then
+ tar xjf linux-x86.tar.bz2 || die
+ fi
+ if use amd64
+ then
+ tar xjf linux-amd64.tar.bz2 || die
+ fi
+
+ insinto "${dir}"
+ doins README.linux ut2004.xpm
+ newicon ut2004.xpm ut2004-demo.xpm
+
+ exeinto "${dir}"
+ doexe bin/ut2004-demo
+
+ exeinto "${dir}"/System
+ doexe System/{libSDL-1.2.so.0,openal.so,ucc-bin,ut2004-bin}
+
+ games_make_wrapper ut2004-demo ./ut2004-demo "${dir}" "${dir}"
+ make_desktop_entry ut2004-demo "Unreal Tournament 2004 (Demo)" ut2004-demo
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "For Text To Speech:"
+ elog " 1) emerge festival speechd"
+ elog " 2) Edit your ~/.ut2004demo/System/UT2004.ini file."
+ elog " In the [SDLDrv.SDLClient] section, add:"
+ elog " TextToSpeechFile=/dev/speech"
+ elog " 3) Start speechd."
+ elog " 4) Start the game. Be sure to go into the Audio"
+ elog " options and enable Text To Speech."
+ echo
+ elog "To test, pull down the console (~) and type:"
+ elog " TTS this is a test."
+ echo
+ elog "You should hear something that sounds like 'This is a test.'"
+ echo
+}