summaryrefslogtreecommitdiff
path: root/games-fps/ut2003-bonuspack-cm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-fps/ut2003-bonuspack-cm
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-fps/ut2003-bonuspack-cm')
-rw-r--r--games-fps/ut2003-bonuspack-cm/Manifest2
-rw-r--r--games-fps/ut2003-bonuspack-cm/ut2003-bonuspack-cm-1-r1.ebuild53
-rw-r--r--games-fps/ut2003-bonuspack-cm/ut2003-bonuspack-cm-1.ebuild38
3 files changed, 54 insertions, 39 deletions
diff --git a/games-fps/ut2003-bonuspack-cm/Manifest b/games-fps/ut2003-bonuspack-cm/Manifest
index 46d626a2e9b4..8ae73ae64ed7 100644
--- a/games-fps/ut2003-bonuspack-cm/Manifest
+++ b/games-fps/ut2003-bonuspack-cm/Manifest
@@ -1,3 +1,3 @@
DIST cbp2003.zip 149198696 BLAKE2B d6319e3605752e309411b16358696cdf0559b3cc6acedfae2f063eedb4ee98fefb470e9ff601cdce46821eaaa3f7c0ef3c13ddc2ce3639842ec98e1e68fefb85 SHA512 382ea605b7ce89654b7a58dfd1b36f0624bb0ac63aff6a07f1942dd3c8715ac6d79812828f2f28e2bd1b162673147e0ab8653ac67b4ee5d936e8840dede8e408
-EBUILD ut2003-bonuspack-cm-1.ebuild 809 BLAKE2B f23c553ce6f765adc800445fe37344a2cf59f89e28c36445eb4760e08f31bccbea3a81e0b1c49de4786c5490d765ccb5b5686865c3e62d60e4deca13f8b4b79a SHA512 960bde355c1c4e2a21c502774564626edf48a08c43d861130237a35722766cb643196310d152371040d33186182659f41879e48e245fa83da2ee278c3ce6ed23
+EBUILD ut2003-bonuspack-cm-1-r1.ebuild 1602 BLAKE2B 28bb152fd2a762ea19f99219d16adf994f123a9468072ca45bf75bdd0f674d4c90e31b2ff2ce39a5cf831be8a30059d2bccb9a811404803407564f9f1b458756 SHA512 fcc00a8de00ce6ad0c42c1751e413efa86f789d48223f27aa168db74eb6af9e4311f391f8c5b05fb3d5b317a9651979da53f361aae866a5c6020070fd17cdfee
MISC metadata.xml 771 BLAKE2B 705c6aa979f650220a52db3ef5d8c5b8b468b28eac8692a2fbe583ed4b3f694fdfe088d64cc3f6d8506494522f8ca11b491e21e322e3f50ff4453e93ce0d543f SHA512 d30d55503e3b3897d2a5093c06a39f684bdf0879214931a360a87637cd62ae1ca019577f42275bf2b4ba28649ab2989b0a2e184998497ddc5ffddbb6ba35ef5e
diff --git a/games-fps/ut2003-bonuspack-cm/ut2003-bonuspack-cm-1-r1.ebuild b/games-fps/ut2003-bonuspack-cm/ut2003-bonuspack-cm-1-r1.ebuild
new file mode 100644
index 000000000000..a40e978c7e73
--- /dev/null
+++ b/games-fps/ut2003-bonuspack-cm/ut2003-bonuspack-cm-1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit unpacker
+
+DESCRIPTION="Community Bonus Pack for UT2003"
+HOMEPAGE="https://liandri.beyondunreal.com/Unreal_Tournament_2003"
+SRC_URI="https://downloads.unrealadmin.org/UT2003/BonusPack/cbp2003.zip"
+S="${WORKDIR}"
+
+LICENSE="ut2003"
+SLOT="1"
+KEYWORDS="~x86"
+# Needs signup to download
+RESTRICT="bindist fetch mirror strip"
+
+RDEPEND="games-fps/ut2003"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/unzip"
+
+src_unpack() {
+ unpack_zip "${DISTDIR}"/${A}
+}
+
+src_install() {
+ # Inlined from games.eclass
+ local dir="${EPREFIX}"/opt/ut2003
+ local Ddir="${D}${dir}"
+
+ # Inlined from games.eclass
+ _games_umod_unpack() {
+ local umod=${1}
+
+ mkdir -p "${Ddir}"/System || die
+ cp "${dir}"/System/{ucc-bin,Manifest.ini,{Engine,Core,zlib,ogg,vorbis}.so,{Engine,Core}.int} "${Ddir}"/System || die
+ # Don't die here (for now) in case Default.ini, DefUser.ini are missing
+ cp "${dir}"/System/Def{ault,User}.ini "${Ddir}"/System &> /dev/null
+
+ cd "${Ddir}"/System || die
+ UT_DATA_PATH="${Ddir}"/System ./ucc-bin umodunpack -x "${S}/${umod}" -nohomedir &> /dev/null || die "uncompressing file ${umod}"
+ rm -f "${Ddir}"/System/{ucc-bin,{Manifest,Def{ault,User},User,UT200{3,4}}.ini,{Engine,Core,zlib,ogg,vorbis}.so,{Engine,Core}.int,ucc.log &>/dev/null || die "Removing temporary files"
+ }
+
+ for i in Animations Help Music Maps StaticMeshes Textures System; do
+ mkdir -p "${Ddir}"/${i} || die
+ done
+
+ _games_umod_unpack CBP2003.ut2mod
+
+ rm "${Ddir}"/Readme.txt "${Ddir}/cbp installer logo1.bmp" || die
+}
diff --git a/games-fps/ut2003-bonuspack-cm/ut2003-bonuspack-cm-1.ebuild b/games-fps/ut2003-bonuspack-cm/ut2003-bonuspack-cm-1.ebuild
deleted file mode 100644
index d42bd801c5ed..000000000000
--- a/games-fps/ut2003-bonuspack-cm/ut2003-bonuspack-cm-1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit games unpacker
-
-DESCRIPTION="Community Bonus Pack for UT2003"
-HOMEPAGE="https://liandri.beyondunreal.com/Unreal_Tournament_2003"
-SRC_URI="https://downloads.unrealadmin.org/UT2003/BonusPack/cbp2003.zip"
-
-LICENSE="ut2003"
-SLOT="1"
-KEYWORDS="~x86"
-RESTRICT="bindist mirror strip"
-
-RDEPEND="games-fps/ut2003"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S=${WORKDIR}
-
-dir=${GAMES_PREFIX_OPT}/ut2003
-Ddir=${D}/${dir}
-
-src_unpack() {
- unpack_zip "${DISTDIR}"/${A}
-}
-
-src_install() {
- for i in Animations Help Music Maps StaticMeshes Textures System
- do
- mkdir -p "${Ddir}"/${i} || die
- done
- games_umod_unpack CBP2003.ut2mod
- rm "${Ddir}/Readme.txt" "${Ddir}/cbp installer logo1.bmp"
- prepgamesdirs
-}