summaryrefslogtreecommitdiff
path: root/games-fps/rott
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-fps/rott
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-fps/rott')
-rw-r--r--games-fps/rott/Manifest4
-rw-r--r--games-fps/rott/metadata.xml25
-rw-r--r--games-fps/rott/rott-1.1.2-r1.ebuild55
3 files changed, 84 insertions, 0 deletions
diff --git a/games-fps/rott/Manifest b/games-fps/rott/Manifest
new file mode 100644
index 000000000000..470de2fc72d5
--- /dev/null
+++ b/games-fps/rott/Manifest
@@ -0,0 +1,4 @@
+DIST rott-1.1.2.tar.gz 749079 BLAKE2B 1c18ef25b8bb97a7edf8c376bf0b6da3829ca0406100ee9f44652077c06414d826086e354850a551152901036673b91d686d4d2e816ba6bb29b8dcce68144c00 SHA512 809a9064fe31c63afccb9a6397ac2c9d4172cdd802b055697cf3b0090ee6a78c9e40b52a4a8df25196489d9a0259304c91e2f84f95413a293bc66192502cf200
+DIST swdata.zip 2889672 BLAKE2B 593f95cbfb4a285ab3b946372d618b6b5cf785aa4b2e5228ac8aaaf702ceb8e4cc000d606f5b3aea85af1b34a4fe45bdebc2f692ba3bfc9c1d3afc7c570ad8a0 SHA512 99373097356afa583021367b2e0ec6ec745941890e4f17f4e07206c66dd370dfa9e928bc0bd6ab9809d8c72646dcc609e3c19f688d2b89a886f215a153b6dd0d
+EBUILD rott-1.1.2-r1.ebuild 1088 BLAKE2B c6dd102f9aa2d38218f1da5e89db7318c7b4cd7fb6a23a834078fff7347badd5b786fb382dffa1e8d2eb43e196092537db68e14c7385eefaa814501741441827 SHA512 0ecd207fb8ec9ecb103611623bdc918e68a499fa58636bc2c9e5719351a4f9efb4ea843da0096fec8abc4d4492339a55210e1d3f4b3d324c152d27a5a446e182
+MISC metadata.xml 1095 BLAKE2B 4a41d9a0bc9962a6a824d7ecc4d0bb774aa2b7feb21829aae74db25874c7f050698a724d7fe3d19e63d2e6aaf1c98d4870ac4d51f14145df24eea9646b3be2a0 SHA512 6e2d291f04b343b366ad9b7e5c18ae7cce327dd27cfdb496247a0228d2cf160d8d42f803f21aed07181dc1395ad8db9431270abd174dfc3c3d46a951294a3325
diff --git a/games-fps/rott/metadata.xml b/games-fps/rott/metadata.xml
new file mode 100644
index 000000000000..5bc2b194722d
--- /dev/null
+++ b/games-fps/rott/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription>
+THE STORY
+
+You are part of an elite group of operatives called HUNT (High-risk
+United Nations Taskforce), and you must stop a maniac cult leader from
+killing millions of people. While scouting a remote island, you are
+suddenly surrounded by enemy troops with guns blaring. In the distance
+you see your boat--your only chance to escape--explode into matchsticks.
+In front of you is a huge fortress monastery, and your only chance to
+stop the madness. You are e quipped with awesome, high-tech weaponry
+like heat-seeking missiles, split missiles, and the Flamewall cannon,
+which leaves a trail of charred skeletons in its wake. You'll also find
+magical instruments and weapons so incredible they defy description.
+</longdescription>
+ <use>
+ <flag name="demo">Install the shareware version</flag>
+ </use>
+</pkgmetadata>
diff --git a/games-fps/rott/rott-1.1.2-r1.ebuild b/games-fps/rott/rott-1.1.2-r1.ebuild
new file mode 100644
index 000000000000..5eabd67d2f86
--- /dev/null
+++ b/games-fps/rott/rott-1.1.2-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Rise of the Triad for Linux!"
+HOMEPAGE="http://www.icculus.org/rott/"
+SRC_URI="http://www.icculus.org/rott/releases/${P}.tar.gz
+ demo? ( http://filesingularity.timedoctor.org/swdata.zip )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="demo"
+
+RDEPEND="media-libs/libsdl[sound,joystick,video]
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${P}/rott
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/^CC =/d' \
+ Makefile || die "sed failed"
+ emake clean
+}
+
+src_compile() {
+ emake -j1 \
+ EXTRACFLAGS="${CFLAGS} -DDATADIR=\\\"/usr/share/${PN}/\\\"" \
+ SHAREWARE=$(usex demo "1" "0")
+}
+
+src_install() {
+ dobin rott
+ dodoc ../doc/*.txt ../README
+ doman ../doc/rott.6
+ if use demo ; then
+ cd "${WORKDIR}" || die
+ insinto /usr/share/${PN}
+ doins *.dmo huntbgin.* remote1.rts
+ fi
+}
+
+pkg_postinst() {
+ if ! use demo ; then
+ elog "To play the full version, just copy the"
+ elog "data files to /usr/share/${PN}/"
+ fi
+}