summaryrefslogtreecommitdiff
path: root/games-fps/quakeforge/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /games-fps/quakeforge/files
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'games-fps/quakeforge/files')
-rw-r--r--games-fps/quakeforge/files/quakeforge-0.7.2-gentoo.patch33
-rw-r--r--games-fps/quakeforge/files/quakeforge-0.7.2_p20210601-png-stub.patch9
-rw-r--r--games-fps/quakeforge/files/quakeforge-0.7.2_p20210601-skipped-tests.patch15
3 files changed, 24 insertions, 33 deletions
diff --git a/games-fps/quakeforge/files/quakeforge-0.7.2-gentoo.patch b/games-fps/quakeforge/files/quakeforge-0.7.2-gentoo.patch
deleted file mode 100644
index 38fb0c187689..000000000000
--- a/games-fps/quakeforge/files/quakeforge-0.7.2-gentoo.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- a/nq/source/Makefile.am 2012-11-18 16:57:56.658388682 +0100
-+++ b/nq/source/Makefile.am 2012-11-18 16:58:11.470268607 +0100
-@@ -138,7 +138,7 @@
- nq_x11_SOURCES= sys_unix.c
- nq_x11_LDADD= $(nq_x11_libs) \
- $(VIDMODE_LIBS) $(DGA_LIBS) $(X_LIBS) -lX11 \
-- $(X_EXTRA_LIBS) $(X_SHM_LIB) $(NET_LIBS)
-+ $(X_EXTRA_LIBS) $(X_SHM_LIB) $(NET_LIBS) -ldl
- nq_x11_LDFLAGS= $(common_ldflags)
- nq_x11_DEPENDENCIES= $(nq_x11_libs)
-
---- a/qw/source/Makefile.am 2012-11-18 17:10:59.148172332 +0100
-+++ b/qw/source/Makefile.am 2012-11-18 17:11:55.866876762 +0100
-@@ -168,7 +168,7 @@
- qw_client_x11_SOURCES= cl_sys_unix.c
- qw_client_x11_LDADD= $(qw_client_x11_libs) \
- $(VIDMODE_LIBS) $(DGA_LIBS) $(X_LIBS) -lX11 \
-- $(X_EXTRA_LIBS) $(X_SHM_LIB) $(NET_LIBS) $(LIBCURL_LIBS)
-+ $(X_EXTRA_LIBS) $(X_SHM_LIB) $(NET_LIBS) $(LIBCURL_LIBS) -ldl
- qw_client_x11_LDFLAGS= $(common_ldflags)
- qw_client_x11_DEPENDENCIES= $(qw_client_x11_libs)
-
---- a/tools/qwaq/Makefile.am 2012-11-18 17:15:16.024714317 +0100
-+++ b/tools/qwaq/Makefile.am 2012-11-18 17:15:41.955749660 +0100
-@@ -38,7 +38,7 @@
- qwaq_x11_SOURCES=qwaq.c qwaq-bi.c
- qwaq_x11_LDADD= $(qwaq_x11_libs) $(QWAQ_LIBS) \
- $(VIDMODE_LIBS) $(DGA_LIBS) $(X_LIBS) -lX11 \
-- $(X_EXTRA_LIBS) $(X_SHM_LIB)
-+ $(X_EXTRA_LIBS) $(X_SHM_LIB) -ldl
- qwaq_x11_LDFLAGS=
- qwaq_x11_DEPENDENCIES= $(qwaq_x11_libs) $(QWAQ_DEPS)
-
diff --git a/games-fps/quakeforge/files/quakeforge-0.7.2_p20210601-png-stub.patch b/games-fps/quakeforge/files/quakeforge-0.7.2_p20210601-png-stub.patch
new file mode 100644
index 000000000000..d32fab57b7e1
--- /dev/null
+++ b/games-fps/quakeforge/files/quakeforge-0.7.2_p20210601-png-stub.patch
@@ -0,0 +1,9 @@
+Fix stub definition for USE=-png
+https://github.com/quakeforge/quakeforge/issues/14
+--- a/libs/image/png.c
++++ b/libs/image/png.c
+@@ -320,3 +320,3 @@
+ VISIBLE tex_t *
+-LoadPNG (QFile *infile)
++LoadPNG (QFile *infile, int load)
+ {
diff --git a/games-fps/quakeforge/files/quakeforge-0.7.2_p20210601-skipped-tests.patch b/games-fps/quakeforge/files/quakeforge-0.7.2_p20210601-skipped-tests.patch
new file mode 100644
index 000000000000..5b25af47ac26
--- /dev/null
+++ b/games-fps/quakeforge/files/quakeforge-0.7.2_p20210601-skipped-tests.patch
@@ -0,0 +1,15 @@
+These are only failing at high precision and
+should not affect normal usage.
+ quat/simd: fails with -mavx
+ sebvf: random failure, sometimes pass
+--- a/libs/util/test/Makemodule.am
++++ b/libs/util/test/Makemodule.am
+@@ -15,8 +15,5 @@
+ libs/util/test/test-qfs \
+- libs/util/test/test-quat \
+ libs/util/test/test-seb \
+- libs/util/test/test-sebvf \
+ libs/util/test/test-seg \
+ libs/util/test/test-set \
+- libs/util/test/test-simd \
+ libs/util/test/test-txtbuffer \