summaryrefslogtreecommitdiff
path: root/games-fps/quake4-demo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-fps/quake4-demo
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-fps/quake4-demo')
-rw-r--r--games-fps/quake4-demo/Manifest3
-rw-r--r--games-fps/quake4-demo/metadata.xml24
-rw-r--r--games-fps/quake4-demo/quake4-demo-1.0-r2.ebuild76
3 files changed, 103 insertions, 0 deletions
diff --git a/games-fps/quake4-demo/Manifest b/games-fps/quake4-demo/Manifest
new file mode 100644
index 000000000000..e57e9828b5f2
--- /dev/null
+++ b/games-fps/quake4-demo/Manifest
@@ -0,0 +1,3 @@
+DIST quake4-linux-1.0-demo.x86.run 337276597 BLAKE2B 1fa657287210e717486955c5b6190e52665c2c8eb4faf44b1a4ba851347e934436f1153c9df2c3296e3e981c7cf981dbcf5bdb042b6eab1d36214f6937839161 SHA512 c7fa64ca9f95ab61fd02f2d7d3a85c718a5dea9f60a89ba8b46e7500f090fe45bbe498775e41541e33a0bb3483b75da10529755bef3a97d3e362d1c173a02abe
+EBUILD quake4-demo-1.0-r2.ebuild 1897 BLAKE2B aa7a681e68bcf05f42f660cfff2916c0accb0a91db2b297bd57deba6b4e123d2679a554c14d7b6f8b561ae881dfeb925b9f8717ac7388cbfc4cdb02bc2e9739f SHA512 743e53e31e2c88114e7ee02b5869447e3a0930006b6673f191895e89dec2113c56ef85d7e44ec76cf3b42955055b2449b5194ddc5dda9d897ddf6452ed3d7acb
+MISC metadata.xml 1090 BLAKE2B 0cef05f0bb46b9e1ddc0a2c30a3441d98bba5e5f16563b52eefccf1a7bcb4d4c5f2528413ed2ca4680c8bfe9bcbadf3a76c6f6efe26e84d663cec985e2add058 SHA512 d1e6906e94fb8a42f605310a3a2e18fdc99f7557ac7605116c2fa328838f624ff70d7e7f716b1b841de78a5e35067f2f6866d8f36feaf6fd36f8b4c964bbbc0f
diff --git a/games-fps/quake4-demo/metadata.xml b/games-fps/quake4-demo/metadata.xml
new file mode 100644
index 000000000000..c4e94c39a17d
--- /dev/null
+++ b/games-fps/quake4-demo/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<longdescription>
+In a desparate war for Earth's survival against and unrelenting alient enemy,
+the only way to defeat them is to become one of them.
+
+Earth is under seige by the Strogg, a barbaric alien race moving through the
+universe consuming, recycling and annihilating any civilization in their path.
+In a deperate attempt to survive, an armada of Earth's finest warriors is sent
+to take the battle to the Strogg home planet.
+
+You are Matthow Kane, an elite member of Rhino Squad and Eath's valiant invasion
+force. Fight alone, with your squad, or in hover tanks and mechanized walkers
+as you engage in a heroic mission the the heart of the Strogg war machine.
+
+Quake 4 is the fourth installment of the extremely popular and successful Quake
+series by id software. This is the demo version of the commercial game.
+</longdescription>
+</pkgmetadata>
diff --git a/games-fps/quake4-demo/quake4-demo-1.0-r2.ebuild b/games-fps/quake4-demo/quake4-demo-1.0-r2.ebuild
new file mode 100644
index 000000000000..a576d70253bb
--- /dev/null
+++ b/games-fps/quake4-demo/quake4-demo-1.0-r2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils unpacker games
+
+MY_P="quake4-linux-${PV}-demo"
+DESCRIPTION="Sequel to Quake 2, an Id 3D first-person shooter"
+HOMEPAGE="http://www.quake4game.com/"
+SRC_URI="mirror://idsoftware/quake4/demo/${MY_P}.x86.run
+ http://www.3ddownloads.com/Action/Quake%204/Demos/${MY_P}.x86.run
+ mirror://3dgamers/quake4/${MY_P}.x86.run
+ http://filebase.gmpf.de/quake4/${MY_P}.x86.run
+ http://www.holarse.de/mirror/${MY_P}.x86.run
+ http://sonic-lux.net/data/mirror/quake4/${MY_P}.x86.run"
+
+LICENSE="QUAKE4"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="dedicated"
+RESTRICT="strip"
+
+RDEPEND="sys-libs/glibc
+ sys-libs/libstdc++-v3:5
+ amd64? ( sys-libs/glibc[multilib] sys-libs/libstdc++-v3:5[multilib] )
+ dedicated? ( app-misc/screen )
+ !dedicated? (
+ || (
+ virtual/opengl[abi_x86_32(-)]
+ x11-drivers/nvidia-drivers
+ )
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
+ >=media-libs/libsdl-1.2.15-r4[X,opengl,sound,abi_x86_32(-)]
+ )"
+
+S=${WORKDIR}
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+QA_PREBUILT="${dir:1}/quake4.x86
+ ${dir:1}/q4ded.x86"
+
+src_install() {
+ insinto "${dir}"
+ doins License.txt q4icon.bmp version.info
+ dodoc README
+
+ exeinto "${dir}"
+ doexe openurl.sh bin/Linux/x86/q4ded.x86
+ games_make_wrapper ${PN}-ded ./q4ded.x86 "${dir}" "${dir}"
+
+ insinto "${dir}"/q4base
+ doins q4base/*
+
+ if ! use dedicated ; then
+ doexe bin/Linux/x86/quake4.x86
+ games_make_wrapper ${PN} ./quake4.x86 "${dir}" "${dir}"
+ newicon q4icon.bmp ${PN}.bmp || die
+ make_desktop_entry ${PN} "Quake IV (Demo)" /usr/share/applications/${PN}.bmp
+ fi
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ if ! use dedicated; then
+ elog "To play the game run:"
+ elog " quake4-demo"
+ echo
+ fi
+ elog "To start the gameserver, run:"
+ elog " quake4-demo-ded"
+}