summaryrefslogtreecommitdiff
path: root/games-fps/quake3-data/quake3-data-1.32b.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-fps/quake3-data/quake3-data-1.32b.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-fps/quake3-data/quake3-data-1.32b.ebuild')
-rw-r--r--games-fps/quake3-data/quake3-data-1.32b.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/games-fps/quake3-data/quake3-data-1.32b.ebuild b/games-fps/quake3-data/quake3-data-1.32b.ebuild
new file mode 100644
index 000000000000..bc98a7d7c2e5
--- /dev/null
+++ b/games-fps/quake3-data/quake3-data-1.32b.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CDROM_OPTIONAL="yes"
+inherit eutils unpacker cdrom games
+
+DESCRIPTION="Quake III Arena - data portion"
+HOMEPAGE="http://icculus.org/quake3/"
+SRC_URI="mirror://idsoftware/quake3/linux/linuxq3apoint-${PV}-3.x86.run"
+
+LICENSE="Q3AEULA"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+S=${WORKDIR}
+dir=${GAMES_DATADIR}/quake3
+
+src_unpack() {
+ use cdinstall && cdrom_get_cds baseq3/pak0.pk3:Quake3/baseq3/pak0.pk3
+ unpack_makeself
+}
+
+src_install() {
+ ebegin "Copying files from linux client ..."
+ insinto "${GAMES_DATADIR}"/quake3/baseq3
+ doins baseq3/*.pk3
+ eend 0
+
+ if use cdinstall ; then
+ einfo "Copying files from CD ..."
+ newins "${CDROM_ABSMATCH}" pak0.pk3
+ eend 0
+ fi
+
+ find "${D}" -exec touch '{}' \;
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if ! use cdinstall ; then
+ echo
+ elog "You need to copy pak0.pk3 from your Quake3 CD into:"
+ elog " ${dir}/baseq3."
+ elog "Or if you have a Windows installation of Q3 make a symlink to save space."
+ elog
+ elog "Or, re-emerge quake3-data with USE=cdinstall."
+ echo
+ fi
+}