summaryrefslogtreecommitdiff
path: root/games-fps/quake3-cpma/quake3-cpma-1.48.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-fps/quake3-cpma/quake3-cpma-1.48.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-fps/quake3-cpma/quake3-cpma-1.48.ebuild')
-rw-r--r--games-fps/quake3-cpma/quake3-cpma-1.48.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/games-fps/quake3-cpma/quake3-cpma-1.48.ebuild b/games-fps/quake3-cpma/quake3-cpma-1.48.ebuild
new file mode 100644
index 000000000000..78808886c95f
--- /dev/null
+++ b/games-fps/quake3-cpma/quake3-cpma-1.48.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+MOD_DESC="advanced FPS competition mod"
+MOD_NAME="Challenge Pro Mode Arena"
+MOD_DIR="cpma"
+
+inherit games games-mods
+
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="http://packages.vstone.eu/quake3/install/cpma${PV//.}-nomaps.zip
+ http://packages.vstone.eu/quake3/install/cpma-mappack-full.zip"
+
+LICENSE="all-rights-reserved"
+KEYWORDS="amd64 x86"
+IUSE="dedicated opengl"
+
+src_prepare() {
+ mv -f *.pk3 ${MOD_DIR} || die
+}
+
+pkg_postinst() {
+ games-mods_pkg_postinst
+ elog "To enable bots: +bot_enable 1"
+}