summaryrefslogtreecommitdiff
path: root/games-fps/quake2-demodata
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-fps/quake2-demodata
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-fps/quake2-demodata')
-rw-r--r--games-fps/quake2-demodata/Manifest3
-rw-r--r--games-fps/quake2-demodata/metadata.xml8
-rw-r--r--games-fps/quake2-demodata/quake2-demodata-3.14.ebuild59
3 files changed, 70 insertions, 0 deletions
diff --git a/games-fps/quake2-demodata/Manifest b/games-fps/quake2-demodata/Manifest
new file mode 100644
index 000000000000..52965c85ea5e
--- /dev/null
+++ b/games-fps/quake2-demodata/Manifest
@@ -0,0 +1,3 @@
+DIST q2-314-demo-x86.exe 39015499 BLAKE2B 1259d8e2481e5667a1a458e356593b026619a16d8dff32b664143121481f61b5e29129aac6b1aee0c0f0f12eee0f254965355f265c6c66d0ba3acab6e1b5983d SHA512 9aa5123807a64a6e3e3b113b582efd353f176f093fd0aae6bd01d9cff397374c06948a7147f59748b3aa6f4251769e409fae838157edb66429c9d41381b3df86
+EBUILD quake2-demodata-3.14.ebuild 1312 BLAKE2B fde56c8e7c52375e09293e8014aad9cff9044fb5fa5f05cc4fc5baf75e33d7862035144f1019777dd62224dd3a10c59330bf92a5b920cc9fb3a9759638641f1e SHA512 66d0d393d270e6364a58ee26ac9e7e26404431248483248915d557492230f29f8f1ed2cf9141dd4e78c49f8d63a9e091fdf7e0fa8fbb5cd1d5030c02551d700c
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-fps/quake2-demodata/metadata.xml b/games-fps/quake2-demodata/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-fps/quake2-demodata/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-fps/quake2-demodata/quake2-demodata-3.14.ebuild b/games-fps/quake2-demodata/quake2-demodata-3.14.ebuild
new file mode 100644
index 000000000000..cd68c344cd8a
--- /dev/null
+++ b/games-fps/quake2-demodata/quake2-demodata-3.14.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit unpacker eutils versionator games
+
+MY_PV=$(delete_all_version_separators)
+MY_PN="quake2"
+FILE="q2-${MY_PV}-demo-x86.exe"
+
+DESCRIPTION="Demo data for Quake 2"
+HOMEPAGE="https://en.wikipedia.org/wiki/Quake_II"
+SRC_URI="mirror://idsoftware/${MY_PN}/${FILE}"
+
+# See license.txt - it's a bit different to Q2EULA in Portage
+LICENSE="quake2-demodata"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~x86 ~x86-fbsd"
+IUSE="symlink"
+
+RDEPEND=""
+DEPEND="app-arch/unzip
+ !games-fps/quake2-data" # games-fps/quake2-data already includes the demo data
+
+S=${WORKDIR}
+dir=${GAMES_DATADIR}/${MY_PN}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_install() {
+ insinto "${dir}"/demo
+ doins -r Install/Data/baseq2/{pak0.pak,players}
+
+ dodoc Install/Data/DOCS/*.txt
+
+ if use symlink ; then
+ # Make the demo the default, so that people can just run it,
+ # without having to mess with command-line options.
+ cd "${D}/${dir}" && ln -sfn demo baseq2
+ fi
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ elog "This is just the demo data. To play, install a client"
+ elog "such as games-fps/qudos"
+ echo
+
+ if use symlink ; then
+ elog "baseq2 has been symlinked to demo, for convenience, within:"
+ elog "${dir}"
+ echo
+ fi
+}