summaryrefslogtreecommitdiff
path: root/games-fps/quake1-teamfortress
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-fps/quake1-teamfortress
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-fps/quake1-teamfortress')
-rw-r--r--games-fps/quake1-teamfortress/Manifest2
-rw-r--r--games-fps/quake1-teamfortress/quake1-teamfortress-2.9-r1.ebuild (renamed from games-fps/quake1-teamfortress/quake1-teamfortress-2.9.ebuild)28
2 files changed, 14 insertions, 16 deletions
diff --git a/games-fps/quake1-teamfortress/Manifest b/games-fps/quake1-teamfortress/Manifest
index 7cb703baff5d..ef6937537ba6 100644
--- a/games-fps/quake1-teamfortress/Manifest
+++ b/games-fps/quake1-teamfortress/Manifest
@@ -1,4 +1,4 @@
DIST tf28.zip 4204316 BLAKE2B 9cb90e942d58380e8b9fd8ec527232d7461860621ed2bce888fadbbae03ad7c4cfb96035b74dc10c1a3124659869c161bb716178b7d7954fac2a6c828cbbef1f SHA512 2b158982fbf501712fa31fae7b8d34ce4adf41c7ada7c32549bc94ea7370f56b7ebb03f08f70c38c4e53a4ba49a95cbd23acda39eddc4a360d236cc0129a3262
DIST tf29qw.zip 626175 BLAKE2B b480cfc0f3ce330142fc1816632b6da8207b532fac9f5e47fd93d4b1b8bc3fc02dbfc541f1ef052782db0ae6251bec90b09f384e607b6ec9272386b6e18623e4 SHA512 77ea488e5d9fcd3ad91317f2a35bd9e19ca38712cf9bf248bcfa88d1a5a66577ccc504476ecfb5d06bb7a28cd93ce92d3728f4be825c93567c8c2b61cb80c08d
-EBUILD quake1-teamfortress-2.9.ebuild 857 BLAKE2B 25253ea854401ca24110656b077c48c56c7e05d1b743880c9dfac41b5fffe59d682be0218259d4b0f9ffa16709924cd75876c2a730da870861fc1e2e5304ab08 SHA512 1ac13963cc26e7933374a42e33223cf2a06e20b862fa78c00758fd2450b2964794fac98c1fff552420b0e1ade02bf4ec7f665d7da2ab1a8555b666310494469b
+EBUILD quake1-teamfortress-2.9-r1.ebuild 826 BLAKE2B e39ee0cb672da49c4da868b9a157959dc8bd2c696ca354ecf977299e778d8075a503c868b41608703627446e776e84b59b466b6ba5423817a6c83341e9ffb75f SHA512 7fe654b6b9b586213ab0591da775723d3991adf5e819b598da649553aa1cdf2e2a9d90a5561fdd3008c0ae95f07d584e89609782d1d99265dfb99e721b313a6c
MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-fps/quake1-teamfortress/quake1-teamfortress-2.9.ebuild b/games-fps/quake1-teamfortress/quake1-teamfortress-2.9-r1.ebuild
index 19e52511fc51..92573dc42b6e 100644
--- a/games-fps/quake1-teamfortress/quake1-teamfortress-2.9.ebuild
+++ b/games-fps/quake1-teamfortress/quake1-teamfortress-2.9-r1.ebuild
@@ -1,37 +1,35 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils games
+EAPI=7
+
+inherit edos2unix
DESCRIPTION="The classic Team Fortress Quake World mod"
HOMEPAGE="http://www.planetfortress.com/teamfortress/"
SRC_URI="mirror://gentoo/tf28.zip
mirror://gentoo/tf29qw.zip"
+S="${WORKDIR}"
LICENSE="quake1-teamfortress"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND="app-arch/unzip"
-S=${WORKDIR}
+BDEPEND="app-arch/unzip"
src_unpack() {
- echo ">>> Unpacking tf28.zip to ${PWD}"
+ elog "Unpacking tf28.zip to ${PWD}"
unzip -qoL "${DISTDIR}"/tf28.zip || die "unpacking tf28.zip failed"
- cd fortress
- echo ">>> Unpacking tf29qw.zip to ${PWD}"
+
+ cd fortress || die
+ elog "Unpacking tf29qw.zip to ${PWD}"
unzip -qoL "${DISTDIR}"/tf29qw.zip || die "unpacking tf29qw.zip failed"
- edos2unix $(find . -name '*.txt' -o -name '*.cfg')
- mv server.cfg server.example.cfg
+ edos2unix $(find . -name '*.txt' -o -name '*.cfg' || die)
+ mv server.cfg server.example.cfg || die
}
src_install() {
- insinto "${GAMES_DATADIR}/quake1"
+ insinto /usr/share/quake1
doins -r *
- prepgamesdirs
}