summaryrefslogtreecommitdiff
path: root/games-fps/quake1-rally
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-fps/quake1-rally
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-fps/quake1-rally')
-rw-r--r--games-fps/quake1-rally/Manifest2
-rw-r--r--games-fps/quake1-rally/quake1-rally-1.2-r1.ebuild (renamed from games-fps/quake1-rally/quake1-rally-1.2.ebuild)33
2 files changed, 18 insertions, 17 deletions
diff --git a/games-fps/quake1-rally/Manifest b/games-fps/quake1-rally/Manifest
index a4d4981e02b7..d520b797bcbb 100644
--- a/games-fps/quake1-rally/Manifest
+++ b/games-fps/quake1-rally/Manifest
@@ -1,4 +1,4 @@
DIST qr12.zip 9885866 BLAKE2B a2fa1ad28033bd5530c53c132b44732325fcfc58585474859b6e3cc34c94751142ff69bcaf01062a8adb16e259583bae923c90d294b08ea7278862621c39a8b2 SHA512 a49b00e67b95c06b4898ad8e1f9e0a718c025736e7d68d3aa8e6ff9cf3062ea8a0cd0ea0deee5c2af8e3e30652c4420cd4b030b3bd8f1dd4ace9236bfaaf5e5a
DIST qrlo1.zip 4086037 BLAKE2B 066945f0121efe38a222dc475d30d759ad50ab0c58f98e798955b18b3723001e2aeeac8d2627972bb3e9706786032ccf53e7fd96874815ae13f9167589435854 SHA512 94af61a0f6978c39425cbc414e094417deef99f109aac2905877b3723873657c3ef7d7ae7d3b247144d68eabbfb79750a654e627ac039d315ff0f2fd323f395d
-EBUILD quake1-rally-1.2.ebuild 929 BLAKE2B b446cebd96148077c9f0756cf711bd19c8b409e71521edc2e9ee8eb6150fb7517724077a003e3d2feca957b410d201a8739e907314bdb22b80c45b9b236ea659 SHA512 efba1aed594e9a8e759654165f7967c9e2c96409a3fbc117e07fd5800dd8b2741baf96840b3a4c5f477dc69493e7085734a1b857f5b73d5c9290c634badb913d
+EBUILD quake1-rally-1.2-r1.ebuild 910 BLAKE2B 0df1015273f0584d15ca56d86f2ac46ff6c661104726be926423d40c08aab9201a741f07b1e581d0da42ddd50395d2cb28ae74b62fc5818d33506d70b9ac80d4 SHA512 b93d6388833bc37fb5fd2d4c3a551d817e7a18a111b72b1611d3fd45c69f7dcb15c5a4c0da1c91dfb5bfbfd728f7252c6139b8bac2e9de68ff3862b13a0e7321
MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-fps/quake1-rally/quake1-rally-1.2.ebuild b/games-fps/quake1-rally/quake1-rally-1.2-r1.ebuild
index e7c086e83cbe..5b4137c84763 100644
--- a/games-fps/quake1-rally/quake1-rally-1.2.ebuild
+++ b/games-fps/quake1-rally/quake1-rally-1.2-r1.ebuild
@@ -1,38 +1,39 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils games
+EAPI=7
+
+inherit edos2unix
DESCRIPTION="TC which turns Quake into a Rally racing game"
HOMEPAGE="http://wiki.quakeworld.nu/Quake_Rally"
SRC_URI="http://ehall.freeshell.org/quake/qr12.zip
http://ehall.freeshell.org/quake/qrlo1.zip"
+S="${WORKDIR}"
LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-RESTRICT="mirror bindist"
-RDEPEND=""
-DEPEND="app-arch/unzip"
+RESTRICT="mirror bindist"
-S=${WORKDIR}
+BDEPEND="app-arch/unzip"
src_unpack() {
- echo ">>> Unpacking qr12.zip to ${PWD}"
+ einfo "Unpacking qr12.zip to ${PWD}"
unzip -qoLL "${DISTDIR}"/qr12.zip || die "unpacking qr12.zip failed"
- echo ">>> Unpacking qrlo1.zip to ${PWD}"
+
+ einfo "Unpacking qrlo1.zip to ${PWD}"
unzip -qoLL "${DISTDIR}"/qrlo1.zip || die "unpacking qrlo1.zip failed"
- rm -f button.wav qrally.exe
- cd rally
- edos2unix $(find . -name '*.txt' -o -name '*.cfg')
- mv rally{,.example}.cfg
+
+ rm -f button.wav qrally.exe || die
+ cd rally || die
+
+ edos2unix $(find . -name '*.txt' -o -name '*.cfg' || die)
+ mv rally{,.example}.cfg || die
}
src_install() {
- insinto "${GAMES_DATADIR}/quake1"
+ insinto /usr/share/quake1
doins -r *
- prepgamesdirs
}