summaryrefslogtreecommitdiff
path: root/games-fps/quake1-demodata
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-fps/quake1-demodata
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-fps/quake1-demodata')
-rw-r--r--games-fps/quake1-demodata/Manifest3
-rw-r--r--games-fps/quake1-demodata/metadata.xml8
-rw-r--r--games-fps/quake1-demodata/quake1-demodata-1.06.ebuild81
3 files changed, 92 insertions, 0 deletions
diff --git a/games-fps/quake1-demodata/Manifest b/games-fps/quake1-demodata/Manifest
new file mode 100644
index 000000000000..42a818047274
--- /dev/null
+++ b/games-fps/quake1-demodata/Manifest
@@ -0,0 +1,3 @@
+DIST quake106.zip 9094045 BLAKE2B 39d639a7c4daf48bacfed3d8f7488131cabd61eba3d1969b23958f4f35ac7f693a165500a4a1cf2b917bb8d363d360a402c7100ba8f6b7083c7eaba1fe16756a SHA512 8960c48d9c3c8bb142fd812968d29f05304384bd559b5cdb1d2cb8b6faac84d30ebf9cdf5e5e4eb3739907d9b599ca2ba34035647c58a8ed1874bdc7f0b75e1d
+EBUILD quake1-demodata-1.06.ebuild 1649 BLAKE2B 0cb318c5343cec04bc601b03b08ce00c31f28ea67757e6ea066a1786b30399ebe0e5ad1f4df8ebb0f260b0d9fd63f204f5813676900cb93841022f73b3a787d7 SHA512 5e54e5e87fbe59ba0a08ffdeea300958ec4c7246fc984ef72e565028c328a4420ec4a51f55e181755e28a8f1572182a4a77badd225b04f45ca6b3dcafe88e98b
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-fps/quake1-demodata/metadata.xml b/games-fps/quake1-demodata/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-fps/quake1-demodata/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-fps/quake1-demodata/quake1-demodata-1.06.ebuild b/games-fps/quake1-demodata/quake1-demodata-1.06.ebuild
new file mode 100644
index 000000000000..7b8a34815e89
--- /dev/null
+++ b/games-fps/quake1-demodata/quake1-demodata-1.06.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils versionator games
+
+MY_PV=$(delete_all_version_separators)
+MY_PN="quake"
+
+DESCRIPTION="Demo data for Quake 1"
+HOMEPAGE="https://en.wikipedia.org/wiki/Quake_I"
+SRC_URI="mirror://idsoftware/${MY_PN}/${MY_PN}${MY_PV}.zip"
+
+# See licinfo.txt
+LICENSE="quake1-demodata"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="symlink"
+
+RDEPEND=""
+DEPEND="app-arch/lha
+ app-arch/unzip"
+
+S=${WORKDIR}
+dir=${GAMES_DATADIR}/${MY_PN}1
+
+pkg_setup() {
+ games_pkg_setup
+
+ if has_version "games-fps/quake1-data" ; then
+ ewarn "games-fps/quake1-data already includes the demo data,"
+ ewarn "so this installation is not very useful."
+ echo
+ if use symlink ; then
+ eerror "The symlink for the demo data conflicts with the cdinstall data"
+ die "Remove the 'symlink' USE flag for this package"
+ fi
+ ebeep
+ epause
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # File rename for bug #159100
+ mv resource.{1,x}
+
+ lha xfq resource.x || die "lha failed"
+ # Don't want to conflict with the cdinstall files
+ mv id1 demo
+}
+
+src_install() {
+ insinto "${dir}"
+ doins -r demo
+
+ dodoc *.txt
+
+ if use symlink ; then
+ # Make the demo the default, so that people can just run it,
+ # without having to mess with command-line options.
+ cd "${D}/${dir}" && ln -sfn demo id1
+ fi
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ elog "This is just the demo data."
+ elog "You will still need a Quake 1 client, to play, such as darkplaces."
+ echo
+
+ if use symlink ; then
+ elog "id1 has been symlinked to demo, for convenience, within:"
+ elog "${dir}"
+ echo
+ fi
+}