summaryrefslogtreecommitdiff
path: root/games-fps/quake1-data
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-fps/quake1-data
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-fps/quake1-data')
-rw-r--r--games-fps/quake1-data/Manifest2
-rw-r--r--games-fps/quake1-data/quake1-data-2.40-r1.ebuild (renamed from games-fps/quake1-data/quake1-data-2.40.ebuild)34
2 files changed, 19 insertions, 17 deletions
diff --git a/games-fps/quake1-data/Manifest b/games-fps/quake1-data/Manifest
index d21843d68a07..27a4226d95e5 100644
--- a/games-fps/quake1-data/Manifest
+++ b/games-fps/quake1-data/Manifest
@@ -1,2 +1,2 @@
-EBUILD quake1-data-2.40.ebuild 1558 BLAKE2B 9ba56a23eef6458886be77c0e1fa3f166cf20d274621efdfaa9a3f28a8f633bbf6d03cb08d74823ad528c8427b2eabade9150ad5835953abe130cd5271b37a57 SHA512 5e98400af621f614a9e69e975b9dc9a76bbd086883ccc64d5fc034228d2cf465174dae33601eef2c206a6db4fa20e984c02b76ffe530ffae973cb173ffe5e9e6
+EBUILD quake1-data-2.40-r1.ebuild 1515 BLAKE2B 55f6f0dde2b47b1bdcb41ce669b28ff8d12bbf95787c23f45b483ff905a376bfac602a12f6d87005998b5a025e2de4d0ef23d2d57288360426a719d45c239932 SHA512 42fb00f20a89360dc8a335611b956a63b4aa0b314f6856afbbea00c8740709d5f8d10a3e70d1c3eac715e6f0362c7b6085fc31c62a13a39b3b880a90caac9482
MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-fps/quake1-data/quake1-data-2.40.ebuild b/games-fps/quake1-data/quake1-data-2.40-r1.ebuild
index 6c3c9e1eb193..ed730aa32cb3 100644
--- a/games-fps/quake1-data/quake1-data-2.40.ebuild
+++ b/games-fps/quake1-data/quake1-data-2.40-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# TODO: if installing off of the 1.01 cd, need to fetch the
@@ -6,51 +6,53 @@
# http://linux.omnipotent.net/article.php?article_id=11287
# ftp://ftp.cdrom.com/pub/idgames/idstuff/quake/quake106.zip
-EAPI=5
-inherit eutils cdrom games
+EAPI=7
+
+inherit cdrom
DESCRIPTION="iD Software's Quake 1 ... the data files"
HOMEPAGE="https://www.idsoftware.com/games/quake/quake/"
-SRC_URI=""
+S="${WORKDIR}"
LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="app-arch/lha"
RDEPEND="!games-fps/quake1-demodata[symlink]"
-
-S=${WORKDIR}
+BDEPEND="app-arch/lha"
src_unpack() {
export CDROM_NAME_SET=("Existing Install" "Quake CD (1.01)" "Ultimate Quake Collection" "Quake CD (newer)")
cdrom_get_cds id1:q101_int.1:Setup/ID1:resource.1
+
if [[ ${CDROM_SET} == "1" ]] ; then
- echo ">>> Unpacking q101_int.lha to ${PWD}"
+ elog "Unpacking q101_int.lha to ${PWD}"
cat "${CDROM_ROOT}"/q101_int.1 "${CDROM_ROOT}"/q101_int.2 > \
"${S}"/q101_int.exe
+
lha xqf "${S}"/q101_int.exe || die
- rm -f q101_int.exe
+ rm -f q101_int.exe || die
elif [[ ${CDROM_SET} == "3" ]] ; then
- echo ">>> Unpacking resource.1 to ${PWD}"
+ elog "Unpacking resource.1 to ${PWD}"
lha xqf "${CDROM_ROOT}"/resource.1 || die
fi
}
src_install() {
- insinto "${GAMES_DATADIR}"/quake1/id1
+ insinto /usr/share/quake1/id1
case ${CDROM_SET} in
- 0) doins "${CDROM_ROOT}"/id1/*
+ 0)
+ doins "${CDROM_ROOT}"/id1/*
dodoc "${CDROM_ROOT}"/*.txt
;;
- 1|3)doins id1/*
+ 1|3)
+ doins id1/*
dodoc *.txt
;;
- 2) newins "${CDROM_ROOT}"/Setup/ID1/PAK0.PAK pak0.pak
+ 2)
+ newins "${CDROM_ROOT}"/Setup/ID1/PAK0.PAK pak0.pak
newins "${CDROM_ROOT}"/Setup/ID1/PAK1.PAK pak1.pak
dodoc "${CDROM_ROOT}"/Docs/*
;;
esac
- prepgamesdirs
}