summaryrefslogtreecommitdiff
path: root/games-fps/legends
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-fps/legends
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-fps/legends')
-rw-r--r--games-fps/legends/Manifest4
-rw-r--r--games-fps/legends/legends-0.4.1.43-r2.ebuild69
-rw-r--r--games-fps/legends/metadata.xml31
3 files changed, 104 insertions, 0 deletions
diff --git a/games-fps/legends/Manifest b/games-fps/legends/Manifest
new file mode 100644
index 000000000000..73c8d619d299
--- /dev/null
+++ b/games-fps/legends/Manifest
@@ -0,0 +1,4 @@
+DIST legends.png 5092 BLAKE2B 74715a28e6c25e3ce9a3357be23b07a998181e12e7a19d721b094c10b7f1312b273307ad1ac2830c0d71a710434be679149e0d758ee5a785cebc6b71d91f965f SHA512 7b9f336335dc69e2fbc24286b2076a228739ab4abf1b77d977321d9dccfb453897bdbd51388e3ed54369ba39b7faa92e458700928d8bf5ccc0f3639f8737489a
+DIST legends_linux-0.4.1.43.run 123964866 BLAKE2B d16da9613a13c4d78d207fc474b859e222d6c387a676bc2fe851f34fed7e689a5457a022674e2e96abd7cfc8e9e68977078811147ffe44388986796a2157cd69 SHA512 17b1caa3aa6124f2389e2220ced82c41c4523897bde2f8211d219dc9ef8620583c4ae68999b0761155e3d45cb1ad9679cd65ba50c8440dd1848ef3b1a7a590d2
+EBUILD legends-0.4.1.43-r2.ebuild 1856 BLAKE2B 17a7e175a6d5ec4f9914b7436c909ee1e20eadcbf711b7030385d2c45162eb7414a453aeaa18aa2269d96c1512c198dd15106a0c942fb61bc9ef5611a2f5465e SHA512 f0c2de1529d004821b6b308553b1845908ce04e6ae85c2da00f788b935e91cde46bceeb22585064f3a1bd7c7238082f2eb9bb7a14d6324694774c175c6df28e6
+MISC metadata.xml 1427 BLAKE2B c9e4086f3639e290c414a48d30a56a56c9f541f2e4ad082a19f6361c55f2f57e862ab571e27d63bdb04702c64c2bc53404d345a8f1328902d03aaac2b4f3d150 SHA512 987ace71750e486c141c1010d1699194c656fda09a4952b51b31ad8f526de8f77372e57632d1636034e6de080871a4fc3140b1e2a49e98b3758d907a0eb3bba3
diff --git a/games-fps/legends/legends-0.4.1.43-r2.ebuild b/games-fps/legends/legends-0.4.1.43-r2.ebuild
new file mode 100644
index 000000000000..0412178e3f4b
--- /dev/null
+++ b/games-fps/legends/legends-0.4.1.43-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils unpacker
+
+MY_P=${PN}_linux-${PV}
+dir=/opt/${PN}
+
+DESCRIPTION="Fast-paced first-person-shooter online multiplayer game, similar to Tribes"
+HOMEPAGE="http://legendsthegame.net/"
+SRC_URI="http://legendsthegame.net/files/${MY_P}.run
+ mirror://gentoo/${PN}.png"
+
+LICENSE="Legends LGPL-2.1+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="+dedicated"
+RESTRICT="strip"
+
+QA_TEXTRELS="${dir:1}/libSDL-1.3.so.0"
+QA_FLAGS_IGNORED="${dir:1}/libSDL-1.3.so.0 ${dir:1}/LinLegends ${dir:1}/lindedicated"
+
+DEPEND=""
+RDEPEND="sys-libs/glibc
+ amd64? ( sys-libs/glibc[multilib] )
+ media-fonts/font-adobe-75dpi
+ media-libs/libsdl[video,sound,opengl,abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ media-libs/libogg[abi_x86_32(-)]
+ media-libs/libvorbis[abi_x86_32(-)]
+ media-libs/openal[abi_x86_32(-)]"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack_makeself ${MY_P}.run
+ cd "${S}"
+
+ # keep libSDL-1.3.so because legends requires it as of 0.4.0, and
+ # 1.2.6 is highest in portage
+ # rm libSDL-*.so*
+ rm runlegends libSDL-1.2.so.0 libopenal.so libogg.so.0 libvorbis.so.0 *.DLL || die
+}
+
+src_install() {
+ insinto "${dir}"
+ doins -r * || die "doins * failed"
+
+ rm "${D}/${dir}/"/{lindedicated,LinLegends,*.so.0}
+ exeinto "${dir}"
+ doexe lindedicated LinLegends *.so.0 || die "doexe failed"
+
+ make_wrapper ${PN} "./LinLegends" "${dir}" "${dir}"
+ if use dedicated ; then
+ make_wrapper ${PN}-ded "./lindedicated" "${dir}" "${dir}"
+ fi
+
+ doicon "${DISTDIR}"/${PN}.png || die "doicon failed"
+ make_desktop_entry legends "Legends"
+}
+
+pkg_postinst() {
+ ewarn "Version ${PV} of ${PN} may give problems if there are"
+ ewarn "config-files from earlier versions. Removing the ~/.legends dir"
+ ewarn "and restarting will solve this."
+ echo
+}
diff --git a/games-fps/legends/metadata.xml b/games-fps/legends/metadata.xml
new file mode 100644
index 000000000000..f1ba53514225
--- /dev/null
+++ b/games-fps/legends/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+<longdescription>
+Legends is a fast-paced first-person-perspective online multiplayer
+game. The game is designed to take advantage of the beautiful
+environments available from the Torque engine it is based on while still
+offering the breakneck pacing and variety of styles available from such
+classics as Quake and Tribes.
+
+Gameplay is not the strafe-strafe-jump-strafe-shoot-strafe-run-like-hell
+style a lot of games espouse; the addition of a jetpack adds a third
+dimension of mobility that makes skill, forethought, and restraint
+necessities to winning.
+
+Team sizes are going to be ideal between 10 and 15 on each side, and the
+network code will allow anyone with any bandwidth to play relatively
+smoothly. Game type offerings will range from the classic Capture the
+Flag to our own new type, affectionately called "Knockout".
+
+Plenty of maps will be provided by us, but the beauty of this game is
+its customization possibilities. Mission creation has never been easier,
+with a stable, full-featured editor integrated into the game engine
+itself. Skins, models, and effects can all be modified by the end-user
+with commonly available tools.
+</longdescription>
+</pkgmetadata>