summaryrefslogtreecommitdiff
path: root/games-fps/gzdoom/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /games-fps/gzdoom/files
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'games-fps/gzdoom/files')
-rw-r--r--games-fps/gzdoom/files/gzdoom-4.4.2-Force-STATIC-for-internal-GZDoom-SPIRV-library.patch30
-rw-r--r--games-fps/gzdoom/files/gzdoom-4.4.2-Introduce-the-BUILD_NONFREE-option.patch35
2 files changed, 65 insertions, 0 deletions
diff --git a/games-fps/gzdoom/files/gzdoom-4.4.2-Force-STATIC-for-internal-GZDoom-SPIRV-library.patch b/games-fps/gzdoom/files/gzdoom-4.4.2-Force-STATIC-for-internal-GZDoom-SPIRV-library.patch
new file mode 100644
index 000000000000..779268ca6d7e
--- /dev/null
+++ b/games-fps/gzdoom/files/gzdoom-4.4.2-Force-STATIC-for-internal-GZDoom-SPIRV-library.patch
@@ -0,0 +1,30 @@
+From c904b7521657e55843bae34f1f958d689538b13b Mon Sep 17 00:00:00 2001
+From: William Breathitt Gray <vilhelm.gray@gmail.com>
+Date: Wed, 17 Jun 2020 15:17:49 -0400
+Subject: [PATCH] Force STATIC for internal GZDoom SPIRV library
+
+This makes sure the internal version of this library bundled with the
+GZDoom source code is used. This prevents the system from building
+GZDoom for dynamic linking with an incompatible external library (see
+commit 6fafa297bfe0f82696d898d66e39c50f4f5eef16 and
+<https://forum.zdoom.org/viewtopic.php?f=2&t=64633>).
+---
+ libraries/glslang/spirv/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libraries/glslang/spirv/CMakeLists.txt b/libraries/glslang/spirv/CMakeLists.txt
+index 453ac16b5..d39a6e300 100644
+--- a/libraries/glslang/spirv/CMakeLists.txt
++++ b/libraries/glslang/spirv/CMakeLists.txt
+@@ -49,7 +49,7 @@ set(SPVREMAP_HEADERS
+ SPVRemapper.h
+ doc.h)
+
+-add_library(SPIRV ${LIB_TYPE} ${SOURCES} ${HEADERS})
++add_library(SPIRV STATIC ${LIB_TYPE} ${SOURCES} ${HEADERS})
+ set_property(TARGET SPIRV PROPERTY FOLDER glslang)
+ set_property(TARGET SPIRV PROPERTY POSITION_INDEPENDENT_CODE ON)
+ target_include_directories(SPIRV PUBLIC
+--
+2.26.2
+
diff --git a/games-fps/gzdoom/files/gzdoom-4.4.2-Introduce-the-BUILD_NONFREE-option.patch b/games-fps/gzdoom/files/gzdoom-4.4.2-Introduce-the-BUILD_NONFREE-option.patch
new file mode 100644
index 000000000000..d7ece785e25d
--- /dev/null
+++ b/games-fps/gzdoom/files/gzdoom-4.4.2-Introduce-the-BUILD_NONFREE-option.patch
@@ -0,0 +1,35 @@
+From decf1df37a22c87da78230941209c110f7763f4b Mon Sep 17 00:00:00 2001
+From: William Breathitt Gray <vilhelm.gray@gmail.com>
+Date: Sat, 31 Aug 2019 21:23:23 +0900
+Subject: [PATCH] Introduce the BUILD_NONFREE option
+
+This allow users to disable building nonfree components (brightmaps.pk3
+and game_support.pk3) if they so desire.
+---
+ CMakeLists.txt | 8 ++++++--
+ 1 file changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4e59452..c2f49b2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -393,10 +393,14 @@ add_subdirectory( libraries/lzma )
+ add_subdirectory( tools )
+ add_subdirectory( libraries/gdtoa )
+ add_subdirectory( wadsrc )
+-add_subdirectory( wadsrc_bm )
+ add_subdirectory( wadsrc_lights )
+-add_subdirectory( wadsrc_extra )
+ add_subdirectory( src )
++option (BUILD_NONFREE "Build nonfree components" ON)
++if( BUILD_NONFREE )
++ add_subdirectory( wadsrc_bm )
++ add_subdirectory( wadsrc_extra )
++endif()
++
+
+ if( NOT CMAKE_CROSSCOMPILING )
+ export(TARGETS ${CROSS_EXPORTS} FILE "${CMAKE_BINARY_DIR}/ImportExecutables.cmake" )
+--
+2.26.2
+