summaryrefslogtreecommitdiff
path: root/games-fps/ezquake-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-fps/ezquake-bin
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-fps/ezquake-bin')
-rw-r--r--games-fps/ezquake-bin/Manifest6
-rw-r--r--games-fps/ezquake-bin/ezquake-bin-2.2.ebuild71
-rw-r--r--games-fps/ezquake-bin/metadata.xml11
3 files changed, 88 insertions, 0 deletions
diff --git a/games-fps/ezquake-bin/Manifest b/games-fps/ezquake-bin/Manifest
new file mode 100644
index 000000000000..87e86e0d944c
--- /dev/null
+++ b/games-fps/ezquake-bin/Manifest
@@ -0,0 +1,6 @@
+DIST ezquake_linux-x86_1.9.3.tar.gz 19230315 BLAKE2B df2128f8aa05a1e4d970b52d193539a93ac2d849720859d97a223a5dc313ff7142bfbc0dd2ac405eede96e247d032483c392c9d1fe0d20e107fbd4be79210fd7 SHA512 c362b0103fa4beb578fec5653b4b9196d0202a00c662e3e001615c07041968daa7bd8edf194e310ac8501d01768b2bda79e250830733fb4dd56cb1517844d79f
+DIST ezquake_linux-x86_64.1.9.3.tar.gz 18624824 BLAKE2B 619d2ef3c03a9d105000c75c0c2d21398d4080810b7cab6d6a143ac0a4513420f0756c01d932f7332cbd87dfba335d6b82b1ee122fb94c2fcf4331e7beab7689 SHA512 4c2f5060bbf08ca3b9583d4c3502e69bf6d503efd0e14df9d5fe54e1e8ac1c5ca0b920c3748e4a8e1f86c60d6e5809977352636d4758fd9cb3934cea03b1138f
+DIST ezquake_linux32_2.2.tar.gz 1685934 BLAKE2B f4e1374992ac548c45ca59161c0e86214f50db17502f6bc89d56ec4e9c596478399ff02c86a539e3590f0ad82d90dd7b2f02df25089573068b4e24e1085d0898 SHA512 2a42b43a0b4ad75c22c58bb53f8161eec1460cac3b841ccf2593e0cb803c4ef5cee23f939f859eb6d95409a01c4ccc3eabae108eac6c1cb850f9c5c3445bf5ab
+DIST ezquake_linux64_2.2.tar.gz 1804397 BLAKE2B 9ad294fda829a9dd68201a7c5deb9e3a708f4ac81caa97745e965bcececfc0c1aa787b53ad5465238452bee4ded256214eb234658e8bc17795ef519faaa67057 SHA512 c1f1772971980a7b349da6c6eea5643591d5bc81a939b28e50651c5773d8372277fb6bc9a5681c59e8273ca6250fa712c3b76db488bf521dd3675aabd5e1af8e
+EBUILD ezquake-bin-2.2.ebuild 1947 BLAKE2B 320e929a05931406741c86197f2942edd1f5ced3e39624d3cc548cceff87213987b444d2941ff9c89e5719953a21aa0780dbe3c812b80e2f9b7d158986df95ff SHA512 00f22b5412d339d18b4d533cf976ae604649473ccf98217425977959f323980d06e2c9fa534c2e4bb0c94e0a124a8f2110316d7668bfeb5797c9edc261e9252f
+MISC metadata.xml 340 BLAKE2B 0e535869685c648fd759901404ee04e736d85783bd09f34756917ce5bfb1239048accdf32fd59ae3a11828da8dbc6ca1b337f28259013b864b9e02e687758cac SHA512 4922600550155470211bb2fe2eab50f02e120d82261d2956f7f73604ec5e76c71e37be5d9a542d9f963eaa0927da7bcb9b464428a7b778d17a383135e423063e
diff --git a/games-fps/ezquake-bin/ezquake-bin-2.2.ebuild b/games-fps/ezquake-bin/ezquake-bin-2.2.ebuild
new file mode 100644
index 000000000000..5e6fe5800999
--- /dev/null
+++ b/games-fps/ezquake-bin/ezquake-bin-2.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit games
+
+MY_FULL_PV=1.9.3
+MY_PN="${PN/-bin/}"
+DESCRIPTION="Quakeworld client with mqwcl functionality and many more features"
+HOMEPAGE="http://ezquake.sf.net/"
+SRC_URI="
+ amd64? ( mirror://sourceforge/${MY_PN}/${MY_PN}_linux-x86_64.${MY_FULL_PV}.tar.gz
+ mirror://sourceforge/${MY_PN}/${MY_PN}_linux64_${PV}.tar.gz )
+ x86? ( mirror://sourceforge/${MY_PN}/${MY_PN}_linux-x86_${MY_FULL_PV}.tar.gz
+ mirror://sourceforge/${MY_PN}/${MY_PN}_linux32_${PV}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="strip mirror"
+IUSE="cdinstall"
+
+DEPEND="cdinstall? ( games-fps/quake1-data )"
+RDEPEND="${DEPEND}
+ virtual/opengl
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm"
+
+S=${WORKDIR}/${MY_PN}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+
+QA_PREBUILT="${dir:1}/ezquake*"
+
+src_unpack() {
+ unpack ${A}
+ if use amd64; then
+ mv ${MY_PN}_linux-x86_64.${MY_FULL_PV} "${MY_PN}"
+ mv ezquake-gl_linux-x64.glx "${MY_PN}"/ezquake-gl.glx
+ else
+ mv ${MY_PN}_linux-x86.${MY_FULL_PV} "${MY_PN}"
+ mv ezquake-gl_linux-x86.glx "${MY_PN}"/ezquake-gl.glx
+ fi
+}
+
+src_install() {
+ exeinto "${dir}"
+ insinto "${dir}"
+
+ doexe ezquake-gl.glx
+ doins -r ezquake qw
+ dosym "${GAMES_DATADIR}"/quake1/id1 "${dir}"/id1
+ games_make_wrapper ezquake-gl.glx ./ezquake-gl.glx "${dir}" "${dir}"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ if ! use cdinstall; then
+ elog "NOTE that this client doesn't include .pak files. You *should*"
+ elog "enable \"cdinstall\" flag or install quake1-demodata with the symlink use flag."
+ elog "You can also copy the files from your Quake1 CD to"
+ elog " ${dir}/quake1/id1 (all names lowercase)"
+ elog ""
+ elog "You may also want to check:"
+ elog " http://fuhquake.quakeworld.nu - complete howto on commands and variables"
+ elog " http://equake.quakeworld.nu - free package containing various files"
+ fi
+}
diff --git a/games-fps/ezquake-bin/metadata.xml b/games-fps/ezquake-bin/metadata.xml
new file mode 100644
index 000000000000..8789378885ba
--- /dev/null
+++ b/games-fps/ezquake-bin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">ezquake</remote-id>
+ </upstream>
+</pkgmetadata>