summaryrefslogtreecommitdiff
path: root/games-fps/doomsday/doomsday-2.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-25 13:01:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-25 13:01:09 +0000
commitecf595717796995cab38a07093dc9597d55d0ea6 (patch)
tree54c2bcea4aafadac2dffe16181af3f0c7dea045e /games-fps/doomsday/doomsday-2.3.1.ebuild
parent50c71de793c37c19d34a68b3af53ba5e7ca51d22 (diff)
gentoo auto-resync : 25:03:2024 - 13:01:08
Diffstat (limited to 'games-fps/doomsday/doomsday-2.3.1.ebuild')
-rw-r--r--games-fps/doomsday/doomsday-2.3.1.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/games-fps/doomsday/doomsday-2.3.1.ebuild b/games-fps/doomsday/doomsday-2.3.1.ebuild
index e47741325506..26cd12c34b90 100644
--- a/games-fps/doomsday/doomsday-2.3.1.ebuild
+++ b/games-fps/doomsday/doomsday-2.3.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{9..10} )
-inherit cmake python-any-r1 qmake-utils readme.gentoo-r1 xdg
+inherit cmake flag-o-matic python-any-r1 qmake-utils readme.gentoo-r1 xdg
DESCRIPTION="A modern gaming engine for Doom, Heretic, and Hexen"
HOMEPAGE="https://www.dengine.net"
@@ -55,6 +55,14 @@ src_prepare() {
}
src_configure() {
+ # -Werror=odr, -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/858743
+ #
+ # Currently working on reporting an upstream bug. Four different websites
+ # including sourceforge and github but the only place for submitting bugs
+ # is a self-hosted redmine that has disabled registration.
+ filter-lto
+
local mycmakeargs=(
-DDENG_ASSIMP_EMBEDDED=OFF
-DDENG_ENABLE_DISPLAYMODE=$(usex display-mode)