summaryrefslogtreecommitdiff
path: root/games-fps/doomsday/doomsday-2.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /games-fps/doomsday/doomsday-2.1.1.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'games-fps/doomsday/doomsday-2.1.1.ebuild')
-rw-r--r--games-fps/doomsday/doomsday-2.1.1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/games-fps/doomsday/doomsday-2.1.1.ebuild b/games-fps/doomsday/doomsday-2.1.1.ebuild
index 757a7f8c4729..8eb5fd81fbea 100644
--- a/games-fps/doomsday/doomsday-2.1.1.ebuild
+++ b/games-fps/doomsday/doomsday-2.1.1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python2_7 python3_{6,7} )
-inherit cmake-utils python-any-r1 readme.gentoo-r1
+inherit cmake python-any-r1 readme.gentoo-r1
DESCRIPTION="A modern gaming engine for Doom, Heretic, and Hexen"
HOMEPAGE="https://www.dengine.net"
@@ -45,7 +45,7 @@ S="${WORKDIR}/${P}/${PN}"
DOC_CONTENTS="You need to copy Doom, Doom 2, Chex Quest, Heretic, Hexen, HexenDD, or Doom64 wads to a folder of your choice and then tell the game engine where that folder is. This is different to older versions, which had separate launchers for each game and required the files to be in a specific place."
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# Fix QA warning for "installing to one or more unexpected paths"
sed -e "10s:/texc:/${PF}:" -i tools/texc/CMakeLists.txt || die
@@ -58,11 +58,11 @@ src_configure() {
-DDENG_ENABLE_TOOLS="$(usex tools)"
-DPYTHON_EXECUTABLE="${PYTHON}"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use tools; then
mv -v "${ED}"/usr/bin/md2tool{,.${PN}} || die