summaryrefslogtreecommitdiff
path: root/games-fps/doom3-demo/doom3-demo-1.1.1286-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-fps/doom3-demo/doom3-demo-1.1.1286-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-fps/doom3-demo/doom3-demo-1.1.1286-r1.ebuild')
-rw-r--r--games-fps/doom3-demo/doom3-demo-1.1.1286-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/games-fps/doom3-demo/doom3-demo-1.1.1286-r1.ebuild b/games-fps/doom3-demo/doom3-demo-1.1.1286-r1.ebuild
new file mode 100644
index 000000000000..c3f4751a0421
--- /dev/null
+++ b/games-fps/doom3-demo/doom3-demo-1.1.1286-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils unpacker games
+
+DESCRIPTION="Doom III - 3rd installment of the classic id 3D first-person shooter"
+HOMEPAGE="http://www.doom3.com/"
+SRC_URI="mirror://3dgamers/doom3/doom3-linux-${PV}-demo.x86.run
+ mirror://idsoftware/doom3/linux/doom3-linux-${PV}-demo.x86.run
+ mirror://gentoo/doom3.png"
+
+LICENSE="DOOM3"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="strip mirror"
+QA_EXECSTACK="${GAMES_PREFIX_OPT:1}/${PN}/*"
+
+# Do not remove the amd64 dep unless you are POSITIVE that it is not necessary.
+# See bug #88227 for more.
+RDEPEND="sys-libs/glibc
+ sys-libs/libstdc++-v3:5
+ amd64? ( sys-libs/glibc[multilib] sys-libs/libstdc++-v3:5[multilib] )
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+src_unpack() {
+ unpack_makeself doom3-linux-${PV}-demo.x86.run
+}
+
+src_install() {
+ insinto "${dir}"
+ doins License.txt README version.info
+
+ insinto "${dir}"/demo
+ doins demo/* || die "doins base"
+
+ exeinto "${dir}"
+ doexe gamex86.so bin/Linux/x86/doom.x86
+
+ newicon "${DISTDIR}"/doom3.png ${PN}.png
+
+ games_make_wrapper ${PN} ./doom.x86 "${dir}" "${dir}"
+ make_desktop_entry ${PN} "Doom III (Demo)"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ elog "To play the game run:"
+ elog " doom3-demo"
+}