summaryrefslogtreecommitdiff
path: root/games-fps/doom-data
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-fps/doom-data
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-fps/doom-data')
-rw-r--r--games-fps/doom-data/Manifest3
-rw-r--r--games-fps/doom-data/doom-data-1-r2.ebuild40
-rw-r--r--games-fps/doom-data/metadata.xml11
3 files changed, 54 insertions, 0 deletions
diff --git a/games-fps/doom-data/Manifest b/games-fps/doom-data/Manifest
new file mode 100644
index 000000000000..c4056bcb87f6
--- /dev/null
+++ b/games-fps/doom-data/Manifest
@@ -0,0 +1,3 @@
+DIST doom1.wad.bz2 1689021 BLAKE2B 45ab359525cec44ac6f58110be80e76a75e0d5e186c1fc6bb67e055e7a7e03d2596c2e99cb3636484245d1af85d6b93830f07d8548df99f5f40e55d249bcef16 SHA512 f3aa78fd1e36d2dbd176c8c5284f8cee4f39d8e34df5386fd668565e752410e2b776413c78c1e7a3571695a1668f1e4820338ebc9a2b1a0ed1a81896260534fe
+EBUILD doom-data-1-r2.ebuild 900 BLAKE2B 9a8e2c28cbc9dbc48fb6e986f557fe7629752358822af27a833f7172ef52bde43da146cb855ffc8ebfea4bc920dd4b58ad3088dbaaffa3eabb3ad14910e7639b SHA512 c0b0d7b36df52b3165a07d63297fa14513d6fc1ee01cb0174c8333def136b1ab197dc9ea1c338a58098c003b2c980c6d52397cd316a823a6a89dca2414aafdc4
+MISC metadata.xml 347 BLAKE2B 4655211a8c43a4659d40a685721f45ba4abce6277eba9ec94b19755dff4824feef2bb704d7f5746cb43d91eef2ab9f72a47fe4a116f994cddb8bcc0cf7371180 SHA512 2cf8dbebdc411b37294374d196748fa23a741e5ae37946d87b74fabba84dc67811db3f5e215b82be1ec0e8543ea4e0b5e3a5e46412dffb576b3492ebb79edd3a
diff --git a/games-fps/doom-data/doom-data-1-r2.ebuild b/games-fps/doom-data/doom-data-1-r2.ebuild
new file mode 100644
index 000000000000..dcbff4655ed9
--- /dev/null
+++ b/games-fps/doom-data/doom-data-1-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Collection of doom wad files from id"
+HOMEPAGE="http://www.idsoftware.com/"
+SRC_URI="mirror://gentoo/doom1.wad.bz2"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doomsday"
+
+RDEPEND="doomsday? ( games-fps/doomsday )"
+DEPEND=""
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/share/doom-data
+ doins *.wad
+ if use doomsday; then
+ # Make wrapper for doomsday
+ make_wrapper doomsday-demo "jdoom -file \
+ /usr/share/doom-data/doom1.wad"
+ make_desktop_entry doomsday-demo "Doomsday - Demo"
+ fi
+}
+
+pkg_postinst() {
+ if use doomsday; then
+ elog "To use the doomsday engine, run doomsday-demo"
+ else
+ elog "A Doom engine is required to play the wad"
+ elog "Enable the doomsday use flag if you want to use"
+ elog " the doomsday engine"
+ fi
+}
diff --git a/games-fps/doom-data/metadata.xml b/games-fps/doom-data/metadata.xml
new file mode 100644
index 000000000000..343e8213e1cf
--- /dev/null
+++ b/games-fps/doom-data/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="doomsday">Add wrapper to run it within doomsday</flag>
+ </use>
+</pkgmetadata>