summaryrefslogtreecommitdiff
path: root/games-engines
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /games-engines
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/Manifest.gzbin3385 -> 3552 bytes
-rw-r--r--games-engines/devilutionx/Manifest3
-rw-r--r--games-engines/devilutionx/devilutionx-9999.ebuild60
-rw-r--r--games-engines/devilutionx/files/devilutionx-facebookincubator_find_libsodium.patch88
-rw-r--r--games-engines/devilutionx/metadata.xml11
-rw-r--r--games-engines/frotz/Manifest8
-rw-r--r--games-engines/frotz/files/frotz-2.43-glibc2.10.patch29
-rw-r--r--games-engines/frotz/files/frotz-2.43-ldflags.patch20
-rw-r--r--games-engines/frotz/frotz-2.43-r1.ebuild52
-rw-r--r--games-engines/frotz/frotz-2.45_pre20190903.ebuild74
-rw-r--r--games-engines/frotz/metadata.xml2
11 files changed, 240 insertions, 107 deletions
diff --git a/games-engines/Manifest.gz b/games-engines/Manifest.gz
index 833ff44e3b7d..18910577e6e9 100644
--- a/games-engines/Manifest.gz
+++ b/games-engines/Manifest.gz
Binary files differ
diff --git a/games-engines/devilutionx/Manifest b/games-engines/devilutionx/Manifest
new file mode 100644
index 000000000000..fa03c45c4cd7
--- /dev/null
+++ b/games-engines/devilutionx/Manifest
@@ -0,0 +1,3 @@
+AUX devilutionx-facebookincubator_find_libsodium.patch 3401 BLAKE2B 3f721056ffd63cb063affb4a54641859e3a45360aa1695fc31f3aecd94fa47ddfb986f5fc35a8c5fd5d706e7f1dce5d8dae4d6def5ed163dda8957ab61728818 SHA512 91ba2f33dec4ea56f0ed5aec334fab2a97bbae82ca425c9962c62d6aedf67b16821bfe47f7abfbdb737e5685531be55442972aabcf39b36092f59b79752dbcbc
+EBUILD devilutionx-9999.ebuild 1354 BLAKE2B 642a915685356f4726d28b07b8186149cb1df7a0b0f1310fe24ce6fc286cdb6c65641b6845d17dd9a52f58703c1b80f9a8be5a798e720b4e327b1dcbd5abf897 SHA512 e6399058fe35c9bb6b4c1771e3b6e008561d53887eed8ed452524a507a50c4ba58ec0ee36a60d944394be863b320e4cc0ced0a2549fea20fdab362d55a8a1c2d
+MISC metadata.xml 349 BLAKE2B 11288d110457dff20a74658a3405aadc17fe8acce67069fd5493f0f81e8e2aa59f45ed5808377362f6840670ae6153b199c724b2801b4689394cadb98a8061a1 SHA512 b759e6fb2533964a7226df5a5877f70eb303689f7c0fd598d1d002444ee71ac0b83747a7c8c262f2ad1d087b232de2c1c7bd3b512bbcf3469eec037009ea7f4d
diff --git a/games-engines/devilutionx/devilutionx-9999.ebuild b/games-engines/devilutionx/devilutionx-9999.ebuild
new file mode 100644
index 000000000000..3070232b1069
--- /dev/null
+++ b/games-engines/devilutionx/devilutionx-9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils desktop
+
+DESCRIPTION="Diablo engine for modern operating systems"
+HOMEPAGE="https://github.com/diasurgical/devilutionX"
+if [[ "${PV}" == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/diasurgical/devilutionX.git"
+else
+ SRC_URI="https://github.com/diasurgical/devilutionX/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="public-domain"
+SLOT="0"
+
+IUSE="debug"
+
+RDEPEND="
+ dev-libs/libsodium
+ media-libs/libsdl2[haptic]
+ media-libs/sdl2-mixer
+ media-libs/sdl2-ttf
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # https://github.com/diasurgical/devilutionX/issues/225
+ eapply -R "${FILESDIR}"/${PN}-facebookincubator_find_libsodium.patch
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBINARY_RELEASE=ON
+ -DDEBUG="$(usex debug)"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ dobin "${BUILD_DIR}/${PN}"
+ make_desktop_entry ${PN} "Diablo devolved"
+}
+
+pkg_postinst() {
+ einfo "In order to play the game you need to install the file"
+ einfo " diabdat.mpq"
+ einfo "from the original game CD into the following directory:"
+ einfo " \${HOME}/.local/share/diasurgical/devilution/"
+ einfo "and make sure it's writeable (chmod u+w)."
+}
diff --git a/games-engines/devilutionx/files/devilutionx-facebookincubator_find_libsodium.patch b/games-engines/devilutionx/files/devilutionx-facebookincubator_find_libsodium.patch
new file mode 100644
index 000000000000..e81de974c4db
--- /dev/null
+++ b/games-engines/devilutionx/files/devilutionx-facebookincubator_find_libsodium.patch
@@ -0,0 +1,88 @@
+From 1f7f5bf3dccee957e23bdf4d976883b155d5e81a Mon Sep 17 00:00:00 2001
+From: Anders Jenbo <anders@jenbo.dk>
+Date: Tue, 23 Jul 2019 21:34:08 +0200
+Subject: [PATCH] Use facebookincubator findflindsodium cmake helper
+
+https://github.com/facebookincubator/fizz/blob/master/fizz/cmake/FindSodium.cmake
+---
+ CMake/Findsodium.cmake | 34 ++++++++++++++++++++--------------
+ 1 file changed, 20 insertions(+), 14 deletions(-)
+
+diff --git a/CMake/Findsodium.cmake b/CMake/Findsodium.cmake
+index 0667920c..c664ccbe 100644
+--- a/CMake/Findsodium.cmake
++++ b/CMake/Findsodium.cmake
+@@ -55,22 +55,22 @@ if (UNIX)
+ endif()
+
+ if(sodium_USE_STATIC_LIBS)
+- if (sodium_PKG_STATIC_LIBRARIES)
+- foreach(_libname ${sodium_PKG_STATIC_LIBRARIES})
+- if (NOT _libname MATCHES "^lib.*\\.a$") # ignore strings already ending with .a
+- list(INSERT sodium_PKG_STATIC_LIBRARIES 0 "lib${_libname}.a")
+- endif()
+- endforeach()
+- list(REMOVE_DUPLICATES sodium_PKG_STATIC_LIBRARIES)
+- else()
+- # if pkgconfig for libsodium doesn't provide
+- # static lib info, then override PKG_STATIC here..
++ foreach(_libname ${sodium_PKG_STATIC_LIBRARIES})
++ if (NOT _libname MATCHES "^lib.*\\.a$") # ignore strings already ending with .a
++ list(INSERT sodium_PKG_STATIC_LIBRARIES 0 "lib${_libname}.a")
++ endif()
++ endforeach()
++ list(REMOVE_DUPLICATES sodium_PKG_STATIC_LIBRARIES)
++
++ # if pkgconfig for libsodium doesn't provide
++ # static lib info, then override PKG_STATIC here..
++ if (NOT sodium_PKG_STATIC_FOUND)
+ set(sodium_PKG_STATIC_LIBRARIES libsodium.a)
+ endif()
+
+ set(XPREFIX sodium_PKG_STATIC)
+ else()
+- if (sodium_PKG_LIBRARIES STREQUAL "")
++ if (NOT sodium_PKG_FOUND)
+ set(sodium_PKG_LIBRARIES sodium)
+ endif()
+
+@@ -101,7 +101,7 @@ elseif (WIN32)
+
+ if (MSVC)
+ # detect target architecture
+- file(WRITE "${CMAKE_CURRENT_BINARY_DIR}/arch.c" [=[
++ file(WRITE "${CMAKE_CURRENT_BINARY_DIR}/arch.cpp" [=[
+ #if defined _M_IX86
+ #error ARCH_VALUE x86_32
+ #elif defined _M_X64
+@@ -109,7 +109,7 @@ elseif (WIN32)
+ #endif
+ #error ARCH_VALUE unknown
+ ]=])
+- try_compile(_UNUSED_VAR "${CMAKE_CURRENT_BINARY_DIR}" "${CMAKE_CURRENT_BINARY_DIR}/arch.c"
++ try_compile(_UNUSED_VAR "${CMAKE_CURRENT_BINARY_DIR}" "${CMAKE_CURRENT_BINARY_DIR}/arch.cpp"
+ OUTPUT_VARIABLE _COMPILATION_LOG
+ )
+ string(REGEX REPLACE ".*ARCH_VALUE ([a-zA-Z0-9_]+).*" "\\1" _TARGET_ARCH "${_COMPILATION_LOG}")
+@@ -224,7 +224,8 @@ endif()
+
+ # communicate results
+ include(FindPackageHandleStandardArgs)
+-find_package_handle_standard_args(sodium
++find_package_handle_standard_args(
++ Sodium # The name must be either uppercase or match the filename case.
+ REQUIRED_VARS
+ sodium_LIBRARY_RELEASE
+ sodium_LIBRARY_DEBUG
+@@ -233,6 +234,11 @@ find_package_handle_standard_args(sodium
+ sodium_VERSION
+ )
+
++if(Sodium_FOUND)
++ set(sodium_LIBRARIES
++ optimized ${sodium_LIBRARY_RELEASE} debug ${sodium_LIBRARY_DEBUG})
++endif()
++
+ # mark file paths as advanced
+ mark_as_advanced(sodium_INCLUDE_DIR)
+ mark_as_advanced(sodium_LIBRARY_DEBUG)
diff --git a/games-engines/devilutionx/metadata.xml b/games-engines/devilutionx/metadata.xml
new file mode 100644
index 000000000000..81aca5b1e557
--- /dev/null
+++ b/games-engines/devilutionx/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">diasurgical/devilutionX</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-engines/frotz/Manifest b/games-engines/frotz/Manifest
index fa77a80eb365..4a7f7d99fc9b 100644
--- a/games-engines/frotz/Manifest
+++ b/games-engines/frotz/Manifest
@@ -1,5 +1,3 @@
-AUX frotz-2.43-glibc2.10.patch 859 BLAKE2B 6d8994a0bc80d9bc24ed76e6016f549b7c6b9cbcf9ed081b3ba4ebedee872bf9e04a7b62a1d8995da5942f3a8c271cf67287d4d4d96b5f3998b9561ea7c6ede6 SHA512 467477b2740667b1f8356845f7ec30a8318120313dc2bbfa2bcbde2c9cde77269349b6e7076397a7c837d9a1e72aa8fe59007fd73bd0de14b6c8244514fb81d2
-AUX frotz-2.43-ldflags.patch 665 BLAKE2B 0c744231190a308761c73f847ea6842259f424cb5ae33f1cc8311e7dc77a3ac9dd85bfc7f99070980042ab83418dd2b3b5a17c4ff29527065eb9d473ded85cff SHA512 9d750679169daa67fcd6580edd5dd53f80ab490e2637d524be9525f99764b5203242a9f9e93262d9c1abcc6d62b994f7d943040931b30ab2ce1ac9a6b772e107
-DIST frotz-2.43.tar.gz 160771 BLAKE2B edee48050b247320df3d02ea4682579d4f933a5853cc9a31f56c4d12596d5e5657e79e176ed1725e72028497a843db1d0b13833ffe44e41ec7f532f0d40ccaf9 SHA512 654f2ca2d1a625df8f88b5629e09a873668cea42688acdf154636b066b94fc9d70b7f45acb33a71d234c19b59c394c63aee38d6224245b3b329210e6b4a58409
-EBUILD frotz-2.43-r1.ebuild 1075 BLAKE2B a3ff1a05881e507a648516abc200721ecedb9ab7cf87f4b6b7673fdcd0114228309274c64f67a242404c21af16bea3cd3319f3c586e4a22e7cf69ef163e6f66f SHA512 00953652ed45fe80f9332758e5399afbbb479d2ef74f1e4e50e7eddda4566e57b4aaf2d51649f792f91abc75a580b8e3ccd677a3fc9bf1af5f07f2c710ad7e16
-MISC metadata.xml 328 BLAKE2B 650d86497c2eb4a36a16c14f088d691a6a586917592b4e3192bb321bb7007f402cbfc45cb272556a78831bab46fe57bde78f6db6b459d26064856f8308a9c19a SHA512 37fcc943d9d2700b5d88e71666af1a3ebe5baf905095d864066ebe20ac7edd54bfcafacc31684ae1eeed5197096cecbfec57c01ff5be1b567af1cc21c7294d6a
+DIST frotz-57e915b5f5b8997d1e4a1e0dac4ace2e62b7f6e9.tar.bz2 281258 BLAKE2B d85a53157e539bb1e79aade97726b5b6f752d7799faea0f35063c3321c97ddbadf7bb9318533badb212b49b397c52e3fd458d5d08868d90b564002de3ffe4324 SHA512 45fc40f4eebb338e4e4cba8ef446726a9126d45b6646ffcf3a2679dfde5630500e492667363c63f7806630d4b8d88a225080c0a2696c4170d86b1cf4d8b0a06c
+EBUILD frotz-2.45_pre20190903.ebuild 1653 BLAKE2B 7d63a13020282e13680e122beaed3026c3e9cfe919cd3199641e6463e73c29dc3bda7e66ae73d09c9909bb4bbe0d4515b19fa1cc9da36b03c9f022087400a1be SHA512 1aece9a3243fe109de57b22ccc8d2f5c77c68a8439bbc17ea1e984f338df2ff1cbe5864a3be6e0e24f7262bc5e1c6ca19e928a540bbe4623ad19ed8b9abdc00b
+MISC metadata.xml 337 BLAKE2B 58dbc1d02cdf6768759edb274b556b608135d088ab1b827abbe23726435e2595a9008a377bd27ebb1b4a517dc9e5ef74a9dcd2e08d829e0aacaa854fc258f830 SHA512 ace3f8702420d20cb543c88e0e22fae40cea97be5d86c40657107b9621c72ef462480a790f26735d212aec7fdffb27a1b00bd48f70d0e030f28efa53f51e0217
diff --git a/games-engines/frotz/files/frotz-2.43-glibc2.10.patch b/games-engines/frotz/files/frotz-2.43-glibc2.10.patch
deleted file mode 100644
index 3f2639ec47d0..000000000000
--- a/games-engines/frotz/files/frotz-2.43-glibc2.10.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/src/dumb/dumb_input.c
-+++ b/src/dumb/dumb_input.c
-@@ -79,7 +79,7 @@
- /* Read one line, including the newline, into s. Safely avoids buffer
- * overruns (but that's kind of pointless because there are several
- * other places where I'm not so careful). */
--static void getline(char *s)
-+static void get_line(char *s)
- {
- int c;
- char *p = s;
-@@ -203,7 +203,7 @@
- fputs(prompt, stdout);
- else
- dumb_show_prompt(show_cursor, (timeout ? "tTD" : ")>}")[type]);
-- getline(s);
-+ get_line(s);
- if ((s[0] != '\\') || ((s[1] != '\0') && !islower(s[1]))) {
- /* Is not a command line. */
- translate_special_chars(s);
-@@ -265,7 +265,7 @@
- if (!*current_page)
- break;
- printf("HELP: Type <return> for more, or q <return> to stop: ");
-- getline(s);
-+ get_line(s);
- if (!strcmp(s, "q\n"))
- break;
- }
diff --git a/games-engines/frotz/files/frotz-2.43-ldflags.patch b/games-engines/frotz/files/frotz-2.43-ldflags.patch
deleted file mode 100644
index c8b4e35eee20..000000000000
--- a/games-engines/frotz/files/frotz-2.43-ldflags.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/Makefile 2010-10-04 14:13:37.000000000 +0200
-+++ b/Makefile 2010-10-04 14:14:06.000000000 +0200
-@@ -162,7 +162,7 @@
- $(NAME): $(NAME)-curses
-
- $(NAME)-curses: soundcard.h $(COMMON_TARGET) $(CURSES_TARGET)
-- $(CC) -o $(BINNAME)$(EXTENSION) $(TARGETS) $(LIB) $(CURSES) \
-+ $(CC) $(LDFLAGS) -o $(BINNAME)$(EXTENSION) $(TARGETS) $(LIB) $(CURSES) \
- $(SOUND_LIB)
-
- all: $(NAME) d$(NAME)
-@@ -170,7 +170,7 @@
- dumb: $(NAME)-dumb
- d$(NAME): $(NAME)-dumb
- $(NAME)-dumb: $(COMMON_TARGET) $(DUMB_TARGET)
-- $(CC) -o d$(BINNAME)$(EXTENSION) $(COMMON_TARGET) \
-+ $(CC) $(LDFLAGS) -o d$(BINNAME)$(EXTENSION) $(COMMON_TARGET) \
- $(DUMB_TARGET) $(LIB)
-
- .SUFFIXES:
diff --git a/games-engines/frotz/frotz-2.43-r1.ebuild b/games-engines/frotz/frotz-2.43-r1.ebuild
deleted file mode 100644
index 08d19d78526c..000000000000
--- a/games-engines/frotz/frotz-2.43-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils
-
-DESCRIPTION="Curses based interpreter for Z-code based text games"
-HOMEPAGE="http://frotz.sourceforge.net/"
-SRC_URI="http://www.ifarchive.org/if-archive/infocom/interpreters/frotz/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="alsa oss"
-
-DEPEND="sys-libs/ncurses:0
- alsa? ( oss? ( media-libs/alsa-oss ) )"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-glibc2.10.patch
- "${FILESDIR}"/${P}-ldflags.patch
-)
-
-src_prepare() {
- default
-
- sed -i \
- -e '/^CC /d' \
- Makefile \
- || die
-}
-
-src_compile() {
- local OPTS="CONFIG_DIR=/etc"
- use oss && OPTS="${OPTS} SOUND_DEFS=-DOSS_SOUND SOUND_DEV=/dev/dsp"
- emake ${OPTS} all
-}
-
-src_install () {
- dobin {d,}frotz
- doman doc/*.6
- dodoc AUTHORS BUGS ChangeLog HOW_TO_PLAY README TODO \
- doc/{frotz.conf-big,frotz.conf-small}
-}
-
-pkg_postinst() {
- echo
- elog "Global config file can be installed in /etc/frotz.conf"
- elog "Sample config files are in /usr/share/doc/${PF}"
- echo
-}
diff --git a/games-engines/frotz/frotz-2.45_pre20190903.ebuild b/games-engines/frotz/frotz-2.45_pre20190903.ebuild
new file mode 100644
index 000000000000..f2a3485e522a
--- /dev/null
+++ b/games-engines/frotz/frotz-2.45_pre20190903.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_PV="57e915b5f5b8997d1e4a1e0dac4ace2e62b7f6e9"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="Interpreter for Z-code based text games"
+HOMEPAGE="https://661.org/proj/if/frotz/"
+SRC_URI="https://gitlab.com/DavidGriffith/${PN}/-/archive/${MY_PV}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="ncurses sdl sound unicode"
+REQUIRED_USE="sound? ( || ( ncurses sdl ) )"
+
+DEPEND="
+ ncurses? (
+ sys-libs/ncurses:0=[unicode?]
+ sound? ( media-libs/libao )
+ )
+ sdl? (
+ media-libs/freetype:2
+ media-libs/libpng:0=
+ media-libs/libsdl2[sound,threads,video]
+ media-libs/sdl2-mixer
+ sys-libs/zlib
+ virtual/jpeg:0=
+ )
+"
+
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ emake \
+ dumb \
+ $(use ncurses && echo ncurses) \
+ $(use sdl && echo sdl) \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)" \
+ RANLIB="$(tc-getRANLIB)" \
+ CURSES=$(usex unicode ncursesw ncurses) \
+ USE_UTF8=$(usex unicode yes "") \
+ SOUND=$(usex sound ao none) \
+ PREFIX="${EPREFIX}/usr" \
+ SYSCONFDIR="${EPREFIX}/etc"
+}
+
+src_install () {
+ emake \
+ install_dumb \
+ $(use ncurses && echo install) \
+ $(use sdl && echo install_sdl) \
+ PREFIX="${EPREFIX}/usr" \
+ DESTDIR="${D}"
+
+ dodoc \
+ AUTHORS ChangeLog CONTRIBUTORS DUMB HOW_TO_PLAY README TODO \
+ doc/frotz.conf-{big,small}
+}
+
+pkg_postinst() {
+ echo
+ elog "Global config file can be installed in ${EPREFIX}/etc/frotz.conf"
+ elog "Sample config files are in ${EPREFIX}/usr/share/doc/${PF}"
+ echo
+}
diff --git a/games-engines/frotz/metadata.xml b/games-engines/frotz/metadata.xml
index 051541926fbb..455473e4c7c5 100644
--- a/games-engines/frotz/metadata.xml
+++ b/games-engines/frotz/metadata.xml
@@ -6,6 +6,6 @@
<name>Gentoo Games Project</name>
</maintainer>
<upstream>
- <remote-id type="sourceforge">frotz</remote-id>
+ <remote-id type="gitlab">DavidGriffith/frotz</remote-id>
</upstream>
</pkgmetadata>