summaryrefslogtreecommitdiff
path: root/games-engines
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-15 13:38:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-15 13:38:09 +0100
commitdb70871b2044b9bfde346d6f4027dafb0a013c4c (patch)
tree34548aee54e5458d3754bd8c8f987acdb5ee444c /games-engines
parent1c382dc5dbc52576ac2300fee0498af8af44e7b4 (diff)
gentoo auto-resync : 15:06:2023 - 13:38:09
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/Manifest.gzbin3384 -> 3380 bytes
-rw-r--r--games-engines/devilutionx/Manifest2
-rw-r--r--games-engines/devilutionx/devilutionx-1.5.0.ebuild83
3 files changed, 85 insertions, 0 deletions
diff --git a/games-engines/Manifest.gz b/games-engines/Manifest.gz
index 8f0180ecbc70..bdc9aca7b106 100644
--- a/games-engines/Manifest.gz
+++ b/games-engines/Manifest.gz
Binary files differ
diff --git a/games-engines/devilutionx/Manifest b/games-engines/devilutionx/Manifest
index ac83fafadcab..594ea8fe1a17 100644
--- a/games-engines/devilutionx/Manifest
+++ b/games-engines/devilutionx/Manifest
@@ -1,3 +1,5 @@
DIST devilutionx-1.4.1.tar.xz 19679968 BLAKE2B 51ae007d5d1dce25a9af20b98017826534d835c2a74bfcd78cb4fb3c8e86b4e2e55a302e0412cbbcff8f931ad33a2baab806199769660351f31cc49fa91814b6 SHA512 9709600395abfd697bc45757bd2cf3e5cf0e07e2c55c86a48a73e9f52003c274724e26306b4fcb36c2eda0776c51dbab96599c0d14744244c8c037fd5dd14263
+DIST devilutionx-1.5.0.tar.xz 21951316 BLAKE2B efc6d3539eed25f917d30f3a858903952068bf4d4c66b0cd39f1a86ce3f98d9d67a8bce3a2467fa22e91bd2f552fbb593b602273e163422ab5f133133d513060 SHA512 df4998a86203372b82cb3be0348a1555ea95127a22ef050fed068215fd2223550f2b64364d83a58f829398169a29a5990d4332dc7f0adec6316f3a6c8e280ccb
EBUILD devilutionx-1.4.1.ebuild 1998 BLAKE2B f28cb67d439a85fe1c062abdf38e2e5a449807825b4edbf23f158d693a2058efc6ca15f562499c118fe3780fc42249ed3fe3c3efef85ea779fee38c9a502748f SHA512 3384d4e416b163a5ec29199395ca55655ff5b44481d2857491aeb1cecc1cc15908c842c981da2802553137efce1e8bf946c3efd585f4e68eca0cb988c51794f4
+EBUILD devilutionx-1.5.0.ebuild 2133 BLAKE2B 9c3e64d67a2167f914a256a483056f94abe6c68b0e281c7be04571c8460e2e652d66ed57856c68d3552c59b98a8f699fca2ed0b7a8c04e838c1dc48fe62b9651 SHA512 01781cc7eb0783ea88f7a639061e47f3f16f640cc1c51b08642b01d402e12efef853ac2ec2464217d623f1cebb7aff01a6db1d7d490eb995f08c6051c61f1d8e
MISC metadata.xml 542 BLAKE2B 25e292f201570a11d08f4f22922a9dfa1f54d51784be9b38f3b8396a44559ffe6d5f8799e20b8c2fa888ce97e8a45d257894c13924e303a7f93d04c0c046e231 SHA512 acb1603f7e41f47daf7f9fde6128b2f7c51c277cb97be62b87695cceb48fca653f90c2ca3e22238758a78aae4fa34f2de555e07f7e8d896a8ccf5e1c569e8083
diff --git a/games-engines/devilutionx/devilutionx-1.5.0.ebuild b/games-engines/devilutionx/devilutionx-1.5.0.ebuild
new file mode 100644
index 000000000000..a755734d4453
--- /dev/null
+++ b/games-engines/devilutionx/devilutionx-1.5.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="Diablo engine for modern operating systems"
+HOMEPAGE="https://github.com/diasurgical/devilutionX/"
+SRC_URI="https://github.com/diasurgical/devilutionX/releases/download/${PV}/devilutionx-src.tar.xz -> ${P}.tar.xz"
+S="${WORKDIR}/${PN}-src-${PV}"
+
+LICENSE="Unlicense CC-BY-4.0 GPL-2+ LGPL-2.1+ MIT OFL-1.1 zerotier? ( BSL-1.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +sodium test zerotier"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-arch/bzip2:=
+ dev-libs/libfmt:=
+ media-libs/libsdl2[haptic,joystick,opengl,video]
+ media-libs/sdl2-image[png]
+ sys-libs/zlib:=
+ media-libs/sdl_audiolib
+ sodium? ( dev-libs/libsodium:= )"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/asio
+ dev-cpp/simpleini
+ test? ( dev-cpp/gtest )"
+BDEPEND="sys-devel/gettext"
+
+src_prepare() {
+ cmake_src_prepare
+
+ # use system asio
+ echo 'add_library(asio INTERFACE)' > 3rdParty/asio/CMakeLists.txt || die
+
+ # ensure system copies are used
+ rm -r dist/{asio,simpleini,sdl_audiolib}-src || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ -DCCACHE_PROGRAM=no #813768
+ -DDEBUG=$(usex debug)
+ -DDISABLE_LTO=yes # let CFLAGS control this
+ -DDISABLE_ZERO_TIER=$(usex !zerotier)
+ -DPACKET_ENCRYPTION=$(usex sodium)
+ -DPIE=yes
+ -DFETCHCONTENT_FULLY_DISCONNECTED=yes
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ # timedemo tests only pass when game assets are available
+ cmake_src_test -E Timedemo.
+}
+
+src_install() {
+ local DOCS=( Packaging/nix/README.txt docs/*.md )
+ cmake_src_install
+
+ rm "${ED}"/usr/share/diasurgical/devilutionx/README.txt || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "In order to play the game, you will need to copy the following data file"
+ elog "from the original game, and optionally the hellfire expansion files:"
+ elog " - DIABDAT.MPQ"
+ elog " - hellfire.mpq hfmonk.mpq hfmusic.mpq hfvoice.mpq"
+ elog "to ~/.local/share/diasurgical/devilution/"
+ elog
+ elog "See ${EROOT}/usr/share/doc/${PF}/README.txt* for details."
+ fi
+}