summaryrefslogtreecommitdiff
path: root/games-engines
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-13 06:19:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-13 06:19:51 +0000
commit8be70107efbb417f839292165ee39d07a062046f (patch)
tree013918887ec4a00f0cefdb4b4d1313cbc3054305 /games-engines
parent343a7272d559a21a0e0ed13cb743fabb2bfcc479 (diff)
gentoo resync : 13.01.2018
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/Manifest.gzbin3381 -> 3382 bytes
-rw-r--r--games-engines/openmw/Manifest2
-rw-r--r--games-engines/openmw/openmw-0.43.0.ebuild125
3 files changed, 127 insertions, 0 deletions
diff --git a/games-engines/Manifest.gz b/games-engines/Manifest.gz
index 047248aaa086..1df8f332c9b5 100644
--- a/games-engines/Manifest.gz
+++ b/games-engines/Manifest.gz
Binary files differ
diff --git a/games-engines/openmw/Manifest b/games-engines/openmw/Manifest
index 569f859aaa02..5d9759f74045 100644
--- a/games-engines/openmw/Manifest
+++ b/games-engines/openmw/Manifest
@@ -1,3 +1,5 @@
DIST openmw-0.42.0.tar.gz 4956838 BLAKE2B 5311a47bbbd917cc2fcf91f79c1f31896afa6cd54f3a1e75fc715c9e09362da9c9117a6c6b42a200047d6953ee4e5bf8ef80fe132f23806f5a354ac3ff634048 SHA512 f638e804e03e965db8e19cb37b3be67804202c1e43b0abf2730e0be104093edc31fc3656f90c570980b66ece4f5c889b44f0f59789e865327d221714a9ed65f3
+DIST openmw-0.43.0.tar.gz 5023421 BLAKE2B c99e3a23b22b642dea9e8f2d9414e00aa6a05c4331a9715882465781caca60cd857675d87079bafc3596783e257213bec9d6f1f4e78a3d795e973fb1d895811e SHA512 e902dd2274c05838bb1171f07d7a673fc7b85d1290a9e01c8ab89f1c279bd236332ecdc0f2b7944ec7209a0e6022ff472639b5724bf26904e3a2d338c7be401a
EBUILD openmw-0.42.0.ebuild 3296 BLAKE2B 532585805ffde333028a0ac9cc16069a9538b99904ded6ec696c5ba81022cd118771c7cba55d26cde5af3020e5cc9a1dd2959935511b6361a391729bf694f141 SHA512 890eebd30fd66cc0c52c043afe686e21c32893c30d4ea29e1a41c3f00512cb77a848cafdbd47fe929accf70d46c5c0d206f223f7f9190e1903575117a915fad4
+EBUILD openmw-0.43.0.ebuild 3121 BLAKE2B 9121c44b4c377230f38dd51c1bd262b4d8f5fc4d61b104ba7916e12b2924bc273f4571a881d34d50c53b58a36c740a43320b2e93280843d80bcb36e91367825a SHA512 4ce6184f86c2dd1ee0d68c1258872c99357215e821471caa850f052b52c949907b8847815d2e34d8e4c9953d6c5495478720646b6cee270357e07220f5ac7926
MISC metadata.xml 1044 BLAKE2B 132bf7783f4cdac33cfb9bffac4e8a0baf7380f8bb91b262c087ebab4848e6fc97dbac258d600836f1d447536077f063d0dc0ca7348179a61310806f5862ecfe SHA512 c47622fc66013a7c61b1f865619a77707b296b051df54bd75048073b6b5875d97fb300d490a5aba923cc369566ffb5f3dbab16451d1bf48f5f91de18ee7c2116
diff --git a/games-engines/openmw/openmw-0.43.0.ebuild b/games-engines/openmw/openmw-0.43.0.ebuild
new file mode 100644
index 000000000000..58000b29e43b
--- /dev/null
+++ b/games-engines/openmw/openmw-0.43.0.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils readme.gentoo-r1
+
+DESCRIPTION="Open source reimplementation of TES III: Morrowind"
+HOMEPAGE="https://openmw.org/"
+SRC_URI="https://github.com/OpenMW/openmw/archive/${P}.tar.gz"
+
+LICENSE="GPL-3 MIT BitstreamVera ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc devtools +qt5"
+
+RDEPEND="
+ >=dev-games/openscenegraph-3.3.4[ffmpeg,jpeg,png,qt5,sdl,svg,truetype,zlib]
+ dev-games/mygui
+ dev-libs/boost:=[threads]
+ dev-libs/tinyxml[stl]
+ media-libs/libsdl2[joystick,opengl,video,X]
+ media-libs/openal
+ media-video/ffmpeg:=
+ >=sci-physics/bullet-2.86
+ virtual/opengl
+ qt5? (
+ app-arch/unshield
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5
+ )
+"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[doc] dev-python/sphinx )"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # We don't install license files
+ sed -e '/LICDIR/d' \
+ -i CMakeLists.txt || die
+ # Use the system tinyxml headers
+ sed -e 's/"tinyxml.h"/<tinyxml.h>/g' \
+ -e 's/"tinystr.h"/<tinystr.h>/g' \
+ -i extern/oics/ICSPrerequisites.h || die
+}
+
+src_configure() {
+ use devtools && ! use qt5 && \
+ elog "'qt5' USE flag is disabled, 'openmw-cs' will not be installed"
+
+ local mycmakeargs=(
+ -DBUILD_BSATOOL=$(usex devtools)
+ -DBUILD_DOCS=$(usex doc)
+ -DBUILD_ESMTOOL=$(usex devtools)
+ -DBUILD_LAUNCHER=$(usex qt5)
+ -DBUILD_NIFTEST=$(usex devtools)
+ -DBUILD_OPENCS=$(usex devtools $(usex qt5))
+ -DBUILD_WIZARD=$(usex qt5)
+ -DBUILD_UNITTESTS=OFF
+ -DGLOBAL_DATA_PATH=/usr/share
+ -DICONDIR="/usr/share/icons/hicolor/256x256/apps"
+ -DMORROWIND_DATA_FILES="/usr/share/morrowind-data"
+ -DUSE_SYSTEM_TINYXML=ON
+ -DDESIRED_QT_VERSION=5
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ if use doc ; then
+ cmake-utils_src_compile doc
+ find "${CMAKE_BUILD_DIR}"/docs/Doxygen/html \
+ -name '*.md5' -type f -delete || die
+ HTML_DOCS=( "${CMAKE_BUILD_DIR}"/docs/Doxygen/html/. )
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ local DOC_CONTENTS="
+ You need the original Morrowind data files. If you haven't
+ installed them yet, you can install them straight via the
+ installation wizard which is the officially supported method
+ (either by using the launcher or by calling 'openmw-wizard'
+ directly).\n"
+
+ if ! use qt5; then
+ local DOC_CONTENTS+="\n\n
+ USE flag 'qt5' is disabled, 'openmw-launcher' and
+ 'openmw-wizard' are not available. You are on your own for
+ making the Morrowind data files available and pointing
+ openmw at them.\n\n
+ Additionally; you must import the Morrowind.ini file before
+ running openmw with the Morrowind data files for the first
+ time. Typically this can be done like so:\n\n
+ \t mkdir -p ~/.config/openmw\n
+ \t openmw-iniimporter /path/to/Morrowind.ini ~/.config/openmw/openmw.cfg"
+ fi
+
+ readme.gentoo_create_doc
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}