summaryrefslogtreecommitdiff
path: root/games-engines
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-15 17:37:09 +0100
commit586819755b4dbfdffdc8a725ab7c0f86095b8489 (patch)
treed6790c838cfe9607c996e4913fdf11bad5fdd528 /games-engines
parent3f71901f8c228f4de570abed1831ce3ee425343e (diff)
gentoo resync : 15.09.2018
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/Manifest.gzbin3372 -> 3375 bytes
-rw-r--r--games-engines/residualvm/Manifest3
-rw-r--r--games-engines/residualvm/residualvm-0.3.1.ebuild91
-rw-r--r--games-engines/residualvm/residualvm-9999.ebuild91
4 files changed, 185 insertions, 0 deletions
diff --git a/games-engines/Manifest.gz b/games-engines/Manifest.gz
index 7b0696633b6b..5d8b17a1b2ba 100644
--- a/games-engines/Manifest.gz
+++ b/games-engines/Manifest.gz
Binary files differ
diff --git a/games-engines/residualvm/Manifest b/games-engines/residualvm/Manifest
index b853dcbd8487..3b0c383fc6e7 100644
--- a/games-engines/residualvm/Manifest
+++ b/games-engines/residualvm/Manifest
@@ -1,3 +1,6 @@
DIST residualvm-0.2.1-sources.tar.bz2 5533814 BLAKE2B befcb42c823d31ff1e8793d0c902bfdf6b3728530c97b3f43ada5d3b2903a0cddba3247095d1674e62cdd75a6db28a7a5f3b1437e5c39cb5eccb37dff9d52fad SHA512 9eed93770ef1ad828934c32e937b861c93f1ebbb0d936f3f56668e654588f734dc88e29446f0a69f8f26475e96b8ce7ca85318758b99aabc9586756692c721da
+DIST residualvm-0.3.1-sources.tar.bz2 6711799 BLAKE2B 93d21bc5ee2c567b1ef256a69a2634761cd52211a0b2d926edc67b65e0cc1bf23b41c91225e6d43990d61e6c3761acf19defaa9b477ad882d332ad77c71af1a6 SHA512 491a77f1775718795d93f099fa39ec5888755ac1df610089c17209334b98ae783271078ed03a61ced09835aa327446804a55522d4b83f618dd3b843c231444a0
EBUILD residualvm-0.2.1-r1.ebuild 1791 BLAKE2B 72cb7fe160b57c2e5d2858fd2aeb3f5b82041374f7523a64f43b69eb211c877d69898e1c2fcf15ba7111ea75ca24a14215cf0d892a65a4ccca47d2e659eed9e8 SHA512 e18cd04be84436fc4f13de9c9aaafa27f5888dfb0cc24e6713916105d515089e1ca23c7870da98138d8c2e673b8f79d54e13904b5b1966530277e485b875f661
+EBUILD residualvm-0.3.1.ebuild 2053 BLAKE2B fa9af5097bda632ae17e4b93f296ac1d0c6afa816b352d53e7d7f706350b2c6d8ade2e5b2c92ed1ce7c7950df65cca15adf590171f96bb45e5c57b2c66c73ed8 SHA512 8feedc692f14ad4e3a7ce10adaf55cb715535274cc88a32d2edd43fb3dc96ae5b751d9fc5be2fff7c030c81223f0b2a473cb3e6609ed1e6869d809cad3a047dd
+EBUILD residualvm-9999.ebuild 2053 BLAKE2B fa9af5097bda632ae17e4b93f296ac1d0c6afa816b352d53e7d7f706350b2c6d8ade2e5b2c92ed1ce7c7950df65cca15adf590171f96bb45e5c57b2c66c73ed8 SHA512 8feedc692f14ad4e3a7ce10adaf55cb715535274cc88a32d2edd43fb3dc96ae5b751d9fc5be2fff7c030c81223f0b2a473cb3e6609ed1e6869d809cad3a047dd
MISC metadata.xml 333 BLAKE2B 37cda9e5ddf385a47b3ad7c5678bd318b79b5c6b87dab92523ad6fd44b850470eae65a01562213709c0b2f6f943c023e5892588ffe484fae12780e531c1725f0 SHA512 41e3a0c69255f5f64ff9c3806e7f1871e0721dc9554d92f370e809487975454b6747818c93da77ad2b8c579b26948ac0a48ac4bb9969838e91f48f51dae2d2f7
diff --git a/games-engines/residualvm/residualvm-0.3.1.ebuild b/games-engines/residualvm/residualvm-0.3.1.ebuild
new file mode 100644
index 000000000000..7343afbb7e72
--- /dev/null
+++ b/games-engines/residualvm/residualvm-0.3.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils toolchain-funcs xdg-utils
+
+DESCRIPTION="A cross-platform 3D game interpreter for play LucasArts' LUA-based 3D adventures"
+HOMEPAGE="http://www.residualvm.org/"
+if [[ "${PV}" = 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/residualvm/residualvm.git"
+else
+ SRC_URI="http://www.residualvm.org/downloads/release/${PV}/${P}-sources.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+# TODO: fix dynamic plugin support
+# games crash without media-libs/libsdl[alsa]
+RDEPEND="
+ media-libs/alsa-lib
+ media-libs/freetype:2
+ media-libs/glew:0=
+ media-libs/libpng:0=
+ media-libs/libsdl2[X,sound,alsa,joystick,opengl,video]
+ sys-libs/zlib
+ virtual/glu
+ virtual/jpeg:0
+ virtual/opengl"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # not an autotools script
+ # most configure options currently do nothing, verify on version bump !!!
+ # disable explicitly, otherwise we get unneeded linkage (some copy-paste build system)
+ local myconf=(
+ --backend=sdl
+ --disable-debug
+ --disable-faad
+ --disable-flac
+ --disable-fluidsynth
+ --disable-libunity
+ --disable-mad
+ --disable-sparkle
+ --disable-translation
+ --disable-tremor
+ --disable-vorbis
+ --docdir="/usr/share/doc/${PF}"
+ --enable-all-engines
+ --enable-release-mode
+ --enable-zlib
+ )
+ ./configure "${myconf[@]}" || die "configure failed"
+}
+
+src_compile() {
+ emake \
+ VERBOSE_BUILD=1 \
+ AR="$(tc-getAR) cru" \
+ RANLIB=$(tc-getRANLIB)
+}
+
+src_install() {
+ dobin residualvm
+
+ insinto "/usr/share/${PN}"
+ doins gui/themes/modern.zip dists/engine-data/residualvm-grim-patch.lab
+
+ doicon -s scalable icons/${PN}.svg
+ doicon -s 256 icons/${PN}.png
+ domenu dists/${PN}.desktop
+
+ doman dists/${PN}.6
+ dodoc AUTHORS README.md KNOWN_BUGS TODO
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
diff --git a/games-engines/residualvm/residualvm-9999.ebuild b/games-engines/residualvm/residualvm-9999.ebuild
new file mode 100644
index 000000000000..7343afbb7e72
--- /dev/null
+++ b/games-engines/residualvm/residualvm-9999.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils toolchain-funcs xdg-utils
+
+DESCRIPTION="A cross-platform 3D game interpreter for play LucasArts' LUA-based 3D adventures"
+HOMEPAGE="http://www.residualvm.org/"
+if [[ "${PV}" = 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/residualvm/residualvm.git"
+else
+ SRC_URI="http://www.residualvm.org/downloads/release/${PV}/${P}-sources.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+# TODO: fix dynamic plugin support
+# games crash without media-libs/libsdl[alsa]
+RDEPEND="
+ media-libs/alsa-lib
+ media-libs/freetype:2
+ media-libs/glew:0=
+ media-libs/libpng:0=
+ media-libs/libsdl2[X,sound,alsa,joystick,opengl,video]
+ sys-libs/zlib
+ virtual/glu
+ virtual/jpeg:0
+ virtual/opengl"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # not an autotools script
+ # most configure options currently do nothing, verify on version bump !!!
+ # disable explicitly, otherwise we get unneeded linkage (some copy-paste build system)
+ local myconf=(
+ --backend=sdl
+ --disable-debug
+ --disable-faad
+ --disable-flac
+ --disable-fluidsynth
+ --disable-libunity
+ --disable-mad
+ --disable-sparkle
+ --disable-translation
+ --disable-tremor
+ --disable-vorbis
+ --docdir="/usr/share/doc/${PF}"
+ --enable-all-engines
+ --enable-release-mode
+ --enable-zlib
+ )
+ ./configure "${myconf[@]}" || die "configure failed"
+}
+
+src_compile() {
+ emake \
+ VERBOSE_BUILD=1 \
+ AR="$(tc-getAR) cru" \
+ RANLIB=$(tc-getRANLIB)
+}
+
+src_install() {
+ dobin residualvm
+
+ insinto "/usr/share/${PN}"
+ doins gui/themes/modern.zip dists/engine-data/residualvm-grim-patch.lab
+
+ doicon -s scalable icons/${PN}.svg
+ doicon -s 256 icons/${PN}.png
+ domenu dists/${PN}.desktop
+
+ doman dists/${PN}.6
+ dodoc AUTHORS README.md KNOWN_BUGS TODO
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}