summaryrefslogtreecommitdiff
path: root/games-engines
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-26 02:57:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-26 02:57:39 +0100
commit24162508832f37f873ab12dfdfb191cf99318055 (patch)
tree3f9d1bac9025c4a823e0d7f948110aa74857baf8 /games-engines
parent26262b314fa723a2e86f4a9b8b344a72eb9c0393 (diff)
gentoo auto-resync : 26:07:2022 - 02:57:39
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/Manifest.gzbin3724 -> 3721 bytes
-rw-r--r--games-engines/devilutionx/Manifest2
-rw-r--r--games-engines/devilutionx/devilutionx-1.4.1.ebuild77
3 files changed, 79 insertions, 0 deletions
diff --git a/games-engines/Manifest.gz b/games-engines/Manifest.gz
index 683f551ef23b..3bf48a443718 100644
--- a/games-engines/Manifest.gz
+++ b/games-engines/Manifest.gz
Binary files differ
diff --git a/games-engines/devilutionx/Manifest b/games-engines/devilutionx/Manifest
index 8ba77e363030..c9321042c985 100644
--- a/games-engines/devilutionx/Manifest
+++ b/games-engines/devilutionx/Manifest
@@ -1,4 +1,6 @@
AUX devilutionx-1.4.0-system-sdl_audiolib.patch 737 BLAKE2B c0d36bc098c0ce319a8c9c0622d16310e64925a8a48b16670a63242d853b4345aec7f3006e0bff01e622d0a289605964536213faad9359f74274cd40da706246 SHA512 e29ae8854676b9c148410886bc18bfbb38bbf7afdd95c9200ebc33686c4f50f5a0f2e31525bcf11de85b34890557848ec6639a99eadd1763bd637084809a994f
DIST devilutionx-1.4.0.tar.xz 19752052 BLAKE2B 3a79e9d88cc2f5623dfd7d4ad2a0a547361cde8d95197be36dc7076e0b56fa1a915c57bf5537f5e4508201c3b5a283ab90d13db93b3836b0f12c6108abf1578a SHA512 9519c0bd52798f35fc986fab867b0005010f089b35200b5d54b7ed94145c2df54270a570cd3b0ff1c260f645d624a145e3581d744b48ae513919eb2258331bcf
+DIST devilutionx-1.4.1.tar.xz 19679968 BLAKE2B 51ae007d5d1dce25a9af20b98017826534d835c2a74bfcd78cb4fb3c8e86b4e2e55a302e0412cbbcff8f931ad33a2baab806199769660351f31cc49fa91814b6 SHA512 9709600395abfd697bc45757bd2cf3e5cf0e07e2c55c86a48a73e9f52003c274724e26306b4fcb36c2eda0776c51dbab96599c0d14744244c8c037fd5dd14263
EBUILD devilutionx-1.4.0.ebuild 2034 BLAKE2B 11755a6583cf4a2087b19e4227248628c89140f1831513ee4776995f8c1e182f2d161be1a0e3131d549f8c80a95e16d6fa5792f239e3b0fb0ce73ebb6fba8591 SHA512 b632ced8ddd68340c2195a736f33e4bec4a006db064e422c7f819e254d8d84ab575391c8d53eb5244bf4a37ce0990ba3f2633aa88aa36e84282afeadca92b76c
+EBUILD devilutionx-1.4.1.ebuild 1998 BLAKE2B f28cb67d439a85fe1c062abdf38e2e5a449807825b4edbf23f158d693a2058efc6ca15f562499c118fe3780fc42249ed3fe3c3efef85ea779fee38c9a502748f SHA512 3384d4e416b163a5ec29199395ca55655ff5b44481d2857491aeb1cecc1cc15908c842c981da2802553137efce1e8bf946c3efd585f4e68eca0cb988c51794f4
MISC metadata.xml 542 BLAKE2B 25e292f201570a11d08f4f22922a9dfa1f54d51784be9b38f3b8396a44559ffe6d5f8799e20b8c2fa888ce97e8a45d257894c13924e303a7f93d04c0c046e231 SHA512 acb1603f7e41f47daf7f9fde6128b2f7c51c277cb97be62b87695cceb48fca653f90c2ca3e22238758a78aae4fa34f2de555e07f7e8d896a8ccf5e1c569e8083
diff --git a/games-engines/devilutionx/devilutionx-1.4.1.ebuild b/games-engines/devilutionx/devilutionx-1.4.1.ebuild
new file mode 100644
index 000000000000..e7608abb497b
--- /dev/null
+++ b/games-engines/devilutionx/devilutionx-1.4.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="Diablo engine for modern operating systems"
+HOMEPAGE="https://github.com/diasurgical/devilutionX/"
+SRC_URI="https://github.com/diasurgical/devilutionX/releases/download/${PV}/devilutionx-src.tar.xz -> ${P}.tar.xz"
+S="${WORKDIR}/${PN}-src-${PV}-5ad792133"
+
+LICENSE="Unlicense CC-BY-4.0 GPL-2+ LGPL-2.1+ MIT OFL-1.1 zerotier? ( BSL-1.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +sodium test zerotier"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-arch/bzip2:=
+ dev-libs/libfmt:=
+ media-libs/libsdl2[haptic,joystick,opengl,video]
+ media-libs/sdl2-image[png]
+ sys-libs/zlib:=
+ media-libs/sdl_audiolib
+ sodium? ( dev-libs/libsodium:= )"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/asio
+ dev-cpp/simpleini
+ test? ( dev-cpp/gtest )"
+BDEPEND="sys-devel/gettext"
+
+src_prepare() {
+ cmake_src_prepare
+
+ # use system asio
+ echo 'add_library(asio INTERFACE)' > 3rdParty/asio/CMakeLists.txt || die
+
+ # ensure system copies are used
+ rm -r dist/{asio,simpleini,sdl_audiolib}-src || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ -DCCACHE_PROGRAM=OFF #813768
+ -DDEBUG=$(usex debug)
+ -DDISABLE_LTO=ON # let CFLAGS control this
+ -DDISABLE_ZERO_TIER=$(usex !zerotier)
+ -DPACKET_ENCRYPTION=$(usex sodium)
+ -DPIE=ON
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ local DOCS=( Packaging/nix/README.txt docs/*.md )
+ cmake_src_install
+
+ rm "${ED}"/usr/share/diasurgical/devilutionx/README.txt || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "In order to play the game, you will need to copy the following data file"
+ elog "from the original game, and optionally the hellfire expansion files:"
+ elog " - DIABDAT.MPQ"
+ elog " - hellfire.mpq hfmonk.mpq hfmusic.mpq hfvoice.mpq"
+ elog "to ~/.local/share/diasurgical/devilution/"
+ elog
+ elog "See ${EROOT}/usr/share/doc/${PF}/README.txt* for details."
+ fi
+}