summaryrefslogtreecommitdiff
path: root/games-engines/zoom
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-engines/zoom
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-engines/zoom')
-rw-r--r--games-engines/zoom/Manifest4
-rw-r--r--games-engines/zoom/files/zoom-1.1.5-gcc7.patch53
-rw-r--r--games-engines/zoom/metadata.xml8
-rw-r--r--games-engines/zoom/zoom-1.1.5-r1.ebuild30
4 files changed, 95 insertions, 0 deletions
diff --git a/games-engines/zoom/Manifest b/games-engines/zoom/Manifest
new file mode 100644
index 000000000000..85968270aed5
--- /dev/null
+++ b/games-engines/zoom/Manifest
@@ -0,0 +1,4 @@
+AUX zoom-1.1.5-gcc7.patch 1732 BLAKE2B 3e7ce92fc7804dabdcd37db32f8dbbdccd4716b52d5266507df01cec35db40b0cafd753c32c4fb7b341c7ee784d752968f99cf06a20d067055c796b175ac5cca SHA512 8b8e130cf889efa48c737145044b23a858419d03ffc7af90fdd875e54a6e3b2f5df148d7755cd325b798445d2190db38ee193a135cae46867a3be7971e346f49
+DIST zoom-1.1.5.tar.gz 2185098 BLAKE2B 899ee9afef431d2cf5a36cbb8c8c5452b8a5a24ce705ed6a5cdba5a6331e4a86fe819a9309748d1f8b7faf9e1d3267a86bc65ded8a52d17d9d2a4cdd6ab600a2 SHA512 800b29e3517ce39000d8c05148d6af0d7c8666db20a06867e35076ffa1914b845e8fa0153571975e59842672572b80826ee8dbe3b2d4bc98c07394054e9bd7ca
+EBUILD zoom-1.1.5-r1.ebuild 605 BLAKE2B 12ef4a5be5e50a086833f1e300a069c34f8d40f15feecb959e60a910ff498c70d53f4eb1622cf24387fc1abf20b255a8c6d73c53aa4aee789127e0655f975a17 SHA512 4917db5ce1be6e271436cbd0951a25ea51da9084221bf507468edeed911badf8d0b296f89c2202cc57ee3e5e8ffd775c1c861cd8b93477035b7881d3ae24970c
+MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-engines/zoom/files/zoom-1.1.5-gcc7.patch b/games-engines/zoom/files/zoom-1.1.5-gcc7.patch
new file mode 100644
index 000000000000..6f50d3f43624
--- /dev/null
+++ b/games-engines/zoom/files/zoom-1.1.5-gcc7.patch
@@ -0,0 +1,53 @@
+Bug: https://bugs.gentoo.org/617808
+Upstream commit: https://github.com/Logicalshift/zoom/commit/6b0ad57dd2c125c9126e9b7913560ad25709a36f
+
+From 6b0ad57dd2c125c9126e9b7913560ad25709a36f Mon Sep 17 00:00:00 2001
+From: Andrew Hunter <andrew@logicalshift.co.uk>
+Date: Sat, 3 Mar 2012 16:31:35 +0000
+Subject: [PATCH] Inline functions need to be marked as static in order to
+ compile with LLVM
+
+---
+ src/interp.c | 4 ++--
+ src/tokenise.c | 6 +++---
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/src/interp.c b/src/interp.c
+index a5fa8fe..3d446fa 100644
+--- a/src/interp.c
++++ b/src/interp.c
+@@ -232,7 +232,7 @@ ZFrame* call_routine(ZDWord* pc, ZStack* stack, ZDWord start)
+ return newframe;
+ }
+
+-inline void store(ZStack* stack, int var, ZWord value)
++static inline void store(ZStack* stack, int var, ZWord value)
+ {
+ #ifdef DEBUG
+ printf_debug("Storing %i in Variable #%x\n", value, var);
+@@ -253,7 +253,7 @@ inline void store(ZStack* stack, int var, ZWord value)
+ }
+ }
+
+-inline void store_nopush(ZStack* stack, int var, ZWord value)
++static inline void store_nopush(ZStack* stack, int var, ZWord value)
+ {
+ #ifdef DEBUG
+ printf_debug("Storing %i in Variable #%x\n", value, var);
+diff --git a/src/tokenise.c b/src/tokenise.c
+index 5925169..fb442d0 100644
+--- a/src/tokenise.c
++++ b/src/tokenise.c
+@@ -154,9 +154,9 @@ ZDictionary* dictionary_cache(const ZUWord dict_pos)
+
+ int cache = 1;
+
+-inline ZUWord lookup_word(unsigned int* word,
+- int wordlen,
+- ZUWord dct)
++static inline ZUWord lookup_word(unsigned int* word,
++ int wordlen,
++ ZUWord dct)
+ {
+ ZByte packed[12];
+ int zscii_len;
diff --git a/games-engines/zoom/metadata.xml b/games-engines/zoom/metadata.xml
new file mode 100644
index 000000000000..78274e0fa550
--- /dev/null
+++ b/games-engines/zoom/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-engines/zoom/zoom-1.1.5-r1.ebuild b/games-engines/zoom/zoom-1.1.5-r1.ebuild
new file mode 100644
index 000000000000..f5f33fac05c6
--- /dev/null
+++ b/games-engines/zoom/zoom-1.1.5-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A fast, clean, modern Z-code interpreter for X"
+HOMEPAGE="http://www.logicalshift.co.uk/unix/zoom/"
+SRC_URI="http://www.logicalshift.co.uk/unix/zoom/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/fontconfig
+ media-libs/libpng:0
+ >=media-libs/t1lib-5
+ x11-libs/libSM
+ x11-libs/libXft"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ x11-base/xorg-proto"
+
+PATCHES=( "${FILESDIR}"/${P}-gcc7.patch )
+
+src_install() {
+ default
+ dodoc -r manual/*
+}