summaryrefslogtreecommitdiff
path: root/games-engines/zoom
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-05 21:52:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-05 21:52:00 +0100
commit2d446203bcf1a0db08e99abca43513d246dfa73d (patch)
treeec623bb5f1f389976977e375342ec59ff441eab7 /games-engines/zoom
parent171a011ad3a131671aeb5a98b9e3adf219ad2865 (diff)
gentoo resync : 05.04.2018
Diffstat (limited to 'games-engines/zoom')
-rw-r--r--games-engines/zoom/Manifest3
-rw-r--r--games-engines/zoom/files/zoom-1.1.5-gcc7.patch53
-rw-r--r--games-engines/zoom/zoom-1.1.5-r1.ebuild4
3 files changed, 58 insertions, 2 deletions
diff --git a/games-engines/zoom/Manifest b/games-engines/zoom/Manifest
index 72ee3c4c835b..cc0855d81c81 100644
--- a/games-engines/zoom/Manifest
+++ b/games-engines/zoom/Manifest
@@ -1,3 +1,4 @@
+AUX zoom-1.1.5-gcc7.patch 1732 BLAKE2B 3e7ce92fc7804dabdcd37db32f8dbbdccd4716b52d5266507df01cec35db40b0cafd753c32c4fb7b341c7ee784d752968f99cf06a20d067055c796b175ac5cca SHA512 8b8e130cf889efa48c737145044b23a858419d03ffc7af90fdd875e54a6e3b2f5df148d7755cd325b798445d2190db38ee193a135cae46867a3be7971e346f49
DIST zoom-1.1.5.tar.gz 2185098 BLAKE2B 899ee9afef431d2cf5a36cbb8c8c5452b8a5a24ce705ed6a5cdba5a6331e4a86fe819a9309748d1f8b7faf9e1d3267a86bc65ded8a52d17d9d2a4cdd6ab600a2 SHA512 800b29e3517ce39000d8c05148d6af0d7c8666db20a06867e35076ffa1914b845e8fa0153571975e59842672572b80826ee8dbe3b2d4bc98c07394054e9bd7ca
-EBUILD zoom-1.1.5-r1.ebuild 562 BLAKE2B 1c38e45b633bb57d72f22a1fa76859b217626e1b9c2492c0425c776e46685328b38a6366d1a3d71c539b24574813c8cdcdd4919d911fd4990af0a8e6ecabeade SHA512 f9a3fc57597ad1eaf4095a53a39af1e8d71346c6e49441766829283f70c0583fb32bbfde0f5ecb63793ce41b463d2d1ce3fb1b8896097dd75c0032fc32e28b32
+EBUILD zoom-1.1.5-r1.ebuild 605 BLAKE2B a7dea11ed292eef18f85691d38863db7ec0f2c83f4325be25e3cab1a5d42fe8271985a50b012f12c2885c0b2accff51a56fc05a0d2c4ed1531866a350e8b59cc SHA512 b7390e2603bb3cd448de3ebfe3cf94ba1d245632b9e1a3d9fd86c8c41138c8182b1bd04a6d3c6ca5838aa6da2cde42fc0e3aec7ab22824470353a6e16153e79b
MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/games-engines/zoom/files/zoom-1.1.5-gcc7.patch b/games-engines/zoom/files/zoom-1.1.5-gcc7.patch
new file mode 100644
index 000000000000..6f50d3f43624
--- /dev/null
+++ b/games-engines/zoom/files/zoom-1.1.5-gcc7.patch
@@ -0,0 +1,53 @@
+Bug: https://bugs.gentoo.org/617808
+Upstream commit: https://github.com/Logicalshift/zoom/commit/6b0ad57dd2c125c9126e9b7913560ad25709a36f
+
+From 6b0ad57dd2c125c9126e9b7913560ad25709a36f Mon Sep 17 00:00:00 2001
+From: Andrew Hunter <andrew@logicalshift.co.uk>
+Date: Sat, 3 Mar 2012 16:31:35 +0000
+Subject: [PATCH] Inline functions need to be marked as static in order to
+ compile with LLVM
+
+---
+ src/interp.c | 4 ++--
+ src/tokenise.c | 6 +++---
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/src/interp.c b/src/interp.c
+index a5fa8fe..3d446fa 100644
+--- a/src/interp.c
++++ b/src/interp.c
+@@ -232,7 +232,7 @@ ZFrame* call_routine(ZDWord* pc, ZStack* stack, ZDWord start)
+ return newframe;
+ }
+
+-inline void store(ZStack* stack, int var, ZWord value)
++static inline void store(ZStack* stack, int var, ZWord value)
+ {
+ #ifdef DEBUG
+ printf_debug("Storing %i in Variable #%x\n", value, var);
+@@ -253,7 +253,7 @@ inline void store(ZStack* stack, int var, ZWord value)
+ }
+ }
+
+-inline void store_nopush(ZStack* stack, int var, ZWord value)
++static inline void store_nopush(ZStack* stack, int var, ZWord value)
+ {
+ #ifdef DEBUG
+ printf_debug("Storing %i in Variable #%x\n", value, var);
+diff --git a/src/tokenise.c b/src/tokenise.c
+index 5925169..fb442d0 100644
+--- a/src/tokenise.c
++++ b/src/tokenise.c
+@@ -154,9 +154,9 @@ ZDictionary* dictionary_cache(const ZUWord dict_pos)
+
+ int cache = 1;
+
+-inline ZUWord lookup_word(unsigned int* word,
+- int wordlen,
+- ZUWord dct)
++static inline ZUWord lookup_word(unsigned int* word,
++ int wordlen,
++ ZUWord dct)
+ {
+ ZByte packed[12];
+ int zscii_len;
diff --git a/games-engines/zoom/zoom-1.1.5-r1.ebuild b/games-engines/zoom/zoom-1.1.5-r1.ebuild
index 20d982f0281d..1f5085ae61da 100644
--- a/games-engines/zoom/zoom-1.1.5-r1.ebuild
+++ b/games-engines/zoom/zoom-1.1.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -22,6 +22,8 @@ DEPEND="${RDEPEND}
dev-lang/perl
x11-proto/xextproto"
+PATCHES=( "${FILESDIR}"/${P}-gcc7.patch )
+
src_install() {
default
dodoc -r manual/*