summaryrefslogtreecommitdiff
path: root/games-engines/scummvm-tools/scummvm-tools-2.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
commit677b7ba5c317778df2ad7e70df94b9b7eec4adbc (patch)
tree6c418a1546fff5becab5d8b9ed6803323e7f316e /games-engines/scummvm-tools/scummvm-tools-2.2.0.ebuild
parentfbda87924e6faa7a1919f1a2b4182490bde5ec5c (diff)
gentoo resync : 10.09.2021
Diffstat (limited to 'games-engines/scummvm-tools/scummvm-tools-2.2.0.ebuild')
-rw-r--r--games-engines/scummvm-tools/scummvm-tools-2.2.0.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/games-engines/scummvm-tools/scummvm-tools-2.2.0.ebuild b/games-engines/scummvm-tools/scummvm-tools-2.2.0.ebuild
index c514a09b8b71..3af45ddd2fa7 100644
--- a/games-engines/scummvm-tools/scummvm-tools-2.2.0.ebuild
+++ b/games-engines/scummvm-tools/scummvm-tools-2.2.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
WX_GTK_VER=3.0-gtk3
inherit wxwidgets toolchain-funcs
@@ -17,7 +17,7 @@ IUSE="flac iconv mad png vorbis"
RESTRICT="test" # some tests require external files
RDEPEND="
- >=dev-libs/boost-1.32:=
+ dev-libs/boost:=
sys-libs/zlib
x11-libs/wxGTK:${WX_GTK_VER}
flac? ( media-libs/flac )
@@ -35,17 +35,18 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-1.8.0-binprefix.patch"
+ "${FILESDIR}/${PN}-2.2.0-strings.patch"
)
src_prepare() {
default
- rm -rf *.bat dists/win32 || die
- sed -ri -e '/^(CC|CXX)\b/d' Makefile || die
+ rm -r *.bat dists/win32 || die
}
src_configure() {
setup-wxwidgets
+ tc-export CXX STRINGS
# Not an autoconf script
./configure \
@@ -61,10 +62,6 @@ src_configure() {
$(use_enable vorbis) || die
}
-src_compile() {
- emake STRINGS="$(tc-getSTRINGS)"
-}
-
src_install() {
EXEPREFIX="${PN}-" default
}