summaryrefslogtreecommitdiff
path: root/games-engines/qtads
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /games-engines/qtads
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'games-engines/qtads')
-rw-r--r--games-engines/qtads/Manifest3
-rw-r--r--games-engines/qtads/files/qtads-3.0-fluidsynth.patch55
-rw-r--r--games-engines/qtads/qtads-3.0.0.ebuild6
3 files changed, 62 insertions, 2 deletions
diff --git a/games-engines/qtads/Manifest b/games-engines/qtads/Manifest
index 784570c980d7..9018b7de037c 100644
--- a/games-engines/qtads/Manifest
+++ b/games-engines/qtads/Manifest
@@ -1,3 +1,4 @@
+AUX qtads-3.0-fluidsynth.patch 1817 BLAKE2B 32f61fde3f3521c7d50ca8b67d5a66721caec4595e6a98a15f4434f6da6dda62b75521d64349252a11fd15e0fc62d301db0329dc07ce56783e7eac8beafef791 SHA512 37c0c5e7ad76d9b483c6e3aa02d1b8673bae50820c48197dc1649efed888ee6156a3a935add16ccd006de43e9067e29f0de8b893c85a476ae4b4b32597799253
DIST qtads-3.0.0-source.tar.xz 5325048 BLAKE2B cb60908e71edb32157638891a58bed83aba01d484821473716c17845094be9232f9e989bad474db27c1e06734b073ee301756b0528ca880e4c40c0994e95bc48 SHA512 e7b72350876475e0b5b9b8c8c953aa380f5f25dade25785d15c5004a6866bb614c3ca2a3b34f84989013e350f9e73d339ce8ddd7d36766d80a981cfbfda7d1c6
-EBUILD qtads-3.0.0.ebuild 849 BLAKE2B a469fe456498ad1f5cb4b7febfdaeb830f4dd10bc9e9997fe22b1fc0c11b4228debfc92b3e0485167f5770315d3db03c208ddf25039abb1635c6ce696cf93f74 SHA512 6617c58720706b65c60101bc60677850352c09a7312f1037347da4dabe1b351ae70bd0c2c8ee243edf9fb3bb085f069a177dd1bcaf683b9ac259162533750f4c
+EBUILD qtads-3.0.0.ebuild 912 BLAKE2B 227fa26b32e4b8e3f41341930fff294bb491d5fddba9dc3624b5a72611704e1932b2d872826c404670a42d4ba098da949288826165c000248031a48144fe3427 SHA512 4d71f4eaffb9dfdd589a67ef123535d1289b03d18139afb81de60c3b0a91488a9985b5549ad35abe895c5e50bb0fcba4be8c1edde8797cffd7943424bf574fd7
MISC metadata.xml 599 BLAKE2B 51ed09fd074eb06d9b3abd5274531653f791323717dc3e1f1ab246f10a80daec5c689f9c0083b62d84560862ec1932b892b4896c122c1cfa284613a0f27663df SHA512 73b2eeac86fd8e65a122adc472e108173d2f9423500ef2bce48f32a0c3b956e41c4bdff1bd8e451d07a8b973e358238b482d28866056c60785c39b47c0e8c5f9
diff --git a/games-engines/qtads/files/qtads-3.0-fluidsynth.patch b/games-engines/qtads/files/qtads-3.0-fluidsynth.patch
new file mode 100644
index 000000000000..0104d35098dc
--- /dev/null
+++ b/games-engines/qtads/files/qtads-3.0-fluidsynth.patch
@@ -0,0 +1,55 @@
+From eedae0e7c67da4e12c65ef049665258c1d8f44a8 Mon Sep 17 00:00:00 2001
+From: Michal Petrucha <michal.petrucha@koniiiik.org>
+Date: Thu, 22 Apr 2021 22:55:40 +0200
+Subject: [PATCH] Add support for fluidsynth 2.2.0
+
+---
+ SDL_audiolib/src/DecoderFluidsynth.cpp | 14 +++++++++++---
+ 1 file changed, 11 insertions(+), 3 deletions(-)
+
+diff --git a/SDL_audiolib/src/DecoderFluidsynth.cpp b/SDL_audiolib/src/DecoderFluidsynth.cpp
+index 62a99df..0f4760d 100644
+--- a/SDL_audiolib/src/DecoderFluidsynth.cpp
++++ b/SDL_audiolib/src/DecoderFluidsynth.cpp
+@@ -11,6 +11,14 @@
+ #include <cstdio>
+ #include <fluidsynth.h>
+
++#if FLUIDSYNTH_VERSION_MAJOR == 2 && FLUIDSYNTH_VERSION_MINOR >= 2
++using read_cb_count_type = fluid_long_long_t;
++using seek_cb_offset_type = fluid_long_long_t;
++#else
++using read_cb_count_type = int;
++using seek_cb_offset_type = long;
++#endif
++
+ namespace chrono = std::chrono;
+
+ static fluid_settings_t* settings = nullptr;
+@@ -36,7 +44,7 @@ static void* sfontOpenCb(const char* filename)
+ return rwops;
+ }
+
+-static int sfontReadCb(void* dst, int count, void* rwops)
++static int sfontReadCb(void* dst, read_cb_count_type count, void* rwops)
+ {
+ Buffer<char> buf(count);
+ if (SDL_RWread(static_cast<SDL_RWops*>(rwops), buf.get(), 1, count) <= 0) {
+@@ -46,7 +54,7 @@ static int sfontReadCb(void* dst, int count, void* rwops)
+ return FLUID_OK;
+ }
+
+-static int sfontSeekCb(void* rwops, long offset, int whence)
++static int sfontSeekCb(void* rwops, seek_cb_offset_type offset, int whence)
+ {
+ switch (whence) {
+ case SEEK_SET:
+@@ -72,7 +80,7 @@ static int sfontCloseCb(void* rwops)
+ return FLUID_OK;
+ }
+
+-static long sfontTellCb(void* rwops)
++static seek_cb_offset_type sfontTellCb(void* rwops)
+ {
+ auto pos = SDL_RWtell(static_cast<SDL_RWops*>(rwops));
+ if (pos == -1) {
diff --git a/games-engines/qtads/qtads-3.0.0.ebuild b/games-engines/qtads/qtads-3.0.0.ebuild
index 57d338defea2..e375495f938f 100644
--- a/games-engines/qtads/qtads-3.0.0.ebuild
+++ b/games-engines/qtads/qtads-3.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -31,6 +31,10 @@ DEPEND="
"
RDEPEND=${DEPEND}
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0-fluidsynth.patch #785235
+)
+
src_configure() {
eqmake5 \
PREFIX="${EPREFIX}/usr" \