summaryrefslogtreecommitdiff
path: root/games-engines/qtads
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-engines/qtads
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-engines/qtads')
-rw-r--r--games-engines/qtads/Manifest3
-rw-r--r--games-engines/qtads/metadata.xml11
-rw-r--r--games-engines/qtads/qtads-2.1.7-r1.ebuild49
3 files changed, 63 insertions, 0 deletions
diff --git a/games-engines/qtads/Manifest b/games-engines/qtads/Manifest
new file mode 100644
index 000000000000..32678d3baed8
--- /dev/null
+++ b/games-engines/qtads/Manifest
@@ -0,0 +1,3 @@
+DIST qtads-2.1.7.tar.bz2 2562026 BLAKE2B daa66022db1b187c2d74fc762fdb60beefb0988401464382d14c6f9bc1455a8046e212cdba9d834decb0efe053b3bb430392696b12bd4f94aaa006744c53a65e SHA512 ab88aa20991642df6048af49d2cd7b804dbb98b3f5c6ab38ad974e8b39531d880eac0eae0ba773f332e9568578b76b677bc35753f7d1e6d9a99d919b15f4c6ee
+EBUILD qtads-2.1.7-r1.ebuild 930 BLAKE2B d8df948d8da8a646e0a2f4e6586e10b03afdc1fd3bd2b9aa9a7a4f50babae0b98166ab2a993625f1b4508090c095ee1d4fde94508547ef5d7db4b5b5380c7cdc SHA512 ea1feb7b2aabc0f403e3176b1a51f3c5924b787a73bdcbd28dc557ffa049f57d7e6b3b14b9885ac66892e6f3ba74e36dd7dcb1a6bc2bfd599486ab85c6c93b5c
+MISC metadata.xml 338 BLAKE2B e923224db53da22487dff5dc33486c7a9b7391d7dbf26a5c11392e0b0808b177488b8b442b888077039d66679cdbd9e87a8389ae347cbc17443eda7e86078015 SHA512 18a82c16eb83363eb440ad9ca6ce1c612a17011194b3e1f50ac2563c0ef72c96c8618643f25ed8df81c852045a281498fabf18468c2181051f28e584738b8472
diff --git a/games-engines/qtads/metadata.xml b/games-engines/qtads/metadata.xml
new file mode 100644
index 000000000000..b4146b480895
--- /dev/null
+++ b/games-engines/qtads/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">qtads</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-engines/qtads/qtads-2.1.7-r1.ebuild b/games-engines/qtads/qtads-2.1.7-r1.ebuild
new file mode 100644
index 000000000000..500c1f64211d
--- /dev/null
+++ b/games-engines/qtads/qtads-2.1.7-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils qmake-utils xdg flag-o-matic
+
+DESCRIPTION="Multimedia interpreter for TADS text adventures"
+HOMEPAGE="http://qtads.sourceforge.net"
+SRC_URI="mirror://sourceforge/qtads/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound]
+ media-libs/sdl-mixer[midi,vorbis]
+ media-libs/sdl-sound[mp3]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # bug 654356 temp fix
+ append-cxxflags -fpermissive
+ eqmake5 qtads.pro -after CONFIG-=silent
+}
+
+src_install() {
+ dobin qtads
+ dodoc AUTHORS HTML_TADS_LICENSE NEWS README
+ insinto /usr
+ doins -r share
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_pkg_postrm
+}