summaryrefslogtreecommitdiff
path: root/games-engines/openxcom
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-engines/openxcom
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-engines/openxcom')
-rw-r--r--games-engines/openxcom/Manifest4
-rw-r--r--games-engines/openxcom/metadata.xml11
-rw-r--r--games-engines/openxcom/openxcom-1.0.0_p20180317.ebuild61
-rw-r--r--games-engines/openxcom/openxcom-9999.ebuild59
4 files changed, 135 insertions, 0 deletions
diff --git a/games-engines/openxcom/Manifest b/games-engines/openxcom/Manifest
new file mode 100644
index 000000000000..a4124c1a1aec
--- /dev/null
+++ b/games-engines/openxcom/Manifest
@@ -0,0 +1,4 @@
+DIST openxcom-1.0.0_p20180317.tar.gz 2801430 BLAKE2B 8a3718fc99f733c145034509b596de8dd17a8bdfe1aa05b68571c66245eea45f997488e57a2811f604e0aac702e30614fcd55ecc71858f49b357afb9e8fc5de4 SHA512 57ff9a9cbbbf48b8c4f792458edf0590d7d0df9a5805eab13a4c984713311e98587afca00778e82bd66fb2f330b354ca80703b87922a92f9ae48e5bdecf68442
+EBUILD openxcom-1.0.0_p20180317.ebuild 1690 BLAKE2B a46c2486a3d63e53ba50d3f6e3f41987cbdfe05b61aba997cad9f8fa99a6d69ee0e0cb5f6c77fde3a76185c81862dfdf02e67cb5365a82c0709621ac62ad9d71 SHA512 a5fe223e4cba4e530a99712f5e2650b50758fccebac99e8f036890efcfec672bed5dbca692ca8288ebc078b84589b850ab9635b965366c47138c0417ddfe43d6
+EBUILD openxcom-9999.ebuild 1572 BLAKE2B 3c949b4b4c1d130adf0a7dfcef819028d5019492243d79ad715be3f8c01f77af2405e381f8167a6ad802f3a03a5b139b23a4e808d39d04b5d2bb202a81e84ced SHA512 931ae79bc045eb233f83e521f5429958057940c5155077ddbe7a49867e8d9f72bbe79ad8c0f908d784a05ef48d63e069abf4da011d0259091add59915ab221df
+MISC metadata.xml 335 BLAKE2B c1f058cb6d2d5fb842d9c198a4d68e43457d6bb7f5bed00d5365d1418afc83a54d3d8d816a312f715abf57d942877874ed92cf716477ab912fe2480afbea32bf SHA512 6d1deba17f18970b9425af0038c24be6f0e0fea46a095d34055884d8899442bc1f0a4f72343f2cf1f66f63c5287dc0373086e111b45ee64a47b8715e2237d6cd
diff --git a/games-engines/openxcom/metadata.xml b/games-engines/openxcom/metadata.xml
new file mode 100644
index 000000000000..86822013a1c2
--- /dev/null
+++ b/games-engines/openxcom/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">SupSuper/OpenXcom</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-engines/openxcom/openxcom-1.0.0_p20180317.ebuild b/games-engines/openxcom/openxcom-1.0.0_p20180317.ebuild
new file mode 100644
index 000000000000..d76a38f5f0b2
--- /dev/null
+++ b/games-engines/openxcom/openxcom-1.0.0_p20180317.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils gnome2-utils
+
+COMMIT="ea9ac466221f8b4f8974d2db1c42dc4ad6126564"
+DESCRIPTION="An open-source reimplementation of the popular UFO: Enemy Unknown"
+HOMEPAGE="https://openxcom.org/"
+SRC_URI="https://github.com/SupSuper/OpenXcom/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+ CC-BY-SA-4.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-cpp/yaml-cpp-0.5.1
+ media-libs/libsdl[opengl,video]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[flac,mikmod,vorbis]"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}/OpenXcom-${COMMIT}"
+DOCS=( README.md )
+
+src_compile() {
+ use doc && cmake-utils_src_compile doxygen
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc -r "${CMAKE_BUILD_DIR}"/docs/html/*
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ echo
+ elog "In order to play you need copy GEODATA, GEOGRAPH, MAPS, ROUTES, SOUND,"
+ elog "TERRAIN, UFOGRAPH, UFOINTRO, UNITS folders from original X-COM game to"
+ elog "/usr/share/${PN}/UFO"
+ echo
+ elog "If you want to play the TFTD mod, you need to copy ANIMS, FLOP_INT,"
+ elog "GEODATA, GEOGRAPH, MAPS, ROUTES, SOUND, TERRAIN, UFOGRAPH, UNITS folders"
+ elog "from the original Terror from the Deep game to"
+ elog "/usr/share/${PN}/TFTD"
+ echo
+ elog "If you need or want text in some language other than english, download:"
+ elog "https://openxcom.org/translations/latest.zip and uncompress it in"
+ elog "/usr/share/${PN}/common/Language"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-engines/openxcom/openxcom-9999.ebuild b/games-engines/openxcom/openxcom-9999.ebuild
new file mode 100644
index 000000000000..7726841e5584
--- /dev/null
+++ b/games-engines/openxcom/openxcom-9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils gnome2-utils git-r3
+
+DESCRIPTION="An open-source reimplementation of the popular UFO: Enemy Unknown"
+HOMEPAGE="https://openxcom.org/"
+EGIT_REPO_URI="https://github.com/SupSuper/OpenXcom.git"
+
+LICENSE="GPL-3+ CC-BY-SA-4.0"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc"
+
+RDEPEND=">=dev-cpp/yaml-cpp-0.5.1
+ media-libs/libsdl[opengl,video]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[flac,mikmod,vorbis]"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+DOCS=( README.md )
+
+src_compile() {
+ use doc && cmake-utils_src_compile doxygen
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc -r "${CMAKE_BUILD_DIR}"/docs/html/*
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ echo
+ elog "In order to play you need copy GEODATA, GEOGRAPH, MAPS, ROUTES, SOUND,"
+ elog "TERRAIN, UFOGRAPH, UFOINTRO, UNITS folders from original X-COM game to"
+ elog "/usr/share/${PN}/UFO"
+ echo
+ elog "If you want to play the TFTD mod, you need to copy ANIMS, FLOP_INT,"
+ elog "GEODATA, GEOGRAPH, MAPS, ROUTES, SOUND, TERRAIN, UFOGRAPH, UNITS folders"
+ elog "from the original Terror from the Deep game to"
+ elog "/usr/share/${PN}/TFTD"
+ echo
+ elog "If you need or want text in some language other than english, download:"
+ elog "https://openxcom.org/translations/latest.zip and uncompress it in"
+ elog "/usr/share/${PN}/common/Language"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}