summaryrefslogtreecommitdiff
path: root/games-engines/frotz/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-engines/frotz/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-engines/frotz/files')
-rw-r--r--games-engines/frotz/files/frotz-2.43-glibc2.10.patch29
-rw-r--r--games-engines/frotz/files/frotz-2.43-ldflags.patch20
2 files changed, 49 insertions, 0 deletions
diff --git a/games-engines/frotz/files/frotz-2.43-glibc2.10.patch b/games-engines/frotz/files/frotz-2.43-glibc2.10.patch
new file mode 100644
index 000000000000..3f2639ec47d0
--- /dev/null
+++ b/games-engines/frotz/files/frotz-2.43-glibc2.10.patch
@@ -0,0 +1,29 @@
+--- a/src/dumb/dumb_input.c
++++ b/src/dumb/dumb_input.c
+@@ -79,7 +79,7 @@
+ /* Read one line, including the newline, into s. Safely avoids buffer
+ * overruns (but that's kind of pointless because there are several
+ * other places where I'm not so careful). */
+-static void getline(char *s)
++static void get_line(char *s)
+ {
+ int c;
+ char *p = s;
+@@ -203,7 +203,7 @@
+ fputs(prompt, stdout);
+ else
+ dumb_show_prompt(show_cursor, (timeout ? "tTD" : ")>}")[type]);
+- getline(s);
++ get_line(s);
+ if ((s[0] != '\\') || ((s[1] != '\0') && !islower(s[1]))) {
+ /* Is not a command line. */
+ translate_special_chars(s);
+@@ -265,7 +265,7 @@
+ if (!*current_page)
+ break;
+ printf("HELP: Type <return> for more, or q <return> to stop: ");
+- getline(s);
++ get_line(s);
+ if (!strcmp(s, "q\n"))
+ break;
+ }
diff --git a/games-engines/frotz/files/frotz-2.43-ldflags.patch b/games-engines/frotz/files/frotz-2.43-ldflags.patch
new file mode 100644
index 000000000000..c8b4e35eee20
--- /dev/null
+++ b/games-engines/frotz/files/frotz-2.43-ldflags.patch
@@ -0,0 +1,20 @@
+--- a/Makefile 2010-10-04 14:13:37.000000000 +0200
++++ b/Makefile 2010-10-04 14:14:06.000000000 +0200
+@@ -162,7 +162,7 @@
+ $(NAME): $(NAME)-curses
+
+ $(NAME)-curses: soundcard.h $(COMMON_TARGET) $(CURSES_TARGET)
+- $(CC) -o $(BINNAME)$(EXTENSION) $(TARGETS) $(LIB) $(CURSES) \
++ $(CC) $(LDFLAGS) -o $(BINNAME)$(EXTENSION) $(TARGETS) $(LIB) $(CURSES) \
+ $(SOUND_LIB)
+
+ all: $(NAME) d$(NAME)
+@@ -170,7 +170,7 @@
+ dumb: $(NAME)-dumb
+ d$(NAME): $(NAME)-dumb
+ $(NAME)-dumb: $(COMMON_TARGET) $(DUMB_TARGET)
+- $(CC) -o d$(BINNAME)$(EXTENSION) $(COMMON_TARGET) \
++ $(CC) $(LDFLAGS) -o d$(BINNAME)$(EXTENSION) $(COMMON_TARGET) \
+ $(DUMB_TARGET) $(LIB)
+
+ .SUFFIXES: