summaryrefslogtreecommitdiff
path: root/games-engines/frotz/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:58:29 +0100
commit0cf2f20608308acdf3cb922c3736446bbd8f3388 (patch)
tree07815070629c7c11000a7f51ceb8ccbccb49a809 /games-engines/frotz/files
parent1798c4aeca70ac8d0a243684d6a798fbc65735f8 (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-engines/frotz/files')
-rw-r--r--games-engines/frotz/files/frotz-2.43-glibc2.10.patch29
-rw-r--r--games-engines/frotz/files/frotz-2.43-ldflags.patch20
2 files changed, 0 insertions, 49 deletions
diff --git a/games-engines/frotz/files/frotz-2.43-glibc2.10.patch b/games-engines/frotz/files/frotz-2.43-glibc2.10.patch
deleted file mode 100644
index 3f2639ec47d0..000000000000
--- a/games-engines/frotz/files/frotz-2.43-glibc2.10.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/src/dumb/dumb_input.c
-+++ b/src/dumb/dumb_input.c
-@@ -79,7 +79,7 @@
- /* Read one line, including the newline, into s. Safely avoids buffer
- * overruns (but that's kind of pointless because there are several
- * other places where I'm not so careful). */
--static void getline(char *s)
-+static void get_line(char *s)
- {
- int c;
- char *p = s;
-@@ -203,7 +203,7 @@
- fputs(prompt, stdout);
- else
- dumb_show_prompt(show_cursor, (timeout ? "tTD" : ")>}")[type]);
-- getline(s);
-+ get_line(s);
- if ((s[0] != '\\') || ((s[1] != '\0') && !islower(s[1]))) {
- /* Is not a command line. */
- translate_special_chars(s);
-@@ -265,7 +265,7 @@
- if (!*current_page)
- break;
- printf("HELP: Type <return> for more, or q <return> to stop: ");
-- getline(s);
-+ get_line(s);
- if (!strcmp(s, "q\n"))
- break;
- }
diff --git a/games-engines/frotz/files/frotz-2.43-ldflags.patch b/games-engines/frotz/files/frotz-2.43-ldflags.patch
deleted file mode 100644
index c8b4e35eee20..000000000000
--- a/games-engines/frotz/files/frotz-2.43-ldflags.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/Makefile 2010-10-04 14:13:37.000000000 +0200
-+++ b/Makefile 2010-10-04 14:14:06.000000000 +0200
-@@ -162,7 +162,7 @@
- $(NAME): $(NAME)-curses
-
- $(NAME)-curses: soundcard.h $(COMMON_TARGET) $(CURSES_TARGET)
-- $(CC) -o $(BINNAME)$(EXTENSION) $(TARGETS) $(LIB) $(CURSES) \
-+ $(CC) $(LDFLAGS) -o $(BINNAME)$(EXTENSION) $(TARGETS) $(LIB) $(CURSES) \
- $(SOUND_LIB)
-
- all: $(NAME) d$(NAME)
-@@ -170,7 +170,7 @@
- dumb: $(NAME)-dumb
- d$(NAME): $(NAME)-dumb
- $(NAME)-dumb: $(COMMON_TARGET) $(DUMB_TARGET)
-- $(CC) -o d$(BINNAME)$(EXTENSION) $(COMMON_TARGET) \
-+ $(CC) $(LDFLAGS) -o d$(BINNAME)$(EXTENSION) $(COMMON_TARGET) \
- $(DUMB_TARGET) $(LIB)
-
- .SUFFIXES: