summaryrefslogtreecommitdiff
path: root/games-engines/frotz/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-11 01:49:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-11 01:49:36 +0000
commitcf7807d7aea23a99a144afceaba961cfed652b5f (patch)
treeffd2c781c27e0b7e72152a685a04938a2b7966f0 /games-engines/frotz/files
parent7c5ebaf83da4c538dd11b56fdd5dfdf39dcbc096 (diff)
gentoo auto-resync : 11:03:2025 - 01:49:36HEADmaster
Diffstat (limited to 'games-engines/frotz/files')
-rw-r--r--games-engines/frotz/files/frotz-2.55-makefile-ordering.patch27
-rw-r--r--games-engines/frotz/files/frotz-2.55-which.patch57
-rw-r--r--games-engines/frotz/files/frotz-stray-dollar.patch26
3 files changed, 84 insertions, 26 deletions
diff --git a/games-engines/frotz/files/frotz-2.55-makefile-ordering.patch b/games-engines/frotz/files/frotz-2.55-makefile-ordering.patch
new file mode 100644
index 000000000000..8fa1f3bf42b4
--- /dev/null
+++ b/games-engines/frotz/files/frotz-2.55-makefile-ordering.patch
@@ -0,0 +1,27 @@
+https://gitlab.com/DavidGriffith/frotz/-/commit/52be64afc92a6ea0a982ff83205a67cbfb94b619
+From 52be64afc92a6ea0a982ff83205a67cbfb94b619 Mon Sep 17 00:00:00 2001
+From: David Griffith <dave@661.org>
+Date: Thu, 6 Feb 2025 19:16:11 -0800
+Subject: [PATCH] Fixed potential SDL interface build failure when using "make
+ -j".
+
+---
+ src/sdl/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/sdl/Makefile b/src/sdl/Makefile
+index e21477e6..fd07089c 100644
+--- a/src/sdl/Makefile
++++ b/src/sdl/Makefile
+@@ -31,7 +31,7 @@ $(TARGET): $(DEFINES) $(OBJECTS) | $(DEFINES)
+ $(RANLIB) $@
+ @echo "** Done with SDL interface."
+
+-%.o: %.c
++%.o: %.c $(DEFINES)
+ $(CC) $(CFLAGS) $(SDL_CFLAGS) -fPIC -fpic -o $@ -c $<
+
+ $(DEFINES):
+--
+GitLab
+
diff --git a/games-engines/frotz/files/frotz-2.55-which.patch b/games-engines/frotz/files/frotz-2.55-which.patch
new file mode 100644
index 000000000000..d8252a13a1cf
--- /dev/null
+++ b/games-engines/frotz/files/frotz-2.55-which.patch
@@ -0,0 +1,57 @@
+Remove which from Makefile
+https://bugs.gentoo.org/949843
+--- a/Makefile 2025-02-26 12:50:58.083970908 +0400
++++ b/Makefile 2025-02-26 12:51:26.363195573 +0400
+@@ -146,8 +146,8 @@
+ endif
+
+ # Determine what system we are on.
+-RANLIB ?= $(shell which ranlib)
+-AR ?= $(shell which ar)
++RANLIB ?= $(shell command -v ranlib)
++AR ?= $(shell command -v ar)
+ # For now, assume !windows == unix.
+ OS_TYPE ?= unix
+ UNAME_S := $(shell uname -s)
+@@ -175,12 +175,12 @@
+ PKGCONF_BIN ?= pkgconf
+ PKG_CONFIG_BIN ?= pkg-config
+ # If we don't have pkgconf", check if pkg-config is available.
+-ifneq ($(shell which $(PKGCONF_BIN)),)
++ifneq ($(shell command -v $(PKGCONF_BIN)),)
+ PKGCONF = $(PKGCONF_BIN)
+ else
+ $(warning *** Could not find $(PKGCONF_BIN). Is $(PKG_CONFIG_BIN) available?)
+ # Check if pkg-config is available.
+-ifneq ($(shell which $(PKG_CONFIG_BIN)),)
++ifneq ($(shell command -v $(PKG_CONFIG_BIN)),)
+ $(warning *** Found $(PKG_CONFIG_BIN)! Now proceeding normally.)
+ PKGCONF = $(PKG_CONFIG_BIN)
+ else
+@@ -332,7 +332,7 @@
+ # If not, make it clear that we're working from a release.
+ #
+ GIT_DIR ?= .git
+-ifneq ($(and $(wildcard $(GIT_DIR)),$(shell which git)),)
++ifneq ($(and $(wildcard $(GIT_DIR)),$(shell command -v git)),)
+ GIT_HASH = $(shell git rev-parse HEAD)
+ GIT_HASH_SHORT = $(shell git rev-parse --short=8 HEAD)
+ GIT_DATE = $(shell git show -s --format=%ci)
+@@ -476,7 +476,7 @@
+
+ owdos: $(DOS_BIN)
+ $(DOS_BIN): $(COMMON_DEFINES) $(HASH)
+-ifneq ($(shell which wmake),)
++ifneq ($(shell command -v wmake),)
+ wmake -f Makefile.ow
+ else
+ $(error wmake command not found. Cannot make the DOS version)
+@@ -786,7 +786,7 @@
+
+ dist: $(NAME)-$(VERSION).tar.gz
+ frotz-$(VERSION).tar.gz:
+-ifneq ($(and $(wildcard $(GIT_DIR)),$(shell which git)),)
++ifneq ($(and $(wildcard $(GIT_DIR)),$(shell command -v git)),)
+ git archive --format=tgz --prefix $(NAME)-$(VERSION)/ HEAD -o $(NAME)-$(VERSION).tar.gz
+ @echo $(NAME)-$(VERSION).tar.gz created.
+ else
diff --git a/games-engines/frotz/files/frotz-stray-dollar.patch b/games-engines/frotz/files/frotz-stray-dollar.patch
deleted file mode 100644
index 9cc2a4212741..000000000000
--- a/games-engines/frotz/files/frotz-stray-dollar.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 7c14d1bd6c129670869db0dc6c025c68f28944a4 Mon Sep 17 00:00:00 2001
-From: James Le Cuirot <chewi@gentoo.org>
-Date: Tue, 21 May 2024 22:53:33 +0100
-Subject: [PATCH] Fix stray $ that breaks the frotz filename when specifying
- LDFLAGS
-
----
- Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Makefile b/Makefile
-index 8860297..35d8246 100644
---- a/Makefile
-+++ b/Makefile
-@@ -394,7 +394,7 @@ DOSVER = $(shell echo $(VERSION) | sed s/\\.//g)
- curses: $(FROTZ_BIN)
- ncurses: $(FROTZ_BIN)
- $(FROTZ_BIN): $(FROTZ_LIBS)
-- $(CC) $+ -o $@$ $(LDFLAGS) $(CURSES_LDFLAGS) $(CURSES_SOUND_LDFLAGS)
-+ $(CC) $+ -o $@ $(LDFLAGS) $(CURSES_LDFLAGS) $(CURSES_SOUND_LDFLAGS)
- @echo "** Done building Frotz with curses interface"
- @echo "** Audio support $(CURSES_SOUND) (type $(SOUND_TYPE))"
- @echo "** Blorb support $(BLORB_SUPPORT)"
---
-2.45.1
-