summaryrefslogtreecommitdiff
path: root/games-engines/frobtads
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-engines/frobtads
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-engines/frobtads')
-rw-r--r--games-engines/frobtads/Manifest5
-rw-r--r--games-engines/frobtads/frobtads-1.2.3-r1.ebuild47
-rw-r--r--games-engines/frobtads/frobtads-1.2.4.ebuild41
-rw-r--r--games-engines/frobtads/metadata.xml12
4 files changed, 105 insertions, 0 deletions
diff --git a/games-engines/frobtads/Manifest b/games-engines/frobtads/Manifest
new file mode 100644
index 000000000000..b16691571e38
--- /dev/null
+++ b/games-engines/frobtads/Manifest
@@ -0,0 +1,5 @@
+DIST frobtads-1.2.3.tar.gz 5227704 BLAKE2B fd481201da6dbddf3b0f5adf7c600282c9500bd65cebebf13e23b139ca1e9793091c6df50bebebed179c6f775d188c8ccbe8450d0058863c55dd322e8a92ce32 SHA512 4efb888860edda24bb5a5812967d0b863614558e9839cf0cfabc649ab0175719bf663de5e725034ba160c015d269dbe2df046cf47ad1019e668bf5b1fb564d7d
+DIST frobtads-1.2.4.tar.bz2 3801366 BLAKE2B 871a4cfd432f1a72915de0652def2f2a9a3cf1bfa20b070c2e59ced673c736584a36b3d17e7d5812ad7cd883c3e038e49f962635a5794d6c914d99651bfd0a55 SHA512 f49f58114cbd78f23fcc3835025af7874da968af825abd449e9ab83c4a90e8d70f8cfafa83780f0631ae9bd2793cce2d5dd947c13ee38ba0d06829d2803abf12
+EBUILD frobtads-1.2.3-r1.ebuild 1084 BLAKE2B 3b4ac366d3b1730473a251261f0c08f24ae8b5c3a9e70fe9f359574a409c2f8f4b62806c92f48ae26c2e5998933a64c098940c33050961ce93becc5c48495c18 SHA512 8f7b51246acedd865d9a396819545964fbcfc69f61c8381b0da2387fb8695fe9655d07097d448a74a8a3606ff3b9f32c738f829e9942ee8bdfc8b332f435c909
+EBUILD frobtads-1.2.4.ebuild 1006 BLAKE2B cda1e9f790d9dd484b026e97389a04480b22f7887581cdf68f102ba877ee6d6d31de66a4745e6e2e32167f79e733cd5b4a473a4d80b85d79985eb01c5c5b3155 SHA512 26e02d7c095cc5c5b0bfa1a0db650b9045c4ab648c6484f4f1237352693dfa15abea91e8b7014082b30245987f52de22b4e5aa29a24c272fb22b26a154bdf1ae
+MISC metadata.xml 394 BLAKE2B db39dd99a448935896847c3ce0c824a3043d65d82e7d35cad3afab2538aebffca96c532f83182bf2e28fab22fcb0d6145e6e5a383def6d956db6d0558e73f481 SHA512 591c0df18a2e4e1469e1f95dce9c74f3b66261377b88ec9dde79c56094253a5579427a2fa836fb1c2926344b95a471b7d13bda4a53f4c6a064b06c61d89e1ab3
diff --git a/games-engines/frobtads/frobtads-1.2.3-r1.ebuild b/games-engines/frobtads/frobtads-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..7b35a8571c33
--- /dev/null
+++ b/games-engines/frobtads/frobtads-1.2.3-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils flag-o-matic
+
+DESCRIPTION="Curses-based interpreter and dev tools for TADS 2 and TADS 3 text adventures"
+HOMEPAGE="http://www.tads.org/frobtads.htm"
+SRC_URI="http://www.tads.org/frobtads/${P}.tar.gz"
+
+LICENSE="TADS2 TADS3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug tads2compiler tads3compiler"
+
+RESTRICT="!tads3compiler? ( test )"
+
+RDEPEND="net-misc/curl
+ sys-libs/ncurses:0"
+DEPEND=${RDEPEND}
+
+DOCS=( doc/{AUTHORS,BUGS,ChangeLog.old,NEWS,README,SRC_GUIDELINES,THANKS} )
+
+src_configure() {
+ append-cxxflags -fpermissive
+ append-libs $(curl-config --libs)
+ econf \
+ $(use_enable debug error-checking) \
+ $(use_enable debug t3debug) \
+ $(use_enable tads2compiler t2-compiler) \
+ $(use_enable tads3compiler t3-compiler)
+}
+
+src_test() {
+ emake -j1 sample
+ ./frob -i plain -p samples/sample.t3 <<- END_FROB_TEST
+ save
+ testsave.sav
+ restore
+ testsave.sav
+ END_FROB_TEST
+ [[ $? -eq 0 ]] || die "Failed to run test game"
+}
+
+src_install() {
+ default
+}
diff --git a/games-engines/frobtads/frobtads-1.2.4.ebuild b/games-engines/frobtads/frobtads-1.2.4.ebuild
new file mode 100644
index 000000000000..7f2b43c14462
--- /dev/null
+++ b/games-engines/frobtads/frobtads-1.2.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Curses-based interpreter and dev tools for TADS 2 and TADS 3 text adventures"
+HOMEPAGE="http://www.tads.org/frobtads.htm"
+SRC_URI="https://github.com/realnc/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="TADS2 TADS3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug tads2compiler tads3compiler"
+
+RESTRICT="!tads3compiler? ( test )"
+
+RDEPEND="net-misc/curl
+ sys-libs/ncurses:0"
+DEPEND=${RDEPEND}
+
+DOCS=( doc/{AUTHORS,BUGS,ChangeLog.old,NEWS,README,SRC_GUIDELINES,THANKS} )
+
+src_configure() {
+ econf \
+ $(use_enable debug error-checking) \
+ $(use_enable debug t3debug) \
+ $(use_enable tads2compiler t2-compiler) \
+ $(use_enable tads3compiler t3-compiler)
+}
+
+src_test() {
+ emake -j1 sample
+ ./frob -i plain -p samples/sample.t3 <<- END_FROB_TEST
+ save
+ testsave.sav
+ restore
+ testsave.sav
+ END_FROB_TEST
+ [[ $? -eq 0 ]] || die "Failed to run test game"
+}
diff --git a/games-engines/frobtads/metadata.xml b/games-engines/frobtads/metadata.xml
new file mode 100644
index 000000000000..89569b770284
--- /dev/null
+++ b/games-engines/frobtads/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="tads2compiler">Build TADS2 compiler</flag>
+ <flag name="tads3compiler">Build TADS3 compiler</flag>
+ </use>
+</pkgmetadata>