summaryrefslogtreecommitdiff
path: root/games-emulation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-23 10:47:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-23 10:47:12 +0000
commit02d5de423c2b7f8d7c873bcc7a1a222b1847149d (patch)
tree29d109245f3aa2842c63489c8ec537f85e92ff41 /games-emulation
parent0770f5276c9044be774368cba8d9d8ce7a43627a (diff)
gentoo auto-resync : 23:01:2024 - 10:47:12
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/Manifest.gzbin12029 -> 12026 bytes
-rw-r--r--games-emulation/stella/Manifest2
-rw-r--r--games-emulation/stella/stella-6.7.1.ebuild74
3 files changed, 76 insertions, 0 deletions
diff --git a/games-emulation/Manifest.gz b/games-emulation/Manifest.gz
index c65bca869f39..a885223946ae 100644
--- a/games-emulation/Manifest.gz
+++ b/games-emulation/Manifest.gz
Binary files differ
diff --git a/games-emulation/stella/Manifest b/games-emulation/stella/Manifest
index 4a3e27fee389..528fb4f2fff8 100644
--- a/games-emulation/stella/Manifest
+++ b/games-emulation/stella/Manifest
@@ -1,3 +1,5 @@
DIST stella-6.7-src.tar.xz 10280224 BLAKE2B da2920384b6b254edd8f615c665ea1eef79030afffdf1b442f490f026c6f577ba4f7329531159767ba720207aeeb14388b5970bdd3e250b0db54e12d5f791396 SHA512 c20a2e9d98e1330f151e5f7d0e7cf15b2279b0d5f1175269f4084bf4964337b998118800615ae62eabf9d0f8abe0bb9cd02bddd1ee827121a49131888b4946ff
+DIST stella-6.7.1-src.tar.xz 10277788 BLAKE2B c40db17c2e91277f3ec4d6db275e9f3c197883888eff44a046fd9405437539f253628777e2230b006ace16105bb2e0d524d86d3b6d3071876d97d190b96dbcb0 SHA512 7ab3c46eb8a1243334222e69a5e6cb33eff18d43f7312f52f660b608dc21992e2c0a0bd43df3a2f1c2a0789e445b960970a866f1f0755edffe2f63ad930a0f3a
+EBUILD stella-6.7.1.ebuild 1698 BLAKE2B 45b3bb50e22da4d4046101046cd42a195fd53ae9fa217900db147dfa0174d3b234ae9ac21ea6b80fe291622968fdc5f1a01ae1045ab4598023ac1c2514d7f43c SHA512 bc2a59559831312e36d7c63c4e38b56720b6eccd2ea8390093e42b03b7185ee89bbe9d582a1496fcf75280fe7798c20021673208f48981c0c689745d62cc8e1b
EBUILD stella-6.7.ebuild 1716 BLAKE2B eb3a1367b952b21d18647e19748b5c365c3d55ee5a7497a3688d9a3f1e80442277694511d2cafe70583b7f49ff279bbf2d7fbb8916352d611ac974cc47158ccd SHA512 ad7934501414e426ba8e979341e3636675ac93504c1aeb08d25270e564e52d91d0f1da04d3841906e235209cb1915e3da818b88ac21cf3d554a1717a86bc66b7
MISC metadata.xml 387 BLAKE2B b0a5ff1a423343613aa6a17767261d65d644401f6945fb7f806363e3cfc291aa68927cc3640db016ca2d4ca1c8d830e9911f115759dd6613b53f2b30f1e6ba4b SHA512 3cdd0d8c089ef1f2635a88204abc739940ab1676699d579e0b2395cd02586d9cb7a4a70bd717724bf9e8a0fea68bccf3dc1060caab180ae6407b013138d6f269
diff --git a/games-emulation/stella/stella-6.7.1.ebuild b/games-emulation/stella/stella-6.7.1.ebuild
new file mode 100644
index 000000000000..aad9eed45418
--- /dev/null
+++ b/games-emulation/stella/stella-6.7.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs xdg
+
+DESCRIPTION="Multi-platform Atari 2600 VCS Emulator"
+HOMEPAGE="https://stella-emu.github.io/"
+SRC_URI="https://github.com/stella-emu/stella/releases/download/${PV}/${P}-src.tar.xz"
+
+LICENSE="GPL-2+ BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+joystick png zlib"
+REQUIRED_USE="png? ( zlib )"
+
+RDEPEND="
+ dev-db/sqlite:3
+ media-libs/libsdl2[joystick?,opengl,sound,video]
+ png? ( media-libs/libpng:= )
+ zlib? ( sys-libs/zlib:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i 's/pkg-config/${PKG_CONFIG}/' configure || die
+ sed -i '/CXXFLAGS+=/s/-fomit-frame-pointer//' Makefile || die
+}
+
+src_configure() {
+ tc-export CC CXX PKG_CONFIG
+
+ # not autotools-based
+ local configure=(
+ ./configure
+ --host=${CHOST}
+ --prefix="${EPREFIX}"/usr
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+ $(use_enable joystick)
+ $(use_enable png)
+ $(use_enable zlib zip)
+ ${EXTRA_ECONF}
+ )
+
+ echo ${configure[*]}
+ "${configure[@]}" || die
+}
+
+src_install() {
+ local DOCS=(
+ Announce.txt Changes.txt README-SDL.txt
+ Readme.txt docs/R77_readme.txt Todo.txt
+ )
+
+ default
+
+ rm -- "${ED}"/usr/share/doc/${PF}/html/*.txt || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if [[ ${REPLACING_VERSIONS} ]] && ver_test ${REPLACING_VERSIONS} -lt 6.7; then
+ elog "With version >=6.7, because of fixes to JSON handling, all remappings"
+ elog "will be reset to defaults. If you had custom mappings, they will need"
+ elog "to be re-entered again."
+ elog
+ elog "Furthermore, because of internal changes, all old state files are invalid."
+ fi
+}