summaryrefslogtreecommitdiff
path: root/games-emulation/stella
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-emulation/stella
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-emulation/stella')
-rw-r--r--games-emulation/stella/Manifest3
-rw-r--r--games-emulation/stella/metadata.xml11
-rw-r--r--games-emulation/stella/stella-4.7.2-r1.ebuild69
3 files changed, 83 insertions, 0 deletions
diff --git a/games-emulation/stella/Manifest b/games-emulation/stella/Manifest
new file mode 100644
index 000000000000..e504b14973d3
--- /dev/null
+++ b/games-emulation/stella/Manifest
@@ -0,0 +1,3 @@
+DIST stella-4.7.2-src.tar.xz 1715332 BLAKE2B 7b397a4e662f8db247a67ddedb314c9b11ee4e99d55768b1cd8e2587b452fab9c5d45c840bf1577833712a2c96d42985d39437d1fac16e93c35762e015ddf445 SHA512 dcfaba9b554ab08c9ba79c8e95551bc688fae4ab0ab368df11c05f3dc7c9431d32068d5dd658ec4d1aa8cb826c7205fc4f301145a149d32369833409992455e2
+EBUILD stella-4.7.2-r1.ebuild 1327 BLAKE2B 5932b462fe8a66386fe6dcd5d1d91b46c584b943b3081e47bc0e33d34e409773cbb63034fbc55609c19649d760050833062fc7813f109677423e3b7775817baa SHA512 cc81a37cc9362b1c2e07fd4f7e6216523a45659c6395da0627089e6a5a17a47eb71432a718e32aa2911fa3f4279c2b15b948f49d742ce3776942e02930cc27cd
+MISC metadata.xml 329 BLAKE2B 3ee498d6ed1bda6ccdd1e6e6a7eae732766c005ae6bf4c02b09f8f5de417d9f4c20ae925a2d7d148204f0c43a4c4ef1310cd6d925dee4beb2ede0c74ae34b636 SHA512 80e6880e6edea2eab64504d6cdf4496f94f9bfb6a4ea63da347b9fb05ca3fa999d646406e22563799d8ba40c1d3d095094ea8d86a500bb490ce2034c3ff38182
diff --git a/games-emulation/stella/metadata.xml b/games-emulation/stella/metadata.xml
new file mode 100644
index 000000000000..2fd0b9ad7a0a
--- /dev/null
+++ b/games-emulation/stella/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">stella</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-emulation/stella/stella-4.7.2-r1.ebuild b/games-emulation/stella/stella-4.7.2-r1.ebuild
new file mode 100644
index 000000000000..1412860717cd
--- /dev/null
+++ b/games-emulation/stella/stella-4.7.2-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop gnome2-utils
+
+DESCRIPTION="Stella Atari 2600 VCS Emulator"
+HOMEPAGE="http://stella.sourceforge.net/"
+SRC_URI="mirror://sourceforge/stella/${P}-src.tar.xz"
+
+LICENSE="GPL-2+ BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="joystick"
+
+RDEPEND="
+ media-libs/libsdl2[joystick?,opengl,video]
+ media-libs/libpng:0=
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/INSTALL/s/-s //' \
+ -e '/STRIP/d' \
+ -e "/icons/d" \
+ -e '/INSTALL.*DOCDIR/d' \
+ -e '/INSTALL.*\/applications/d' \
+ -e '/CXXFLAGS+=/s/-fomit-frame-pointer//' \
+ Makefile || die
+}
+
+src_configure() {
+ # not an autoconf script
+ ./configure \
+ --prefix="/usr" \
+ --bindir="/usr/bin" \
+ --docdir="/usr/share/doc/${PF}" \
+ --datadir="/usr/share" \
+ $(use_enable joystick) \
+ || die
+}
+
+src_install() {
+ local i
+
+ DOCS="Announce.txt Changes.txt Copyright.txt README-SDL.txt Readme.txt Todo.txt" \
+ default
+
+ for i in 16 22 24 32 48 64 128 ; do
+ newicon -s ${i} src/common/stella-${i}x${i}.png stella.png
+ done
+ domenu src/unix/stella.desktop
+ HTML_DOCS="docs/*" einstalldocs
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}