summaryrefslogtreecommitdiff
path: root/games-emulation/ppsspp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-18 03:03:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-18 03:03:03 +0000
commitf9f6fa91738181ebe9aca71b75d157d8b5df5335 (patch)
tree556cf671790196d83709b89133064a855f1879f2 /games-emulation/ppsspp
parent3455c0a5153ae27d7c6c16ecd35fa3dec33f3dda (diff)
gentoo auto-resync : 18:11:2024 - 03:03:03
Diffstat (limited to 'games-emulation/ppsspp')
-rw-r--r--games-emulation/ppsspp/Manifest2
-rw-r--r--games-emulation/ppsspp/ppsspp-1.18.1.ebuild90
2 files changed, 92 insertions, 0 deletions
diff --git a/games-emulation/ppsspp/Manifest b/games-emulation/ppsspp/Manifest
index 4a9a86699cc7..17817cffcbc5 100644
--- a/games-emulation/ppsspp/Manifest
+++ b/games-emulation/ppsspp/Manifest
@@ -4,5 +4,7 @@ AUX ppsspp-1.17.1-ccache-18826.patch 1110 BLAKE2B 243a9bf36da743a4e147355703976a
AUX ppsspp-1.17.1-cmake-cxx.patch 252 BLAKE2B 4d20d67c111e9992a2a728c5d294034a3385181079d00e886aa24bb60f9bf861485d11c2292dcaee2a03c4c434cf0713664a44865bc081968369c48733b0df68 SHA512 3c122bf12349b51fbda0a86ffa3f46afad6e5a766e0ff4ea4ceda2acda90a7a758e78732fb7dc20fc8a297f3eb71e0c5d2e2de69d566268a0bbfee16490c0c79
AUX ppsspp-CMakeLists-flags.patch 913 BLAKE2B 7bd5df94b51dad35325586f7ad23284436ba670a8c2218a4a6bfb28fb5a055240aeb0543fe331310a0d86d3661cbdf418689a592139ff832802ba1fabbd10fc3 SHA512 5b2ee899b2fbed7229d4abc027e2a010327be4d334e343f977319c475feaf2d180bd74d3640022d0175b11e8256035c828dd4cf03c8a5b9240c989b2d7f72fb7
DIST ppsspp-1.17.1.tar.xz 54663108 BLAKE2B 91c4964c9f334d42e090f59485e2f02ba8edb780903d2fa46e1a9cea77f6cc9e1a0605310d76445738259c0e99d5d1ca0764ef5f5565e781b482d5d5274620e5 SHA512 eaa0046f5d8e529efd8238690fa242638aa88630172abe59c4b7ffb16b1e18eeb38fcaf8e70ef76dbd2304b226d1f33e10cde709abe00fa2a5baff16c1883c31
+DIST ppsspp-1.18.1.tar.xz 54239412 BLAKE2B c0a59b63be4fdf8db1bb4c30192adc37874f1976baa0876a21722d8b86dac5a245cd5dbcea2f9ca89fef2035338c1786bbcf9b3c379d48d5a633ddd263b6e8d3 SHA512 00531109d67a35fe252b1af7d41a41ec85950f5d7c818bcdfb713d74b2b94f81f5af12e3e68d49ab0f7c7d29ccc42ca3ae7956f438964a205004293bb7e07510
EBUILD ppsspp-1.17.1-r2.ebuild 1892 BLAKE2B 64f33d77b7833286dafe99af39c8454188f1200f93d02d368547ba91d6bf69635b8366d206b6356608e0abfb2bbbb2a648a395920831e47e117bbbc9657e15b3 SHA512 4e194cf87d4d0ecfe7bc3041b2a56b57eb68f92e0cd4f07a6fde67456a74b024e89a79412a92e3513b31db887ef763df174b1524cfe1658e78b2ca3488018972
+EBUILD ppsspp-1.18.1.ebuild 1822 BLAKE2B 97e2e986eb8b51c6b6dffb418aea6616dc8282ba450e449f041504a75616b6cafea40aaf95dc7be3e61a170c8740755da4798d298b97c141aff6fa51430d7257 SHA512 9b2e10fe41f124f93ede5b25efee975dc01b713599131fc4cd5975a25900426855a4790f7ead995dd507455fca1bfabb163c776a6ac02b1f31b6703814ef4e5a
MISC metadata.xml 526 BLAKE2B 19d0378d36d2b1d81ce404a95d98488b54f4368c72a7397b6d7c9a444edec9c19d146295cfc247a75aca1e1b5d1643161a627b80ea76aa8d43189a5eb14380c2 SHA512 7a8c8a7c05acdc110422d7c38552c8106d1886a672e6bda1212ce9cba737ae5e89e6624010d5bc3149b8da7c061b10295a721c74e7377587ec52ec7be2237855
diff --git a/games-emulation/ppsspp/ppsspp-1.18.1.ebuild b/games-emulation/ppsspp/ppsspp-1.18.1.ebuild
new file mode 100644
index 000000000000..0313b1d5fe21
--- /dev/null
+++ b/games-emulation/ppsspp/ppsspp-1.18.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..13} )
+
+inherit flag-o-matic python-any-r1 xdg cmake
+
+DESCRIPTION="A PSP emulator written in C++"
+HOMEPAGE="https://www.ppsspp.org/
+ https://github.com/hrydgard/ppsspp/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/hrydgard/${PN}.git"
+else
+ SRC_URI="https://github.com/hrydgard/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0 BSD BSD-2 GPL-2 JSON MIT"
+SLOT="0"
+IUSE="discord qt5 test wayland"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-arch/snappy:=
+ app-arch/zstd:=
+ dev-libs/libzip:=
+ media-libs/glew:=
+ media-libs/libpng:=
+ media-libs/libsdl2[joystick]
+ media-video/ffmpeg:0/58.60.60
+ sys-libs/zlib:=
+ virtual/opengl
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[-gles2-only]
+ dev-qt/qtmultimedia:5[-gles2-only]
+ dev-qt/qtopengl:5[-gles2-only]
+ dev-qt/qtwidgets:5[-gles2-only]
+ )
+ !qt5? (
+ media-libs/libsdl2[X,opengl,sound,video,wayland?]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.17.1-SpvBuilder-cstdint.patch"
+ "${FILESDIR}/${PN}-1.17.1-cmake-cxx.patch"
+ "${FILESDIR}/${PN}-CMakeLists-flags.patch"
+)
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ # bug https://bugs.gentoo.org/926079
+ filter-lto
+
+ local -a mycmakeargs=(
+ -DBUILD_SHARED_LIBS="OFF"
+ -DCMAKE_SKIP_RPATH="ON"
+ -DHEADLESS="OFF"
+ -DUSE_CCACHE="OFF"
+ -DUSE_SYSTEM_FFMPEG="ON"
+ -DUSE_SYSTEM_LIBZIP="ON"
+ -DUSE_SYSTEM_SNAPPY="ON"
+ -DUSE_SYSTEM_ZSTD="ON"
+ -DUSE_DISCORD="$(usex discord)"
+ -DUSE_WAYLAND_WSI="$(usex wayland)"
+ -DUSING_QT_UI="$(usex qt5)"
+ -DUNITTEST="$(usex test)"
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ cmake_src_test -E glslang-testsuite
+}