summaryrefslogtreecommitdiff
path: root/games-emulation/pcsx2_patches
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-24 07:26:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-24 07:26:21 +0100
commite28a6e6eb5373071be3a09aa457f0488d753c80c (patch)
tree9ee566eff30cce9e22de0c44094909588e14027d /games-emulation/pcsx2_patches
parenta152c669e7ec3bb6ae13b747b985e2ece3b58b0a (diff)
gentoo auto-resync : 24:06:2023 - 07:26:21
Diffstat (limited to 'games-emulation/pcsx2_patches')
-rw-r--r--games-emulation/pcsx2_patches/Manifest4
-rw-r--r--games-emulation/pcsx2_patches/metadata.xml12
-rw-r--r--games-emulation/pcsx2_patches/pcsx2_patches-0_p20230623.ebuild54
-rw-r--r--games-emulation/pcsx2_patches/pcsx2_patches-9999.ebuild54
4 files changed, 124 insertions, 0 deletions
diff --git a/games-emulation/pcsx2_patches/Manifest b/games-emulation/pcsx2_patches/Manifest
new file mode 100644
index 000000000000..55778d6d1398
--- /dev/null
+++ b/games-emulation/pcsx2_patches/Manifest
@@ -0,0 +1,4 @@
+DIST pcsx2_patches-0_p20230623.tar.gz 598611 BLAKE2B 5a2fb1b31f9448064d7ce46c11b1dadbf1960403c082c8cee5a4c897e9c7db334a70d1f088ad18893bad89e12ef4369e2a6cba3e493fe11846848180a755b0c4 SHA512 55b7221c8f5124a44f73aa552491d1ceac796e0c34179439ba2a599891691ece19ad35b16600fa3eea1031fdcf6f5f2ee2d9da9226656ade1413b83c983383a9
+EBUILD pcsx2_patches-0_p20230623.ebuild 1514 BLAKE2B 103b8e377498dc92c988ee84a6e297db60008dc5adca4c4e72ad7c3c226e8601a1c38249526e4bfb4c4af6bde8d064a00a6626d19491fd42d39ac6a1b9c667d7 SHA512 b684dd45d2bf2bfce36131a7a2b8289de3eed8f913972dca9781099afd37401adbda59cae7b5a88f9ef9dc7c720d0cec00fe5a5b824a6053de6081e58099f7ec
+EBUILD pcsx2_patches-9999.ebuild 1474 BLAKE2B f504882547fff78ed299bff906ebbfe28cd5831b052589f49d8dcf02f5dedf63b083f188e36255f7991cd3c15b748f177486f245af4ae73fcdc3c4b435735472 SHA512 ce3e4fdb3e1cca2efbbf40166d7de36db5a60a6876dbc7266e12640140e908f0c1f02ad0407b3fafd2562ac95d7e16e1020a61b9b1b5b358a10dd0ceb5fbd3d7
+MISC metadata.xml 362 BLAKE2B 3b213785f8a28bc1e2f540e27b025d4397dec5f7885fcc8f7e3fa56186b8f023ef97de5ff7b927a8c09ad1f79baee546d08b25cf865e344197a1640470f37641 SHA512 f00b1d14ba779989c235775de6f2470e18b29f2813723eae51015681af2d2c798aeddaa9657897c83b8bcb0b124ea77b34cf6370e37104fa24a968834ea5fabb
diff --git a/games-emulation/pcsx2_patches/metadata.xml b/games-emulation/pcsx2_patches/metadata.xml
new file mode 100644
index 000000000000..dadfc4f6e874
--- /dev/null
+++ b/games-emulation/pcsx2_patches/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">PCSX2/pcsx2_patches</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-emulation/pcsx2_patches/pcsx2_patches-0_p20230623.ebuild b/games-emulation/pcsx2_patches/pcsx2_patches-0_p20230623.ebuild
new file mode 100644
index 000000000000..97b5bf34a19b
--- /dev/null
+++ b/games-emulation/pcsx2_patches/pcsx2_patches-0_p20230623.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit python-any-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/PCSX2/pcsx2_patches.git"
+else
+ HASH_PCSX2_PATCHES=665e8779d10ef046da2a46118c2d1efc02d8cb2c
+ SRC_URI="
+ https://github.com/PCSX2/pcsx2_patches/archive/${HASH_PCSX2_PATCHES}.tar.gz
+ -> ${P}.tar.gz"
+ S=${WORKDIR}/${PN}-${HASH_PCSX2_PATCHES}
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Collection of game patches for use with PCSX2 (e.g. widescreen hacks)"
+HOMEPAGE="https://github.com/PCSX2/pcsx2_patches/"
+
+# these are normally distributed by upstream with PCSX2 which is GPL-3+
+LICENSE="GPL-3+"
+SLOT="0"
+
+BDEPEND="${PYTHON_DEPS}"
+
+src_compile() {
+ # upstream uses a constantly replaced "latest" patches.zip (currently no
+ # real releases), and github's .zip archives cannot be used either due to
+ # having the patches/ subdirectory -- so we use a snapshot and repack
+ # (could use app-arch/zip, but python is more likely to skip a dependency)
+ ebegin "Creating patches.zip"
+ "${PYTHON}" - <<-EOF
+ import pathlib
+ from zipfile import ZipFile, ZIP_DEFLATED
+
+ patches = pathlib.Path("patches/")
+
+ with ZipFile("patches.zip", "w", ZIP_DEFLATED, compresslevel=9) as archive:
+ for file in patches.iterdir():
+ archive.write(file, arcname=file.name)
+ EOF
+ eend ${?} || die
+}
+
+src_install() {
+ insinto /usr/share/pcsx2/resources
+ doins patches.zip
+
+ einstalldocs
+}
diff --git a/games-emulation/pcsx2_patches/pcsx2_patches-9999.ebuild b/games-emulation/pcsx2_patches/pcsx2_patches-9999.ebuild
new file mode 100644
index 000000000000..c843add3dbc2
--- /dev/null
+++ b/games-emulation/pcsx2_patches/pcsx2_patches-9999.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit python-any-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/PCSX2/pcsx2_patches.git"
+else
+ HASH_PCSX2_PATCHES=
+ SRC_URI="
+ https://github.com/PCSX2/pcsx2_patches/archive/${HASH_PCSX2_PATCHES}.tar.gz
+ -> ${P}.tar.gz"
+ S=${WORKDIR}/${PN}-${HASH_PCSX2_PATCHES}
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Collection of game patches for use with PCSX2 (e.g. widescreen hacks)"
+HOMEPAGE="https://github.com/PCSX2/pcsx2_patches/"
+
+# these are normally distributed by upstream with PCSX2 which is GPL-3+
+LICENSE="GPL-3+"
+SLOT="0"
+
+BDEPEND="${PYTHON_DEPS}"
+
+src_compile() {
+ # upstream uses a constantly replaced "latest" patches.zip (currently no
+ # real releases), and github's .zip archives cannot be used either due to
+ # having the patches/ subdirectory -- so we use a snapshot and repack
+ # (could use app-arch/zip, but python is more likely to skip a dependency)
+ ebegin "Creating patches.zip"
+ "${PYTHON}" - <<-EOF
+ import pathlib
+ from zipfile import ZipFile, ZIP_DEFLATED
+
+ patches = pathlib.Path("patches/")
+
+ with ZipFile("patches.zip", "w", ZIP_DEFLATED, compresslevel=9) as archive:
+ for file in patches.iterdir():
+ archive.write(file, arcname=file.name)
+ EOF
+ eend ${?} || die
+}
+
+src_install() {
+ insinto /usr/share/pcsx2/resources
+ doins patches.zip
+
+ einstalldocs
+}